-   Slackware (
-   -   Wireless network problem. High unstability using Atheros AR9285 and ath9k module. (

astro11 01-03-2011 02:10 PM

Wireless network problem. High unstability using Atheros AR9285 and ath9k module.
I'm using Slackware 13.1 in my Toshiba NB200 netbook. My Wi-Fi card is an Atheros AR9285, loaded automatically by ath9k module (at least that's what lsmod shows).

I can use the internet, but my connection is very, very unstable. I have another computer (Windows 7), and two videogames using the same router and there's no problem with them. And if I try this same netbook using Windows 7 or XP, there will be no problem.

To be sure of the connection unstability, I pinged for almost 4 hours. The results:

--- ping statistics ---
5952 packets transmitted, 4105 received, 31% packet loss, time 12964276ms
rtt min/avg/max/mdev = 149.188/170.244/1743.669/67.870 ms, pipe 2

Almost 1/3 of my connection is lost, and I'm sitting next to my router, giving 98% of signal quality.

I tried to search this problem on Google, but I was unable to find any solution. If anyone here has a guess, it'll be very appreciated.

lsmod | grep ath:

ath9k                  65211  0
ath9k_common            2033  1 ath9k
mac80211              153050  2 ath9k,ath9k_common
ath9k_hw              207118  2 ath9k,ath9k_common
ath                    6820  2 ath9k,ath9k_hw
cfg80211              109656  4 ath9k,ath9k_common,mac80211,ath
led_class              2037  1 ath9k

tuxrules 01-03-2011 05:19 PM

I don't have any tips for you. Just wanted to post that I'm also using the same wifi card and ath9k module. I see the traffic stalling sometimes which may be due to key negotiation but other than that, the card works fine. No instability although my signal quality is at 62% but then my machine is connected to TV and in a living room inside the tv table cabinet.

BTW, I'm using -current and kernel

kingbeowulf 01-03-2011 05:49 PM

I have found that 802.11n connections can be a bit gimpy at times, dependent on the specific way the Atheros chipset is implemented by the notebook manufacturer. Can you test the connection as 802.11g (if not already)? Can you test via open, unencrypted connection (so might be a wpa-supplicant issue.) Check for other wifi modules that are also loaded (then blacklist them)? Is the Atheros AR9285 chip implemented via PCI, PCI-express or USB? You may wnat to poke around here:

disturbed1 01-03-2011 06:01 PM

This CR-48 also has an Atheros AR928x wireless card, and I've notice the exact same issues as you with 802.11G. With WPA2 I had to set encryption type to AES - which is better, but still not all that great. TKIP sometimes refuses to even connect. WPA works pretty well. I decided to turn off wireless encryttion, hide the SSID, filter by MAC address, and sandbox all wireless connections (isolates wireless connections from the LAN). Which works best for this device. Of course, in my area there's only 1 other wireless, so I'm somewhat technologically isolated :)

Not sure if it's a driver issue, or lack of power from this Atom N455. My rt73usb lacks throughput, but does not have connection/stability issues, neither do the Intel chipsets. Of course those wireless cards are in more powerful machines.

astro11 01-08-2011 08:01 AM

Following the suggestions some of you made, I did a few tests to locate the real problem.


Test #01
Connection: 802.11n (Channel 1)
Security: WEP
Quality Signal: 98%

--- ping statistics ---
2422 packets transmitted, 1970 received, 18% packet loss, time 4315071ms
rtt min/avg/max/mdev = 150.557/164.704/315.536/15.698 ms


Test #02
Connection: ethernet cable

--- ping statistics ---
1410 packets transmitted, 1404 received, 0% packet loss, time 2068127ms
rtt min/avg/max/mdev = 149.908/363.734/121020.745/4131.285 ms


Test #03
Connection: 802.11n (Channel 1)
Security: Unsecured
Quality Signal: 92%

--- ping statistics ---
1017 packets transmitted, 658 received, 35% packet loss, time 2117881ms
rtt min/avg/max/mdev = 165.795/178.154/342.701/14.261 ms


Test #04
Connection: 802.11g (Channel 1)
Security: Unsecured
Quality Signal: 92%

--- ping statistics ---
711 packets transmitted, 329 received, 53% packet loss, time 2427176ms
rtt min/avg/max/mdev = 165.461/178.255/302.970/14.182 ms


Test #05
Connection: 802.11n (Channel 6)
Security: WEP
Quality Signal: 92%

--- ping statistics ---
1005 packets transmitted, 818 received, 18% packet loss, time 1406440ms
rtt min/avg/max/mdev = 165.386/176.594/545.760/27.718 ms

I also pinged my router while doing these tests and had 0% packet loss.
As you can see, I tried changing the security type (WEP to Unsecured), the channel the connection is (I usually use 1, tried 6) and also from 802.11n to 802.11g, which was the worst case.

I actually don't know if there is any other wifi module loaded, I don't think so. Anyway, here is my full lsmod:

Module                  Size  Used by
snd_seq_dummy          1107  0
snd_seq_oss            25580  0
snd_seq_midi_event      4620  1 snd_seq_oss
snd_seq                42857  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          4543  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            33917  0
snd_mixer_oss          13399  1 snd_pcm_oss
ipv6                  229909  20
pcmcia                27872  0
pcmcia_core            25659  1 pcmcia
cpufreq_ondemand        6917  2
speedstep_lib          2683  0
acpi_cpufreq            5705  1
freq_table              2027  2 cpufreq_ondemand,acpi_cpufreq
lp                      7161  0
ppdev                  5103  0
parport_pc            18027  0
parport                25487  3 lp,ppdev,parport_pc
fuse                  52401  1
snd_hda_codec_realtek  185089  1
ath9k                  65211  0
ath9k_common            2033  1 ath9k
mac80211              153050  2 ath9k,ath9k_common
snd_hda_intel          18936  0
i915                  263263  2
snd_hda_codec          57091  2 snd_hda_codec_realtek,snd_hda_intel
ath9k_hw              207118  2 ath9k,ath9k_common
joydev                  7989  0
drm_kms_helper        23751  1 i915
snd_hwdep              5046  1 snd_hda_codec
drm                  133002  3 i915,drm_kms_helper
uvcvideo              54940  0
snd_pcm                57736  3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
rtc_cmos                7838  0
ath                    6820  2 ath9k,ath9k_hw
intel_agp              22699  1
rtc_core              12050  1 rtc_cmos
usbhid                33016  0
videodev              32975  1 uvcvideo
snd_timer              15699  2 snd_seq,snd_pcm
cfg80211              109656  4 ath9k,ath9k_common,mac80211,ath
i2c_algo_bit            4355  1 i915
snd                    43107  11 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
v4l1_compat            13004  2 uvcvideo,videodev
r8169                  31285  0
i2c_i801                7194  0
thermal                10194  0
processor              26515  3 acpi_cpufreq
rtc_lib                1522  1 rtc_core
battery                7944  0
video                  15937  1 i915
soundcore              4815  1 snd
psmouse                40750  0
agpgart                23773  2 drm,intel_agp
led_class              2037  1 ath9k
ac                      2423  0
output                  1444  1 video
rfkill                12812  2 cfg80211
mii                    3322  1 r8169
thermal_sys            12086  3 thermal,processor,video
snd_page_alloc          5849  2 snd_hda_intel,snd_pcm
hid                    61027  1 usbhid
serio_raw              3754  0
hwmon                  1085  1 thermal_sys
evdev                  6939  15
button                  3934  1 i915
i2c_core              15279  6 i915,drm_kms_helper,drm,videodev,i2c_algo_bit,i2c_i801
sg                    21214  0

I can try connecting to the same wireless connection using an USB wifi dongle, but until I have it in hands this is the info I can give to you.

Any guesses?

forker 02-07-2011 07:18 PM

I have EXACTLY the same problem with AR9285.
Ethernet connection works fine and a wifi usb stick (RTL8187b) also works without any losses.

The problem appears to be on the device specific layer.

Did you get that fixed?

monstermudder78 02-26-2011 02:21 AM

Not sure if you all have figured this out, but what has seemed to cure my problem (Atheros AR928X card, unstable connection, 30-60% packet loss) was to downgrade from kernel 26-2.6.37-5-ARCH to kernel26- Not sure what kernel you guys are using so YMMV.

forker 02-27-2011 07:20 AM

I'll give it a try
Thank you, monstermudder78

Though I tried Arch LTS kernel, which is 2.6.32 and it didn't help. It seems to me that there was some evil patch that was applied to both streams recently.

mcnalu 02-27-2011 08:23 AM

Me too.

I've had problems with the ath9k module under slackware current on my new laptop (packbard dot u, rebrand of acer). lspci says it has an AR928X. It's fine for most things, but I noticed that transferring large files failed sometimes and I traced the problem back to the wireless network dropping (say once or twice per hour).

A quick search revealed mailing lists of people reporting that the ath9k driver has such problems going back for months/years - unfortunately I didn't see much progress in fixing them.

bassplayer69 03-28-2012 12:08 PM

I've been having the same issues, but with the ath5k (TP-Link TL-WN350G PCI connector) driver. I'm going to try the kernel and perhaps build the and 2.6.39-rc4 (the config files are shipped with 13.37) to see if this issue has improved. The funny thing about this is that I install windows 7 on this machines and I get 0% lost packets, but with Slackware 13.37 I get anywhere between 30% ~ 56% lost packets.

Rasta420 03-28-2012 12:38 PM

have you tried the drivers from

EDIT: I had to use the firmware from here for the ALFA AWUS036NHA USB card with a 9dBI antenna to get it to work. The ath9k driver was fine but needed the firmware module to get it working right.


wagscat123 01-18-2014 09:07 PM

I know this thread is old, but I have the same AR9285 wireless network adapter with the same instability and was wondering which solution below worked. I can't find anything that someone said worked. This issue seems to transcend distros, as it is an issue in both my openSUSE 13.1 install and my LinuxMint 13 install.

mcnalu 01-19-2014 02:43 AM

I'm running slackware 14.0 on the laptop I mentioned earlier in this thread and have no problems with the wifi now. So updating to a newer kernel or module may help.

wagscat123 01-20-2014 10:00 AM

I was hoping that upgrading my Os and starting clean would clear things up - but it has been a recurring (but improving) issue since openSUSE 12.1 (kernel 3.1) and it still is an issue in 13.1 (3.11 now) and Mint 13. I'll look into the hardware if it is not an issue for you with the exact same hardware.

Richard Cranium 01-20-2014 10:40 AM


Originally Posted by wagscat123 (Post 5100523)
I know this thread is old, but I have the same AR9285 wireless network adapter with the same instability and was wondering which solution below worked. I can't find anything that someone said worked. This issue seems to transcend distros, as it is an issue in both my openSUSE 13.1 install and my LinuxMint 13 install.

Bring an old thread back to life and you don't even use Slackware? There are perfectly fine Mint and SUSE forums on LQ. If those are the distributions that you use (nothing wrong with that), perhaps you should raise your questions over in those forums.

All times are GMT -5. The time now is 06:17 AM.