-   Slackware (
-   -   wireless/madwifi trouble on Slackware 12 - unable to get dhcp response (

jeffmccoy 07-07-2007 07:02 AM

wireless/madwifi trouble on Slackware 12 - unable to get dhcp response
I've just done a fresh install of Slackware 12, and I'm having trouble getting my wireless connection to work.

It's a Atheros card (a pci card in a desktop computer). I have a dlink router and a linksys wireless access point. I've downloaded the madwifi code. It compiles fine, and I can bring up the ath0 interface, do iwlist and scan for access points, set the ESSID and key, but when I try to use dhcp, it times out with "no DHCP offers received".

I'm using a short script to keep things simple: bring down eth0 (just in case it gets in the way), bring up ath0, set the essid, set the key, then use dhcpcd. Each step works fine except for DHCP. I can see ath0, I can assign the essid, I can even scan for access points and see everything. But I when I do "dhcpcd ath0" or "dhclient ath0", it eventually times out, saying it didn't receive any offers.

Things I've tried so far:

in /var/log/debug, I noticed an error message that said no ipv6 routers were present. In some other posts, there were errors where the system was looking for ipv6 and wouldn't accept anything else. I've blacklisted the ipv6 module and rebooted, it's no longer there, but the problem still persists.

I've tried different versions of madwifi - latest stable code, latest snapshot, and getting the code from subversion. It didn't seem to help.

For kernel, I was using the "huge" smp kernel, also tried the generic kernel to see if that would make a difference. I looked on the madwifi site and didn't see anything suggesting that current madwifi code isn't compatible with, which is the kernel I'm using (the one that shipped with Slackware 12).

I've tried upgrading to latest version of dhcpcd and also downloaded and compiled the latest version of dhclient. In both cases it times out, saying that no offers were received. The log files didn't have anything more specific than that; I did turn on logging/debgging for dhcpcd.

Also, I've tried a wired connection, and that works fine - dhcpcd or dhclient will connect with no problems.

The wireless card works in other linux distos, currently ubuntu and pclinuxos. I'm using the same simple script in ubuntu without problems. Also, I remember this working in earlier versions of Slackware.

If anyone has any ideas, let me know, any help or advice would be much appreciated.


tdaley 07-27-2007 10:29 AM

delay after setting essid
I was having problems with wireless setup on my new Slackware 12 install. The setup worked if I did it on the command line but the rc.wireless script failed. I found that I needed to add a "sleep 1" in rc.wireless after the essid gets set (in two places in the script).

I am not sure of the underlying cause, but it works for me.

I hope this helps.

All times are GMT -5. The time now is 08:44 PM.