-   Slackware (
-   -   Wireless issue with RTL8191SEvA Wireless LAN Controller (

clod89 11-09-2012 12:31 PM

Wireless issue with RTL8191SEvA Wireless LAN Controller
I'm using slackware 14 and at random times my wireless connection stops working, it seems to be an issue with dns but I can't even load my router webpage.

During the "blackouts" the card seems to be still associated with the AP (or at least networkmanager says so). If I try to disconnect and reconnect it always fails to get an ip address.

Only if I rmmod rtl8192se and modprobe it again it works. I thought it could be an ipv6 issue and I tried everything from this post "" but I can't disable the ipv6 module.

The following link is my dmesg of a disconnection and a reconnection:

Thanks in advance for any help.


markush 11-09-2012 04:25 PM

You should distinguish between a DNS issue and an issue with the connection to the AP.

If you have a DNS issue, you can still connect to your router via it's IP-adress.

If you have an issue with the connection (or authentication respectively) to your IP, you can simpliy use the iwconfig command which shows you if you're connected or not.

What to do: next time when you can't access the internet, try at first to ping your router by it's ip-adress and name. If pining the ip-adress works and pinging the name doesn't, you have a DNS issue.
Then execute iwconfig (as root) and check if you're connected to the AP. Then post here what you've found out.


clod89 11-09-2012 05:00 PM

Sorry I haven't been very clean in my first post, at first I thought it was a dns issue but then upon further testing it seems to be a problem with the AP (probably related to ipv6). I have tried pinging the router but it failed, and iwconfig shows wlan0 as still connected to the AP. If I then try to reconnect it always fails to get an address untill I rmmod and modprobe rtl8192se, then it works as it should.


markush 11-09-2012 05:02 PM

Do you really use ipv6?

What exactly do you do in order to reconnect and connect?


clod89 11-09-2012 05:22 PM

I don't use ipv6 even if ifconfig shows inet6 as configured, and in dmesg there's this "wlan0: no IPv6 routers present", ipv6 could not be related to it but it's my best guess as of now since with a custom kernel 3.2.29 made on another distro everything worked fine.

markush 11-09-2012 05:44 PM

I've disabled ipv6 in my kernel. I am not sure, but as far as I know it can be a problem when your Linuxcomputer tries to use ipv6 but it isn't possible.


clod89 11-09-2012 05:50 PM

The werid thing is that it happens after a while (could be hours could be minutes) that the connection has been enstablished.

markush 11-09-2012 05:58 PM

Do you have other computers in the network? or Windows running on the same computer? and doesn't the wireless break down with other computers?

If there aren't any other computers, you could boot a live-CD (for example porteus which is Slackware-based) and try out if it works.


clod89 11-09-2012 06:01 PM

This pc dual boots slackware and scientific linux (which does not have this issue but has also completly different kernel and package versions). I've used slackware on my laptop too without issues (I don't have right know though it's out for repairs. The other computers on the network all run linux and have no issues with connecting (that I know of at least).

markush 11-09-2012 06:07 PM

Well, do you use networkmanager also with the other computers?

I have also wireless on my laptop, but don't use networkmanager. I use only wpa_supplicant. I would recommend that you connect with wpa_supplicant only and check if it then works.

You would have to make /etc/rc.d/rc.networkmanager not-executable (chmod 644) and then edit your /etc/wpa_supplicant.conf

In your /etc/rc.d/rc.inet1.conf you'll have to configure for wlan (probably wlan0) and wpa_supplicant, there is an explanation anywhere in the internet on the site of AlienBob.

Good luck, I'll have to go to bed now, it's 1 o'clock in the morning here ;)


H_TeXMeX_H 11-10-2012 02:29 AM

I would try a newer kernel (3.4.x or higher) and the latest firmware.

All times are GMT -5. The time now is 10:46 AM.