LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 07-14-2008, 11:58 PM   #1
kiyoura
LQ Newbie
 
Registered: Jul 2008
Posts: 9

Rep: Reputation: 0
Wireless internet on Slackware 12.1


Hello,

I am relatively new to Slackware, but not new to Linux. For the last two days I've been trying to set up my wireless internet but with no success. My current wireless card is (command: lspci)

07:00.0 Network controller: Atheros Communications Inc. AR5416 802.11abgn Wireless PCI Adapter (rev 01)

I have tried Ndiswrapper AND Madwifi, switching back and forth between the two but settled with Madwifi considering my card is Atheros. When i set up Ndiswrapper, I would get a wlan0 interface and could set the access point information but would get no connection. Madwifi, not even the ath0 OR wlan0 interface will start. I've researched and found a lot of methods and information but nothing will work...

Here's some more information:

(command: iwconfig)
lo no wireless extensions.

eth0 no wireless extensions.

(command: lsmod | grep ath)
ath_pci 94752 0
wlan 194032 1 ath_pci
ath_hal 193488 1 ath_pci


If any other information is needed, ask and i will reply with information required.

Thank you in advanced.
 
Old 07-15-2008, 01:35 AM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Check out Alien Bob's wiki for the proper methods in Slackware.

I'm not sure your chipset is supported by madwifi ... check more, and maybe
it's supported by the ath5k driver in the latest stable kernels.
 
Old 07-15-2008, 08:55 AM   #3
storkus
Member
 
Registered: Jun 2008
Posts: 296

Rep: Reputation: 45
Also bear in mind that, particularly with Atheros chipsets, lspci lies.
I have a laptop with an AR2425 AKA AR5007EG AKA AR5BXB63, which lspci
reports back as an AR5006EG--incorrect. This chipset is only supported in
Sam Leffler's new HAL, which is now included as a separate branch in the
MadWIFI snapshot/SVN directories (the new HAL is 0.10.5.6).

Note that, as of this writing, snapshot containing the new HAL won't
compile with kernel 2.6.26 because of a parameter passing change. I've
written a ticket that they forgot to include the patch for 2.6.26 in that
branch and I'm hoping it'll show up today.

Mike

P.S. The "ath_info" utility should tell you the truth about what you have.
Again, this isn't part of Slackware AFAIK.

UPDATE: The the patch has been included as of 7-16-08 and is working for me on SlamD64 and kernel 2.6.26.

Last edited by storkus; 07-18-2008 at 05:32 AM.
 
Old 07-16-2008, 05:37 PM   #4
p|ush
LQ Newbie
 
Registered: Jul 2008
Distribution: slackware
Posts: 1

Rep: Reputation: 0
i am a linux n00b and had the same problem. I beat my head on the wall untill one day i read something on some forum (wish i could site the source, because it's not entirely all my own brainchild). i believe the /etc/rc.d/rc.inet1.conf file contains the wireless settings for start up. On my laptop the default was setup for the the rj-45 plug not my wireless card. eth0 i believe was setup by default. i don't have my laptop with me so this may be a little rough. i disabled the dhcp option(and maybe some other options) under eth0. then enable it for wlan0 (and maybe some other options). I played with the options for a bit before I finally was able to connect. Hope this helps, or at least points you in the right direction.

Last edited by p|ush; 07-16-2008 at 11:33 PM. Reason: wrong file listed for wireless settings
 
Old 07-18-2008, 05:38 AM   #5
storkus
Member
 
Registered: Jun 2008
Posts: 296

Rep: Reputation: 45
Ah yes, the rc.inet1 mess. I mostly love Slackware, but when it comes to wireless rc.inet1 and rc.wireless is a huge mess--they really need to clean it up! One of these days, I'll probably do it myself and submit the changes to Pat and Fred.

My own technique is to disable rc.wireless and change the first wireless settings in rc.inet1.conf while making sure the 2nd is all commented out. If you're running original MadWiFi like I am, make sure to change the interface name from "wlan0" to "ath0" as well. After this, it seems to work just fine. I still haven't figured out if kmod is loading "ath_pci" or a script is doing it (haven't looked, bigger fish to fry like getting all of ACPI working right), but once installed it gets loaded automagically during boot and you only have to "modprobe ath_pci" right after you install it fresh.

Mike
 
Old 07-18-2008, 06:33 AM   #6
carlitoco
Member
 
Registered: Jan 2008
Location: Berlin
Distribution: Slackware / Arch
Posts: 130

Rep: Reputation: 15
I have also an atheros w-lan card
bash-3.1$ lsmod | grep ath
ath_rate_sample 15872 1
ath_pci 94624 0
wlan 193904 5 wlan_wep,wlan_scan_sta,ath_rate_sample,ath_pci
ath_hal 193488 3 ath_rate_sample,ath_pci

It works with slack-12.0 &12.1 but just with wep crypt.

1.install madwifi with $ make
# make install
2.reboot
3.#$ cat scripts/haselforster-connect.sh
#!/bin/sh
rm /etc/dhcpc/dhcpcd-ath0.pid
ifconfig ath0 down
ifconfig ath0 up
iwconfig ath0 essid dd-wrt
iwconfig ath0 channel 11
iwconfig ath0 key 0123456789
dhcpcd ath0

I massively dont know how to set it with WPA but can anbody helps me ?

greetings carlitoco

Last edited by carlitoco; 07-18-2008 at 06:37 AM.
 
Old 07-18-2008, 06:40 AM   #7
tomtomjkw
Member
 
Registered: Jan 2008
Distribution: Slackware64-current
Posts: 125

Rep: Reputation: 31
carlitoco ->

To set WPA encryption, use wpa_supplicant.
 
Old 07-18-2008, 08:49 AM   #8
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
You guys should read the previous posts. And fwiw, with Slackware the
/etc/rc.d/rc.inet1.conf file is all you need to touch. And it's NOT a mess,
unless someone who can't read the massively commented file messes
it up. I've setup quite a number of boxen with wireless, and it's never
been a problem.

And storkus, Fred (assuming you mean Fred Emmott) has nothing to do with
those scripts. Not even in his own distro ... he copies them from Slackware.
The one writing the scripts is Alien Bob, and Pat V. finalizes them.
 
Old 07-18-2008, 12:33 PM   #9
kiyoura
LQ Newbie
 
Registered: Jul 2008
Posts: 9

Original Poster
Rep: Reputation: 0
fixed

For anyone who cares, this fixed my problem.

Code:
wget http://snapshots.madwifi.org/special/madwifi-nr-r3366+ar5007.tar.gz
tar -zxvf madwifi-nr-r3366+ar5007.tar.gz
cd madwifi-nr-r3366+ar5007
make
checkinstall --fstrans=no -S -y
installpkg madwifi-nr-r3366+ar5007-i386-1.tgz
cd .. 
rm -rf  madwifi-nr-r3366+ar5007*
I believe that some some cards or systems require this..."special" madwifi version. Regardless anyone with problems try this; may have to set up checkinstall in order to make the packages. BUT IT WORKED!
 
Old 07-18-2008, 12:48 PM   #10
Oliver_H
Member
 
Registered: May 2008
Distribution: Slackware, FreeBSD
Posts: 47

Rep: Reputation: 16
And one hint, don't even try ath5k in kernel (I'm using 2.6.26 at the moment in 12.1), it's in my opinion yet an alpha version of a driver. With madwifi you'll have less pain ;-)
 
Old 07-21-2008, 02:24 AM   #11
carlitoco
Member
 
Registered: Jan 2008
Location: Berlin
Distribution: Slackware / Arch
Posts: 130

Rep: Reputation: 15
Quote:
Originally Posted by tomtomjkw View Post
carlitoco ->

To set WPA encryption, use wpa_supplicant.
I dont know why but it dosnt work with wpa did any body know how to do it, or a tutorial link?

thx
 
Old 07-21-2008, 03:13 AM   #12
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
carlitoco,

In post #2 I referred the OP to Alien Bob's wiki. This is the specific
page for Madwifi and WPA encryption.
 
Old 07-21-2008, 05:29 AM   #13
wheelsg
Member
 
Registered: Feb 2004
Location: Westchester, NY
Distribution: slackware
Posts: 56

Rep: Reputation: 15
I have had _some_ success with madwifi and wpa_supplicant, and I'm using a Linksys WPC 100 (Atheros 5416 chipset). It is correct that you'll need the madwifi-trunk-current tarball. There are links on the wiki to Alien Bob's build scripts, and he's tweaked the one for the 'current' branch of madwifi. Build the madwifi, then removepkg wpa_supplicant and reinstall it. Should work, and I've been able to use WPA2 and connect. There _are_ issues with rc.inet1, but mine have involved an on-board ethernet port and whether it was connected or not. But more on that in a later post.
 
Old 07-22-2008, 02:56 AM   #14
carlitoco
Member
 
Registered: Jan 2008
Location: Berlin
Distribution: Slackware / Arch
Posts: 130

Rep: Reputation: 15
Thanks at first, I will try it.

And sorry for my bad english in the last post


greetings
 
Old 07-23-2008, 05:48 PM   #15
resaguk
Member
 
Registered: Aug 2004
Location: Leamington Spa, UK
Distribution: Slackware
Posts: 66

Rep: Reputation: 15
Quote:
Originally Posted by Bruce Hill View Post
Check out Alien Bob's wiki for the proper methods in Slackware.
I did that in Slackware 12.0 and got my wireless card running just fine; however, since I installed 12.1 (first by upgrade and then when I couldn't get wireless up and running by fresh install) I managed to break something and I'm just not sure what I broke!

Relevant bits of config:

Code:
# lspci -v
{snip}
04:02.0 Ethernet controller: Belkin Unknown device 700f (rev 20)
	Subsystem: Belkin Unknown device 700f
	Flags: bus master, medium devsel, latency 64, IRQ 21
	I/O ports at cc00 [size=256]
	Memory at dfaffe00 (32-bit, non-prefetchable) [size=512]
	Capabilities: [50] Power Management version 2
	Kernel driver in use: ndiswrapper
Ok, so that is my wireless card, for which I had the windows driver working under 12.0 with ndiswrapper, as you can see above, lspci is reporting ndiswrapper is in use.

Code:
# ndiswrapper -l
blkwgdv7 : driver installed
        device (1799:700F) present
And there is ndiswrapper reporting that everything is tickety-boo.

Code:
# cat /etc/rc.d/rc.inet1.conf
# /etc/rc.d/rc.inet1.conf
#
# This file contains the configuration settings for network interfaces.
# If USE_DHCP[interface] is set to "yes", this overrides any other settings.
# If you don't have an interface, leave the settings null ("").

# You can configure network interfaces other than eth0,eth1... by setting
# IFNAME[interface] to the interface's name. If IFNAME[interface] is unset
# or empty, it is assumed you're configuring eth<interface>.

# Several other parameters are available, the end of this file contains a
# comprehensive set of examples.

# =============================================================================

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Default gateway IP address:
GATEWAY=""

# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"

## Example config information for wlan0.  Uncomment the lines you need and fill
## in your info.  (You may not need all of these for your wireless network)
IFNAME[3]="wlan0"
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]="yes"
DHCP_HOSTNAME[3]="{removed}"
WLAN_ESSID[3]="{removed}"
WLAN_MODE[3]="Managed"
WLAN_WPA[3]="wpa_supplicant"
WLAN_WPADRIVER[3]="wext"
The above is my 12.0 config file and from what I can work out should carry straight over to 12.1 - to make sure there was no craziness going on between rc.inet1 and rc.wireless I have done "# chmod -x rc.wireless"

Code:
# cat /etc/wpa_supplicant.conf
# See /usr/doc/wpa_supplicant-0.5.10/wpa_supplicant.conf.sample
# for many more options that you can use in this file.

# This line enables the use of wpa_cli which is used by rc.wireless
# if possible (to check for successful association)
ctrl_interface=/var/run/wpa_supplicant
# By default, only root (group 0) may use wpa_cli
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1

# WPA protected network, supply your own ESSID and WPAPSK here:
network={
  scan_ssid=0
  ssid="{removed}"
  proto=WPA
  key_mgmt=WPA-PSK
  pairwise=CCMP TKIP
  group=CCMP TKIP WEP104 WEP40
  psk={removed}
}

# Plaintext connection (no WPA, no IEEE 802.1X),
# nice for hotel/airport types of WiFi network.
network={
  key_mgmt=NONE
  priority=0
}
As with rc.inet1.conf this is the same as I used for 12.0, I can see nothing that means it should fail on 12.1, so why is it I get this:

Code:
# iwconfig wlan0
wlan0     IEEE 802.11g  ESSID:off/any  
          Mode:Auto  Frequency:2.412 GHz  Access Point: Not-Associated   
          Bit Rate:54 Mb/s   Tx-Power:46 dBm   Sensitivity=0/3  
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
?

If anyone can please tell me what I've forgotten/missed out it'd be much appreciated!

Oh, yes, my kernel is 2.6.24.5-smp (generic).
 
  


Reply

Tags
atheros, madwifi, slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware blocking internet or settings incorrect for Java Wireless Toolkit? lifeforce4 Slackware 0 02-15-2008 10:41 AM
Wireless card..Wireless router.. Slackware 10.2 ..Problems with Internet Connection. Storm Bringer Linux - Wireless Networking 4 03-23-2006 06:25 AM
How do I automatically bring up wireless internet conneciton in Slackware 10.1? n00bified Linux - Hardware 1 12-28-2005 01:17 PM
Slackware 9.1 - Wireless Internet problem jelitegamer Linux - Software 3 09-01-2004 05:39 PM


All times are GMT -5. The time now is 07:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration