LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-16-2007, 10:28 PM   #1
pxumsgdxpcvjm
Member
 
Registered: Aug 2005
Posts: 235

Rep: Reputation: 30
Wireless DHCP Issue


Why doesn't Slackware obey the settings in /etc/rc.d/rc.inet1.conf? For some reason, to get my Wireless network working, I need to run "hostname -h Sen" every time my computer starts. DHCP starts fine when using an eth* connection. Why is this turned off by default? And can I turn this on?

Thanks to any replies.
 
Old 01-16-2007, 11:22 PM   #2
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,012

Rep: Reputation: 115Reputation: 115
???
Anyway, the hostname that the router sees is defined by DHCP_HOSTNAME[n]. The hostname that comes up on the console is controlled by /etc/HOSTNAME and /etc/hosts.
 
Old 01-16-2007, 11:30 PM   #3
pxumsgdxpcvjm
Member
 
Registered: Aug 2005
Posts: 235

Original Poster
Rep: Reputation: 30
Sorry, I should make made it more clear. This isn't about the hostname. The default install of Slackware 11.0 makes it so that dhcpcd is ran (if requested) for eth0 connections, but not for ath0 connections, even if it has been set. Why is this?
 
Old 01-17-2007, 12:51 AM   #4
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,012

Rep: Reputation: 115Reputation: 115
You need to set IFNAME[n] to ath0
 
Old 01-17-2007, 02:40 AM   #5
pxumsgdxpcvjm
Member
 
Registered: Aug 2005
Posts: 235

Original Poster
Rep: Reputation: 30
Yea, I've done that. To my knowledge, this doesn't work with the default scripts.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
perplexing issue with DHCP on wireless router rshields9093 Linux - Wireless Networking 2 10-13-2006 09:01 PM
Backtrack / DHCP Issue bigdogg Slackware 7 03-30-2006 10:48 AM
DHCP Handout Issue KevinGuy Linux - Networking 1 06-17-2005 04:17 PM
Strange Wireless DHCP issue Fozzle Linux - Wireless Networking 3 08-10-2004 01:14 PM
Dhcp Issue real_shock Linux - Networking 3 07-16-2004 11:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration