LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-28-2006, 02:37 AM   #1
mikedeatworld
Member
 
Registered: Nov 2003
Location: Farmington Michigan
Distribution: UBUNTU - Slackware - SuSE 9.1 - Knoppix - Fedora
Posts: 828

Rep: Reputation: 30
Wireless, and dns will not resolve????


Hi all-

I have happily, recomplied my Slackware kernel! It is 3:32 a.m. and I'm so happy to be working on my box, and not sleeping, for some weird reason. But I digress.

Like I said, I have my kernel recomplied, and all of the wireless drivers, modules, etc have been loaded.

I am able to statically set my IP address, and DNS entries, for ath0. and uninstall iptables just as a troubleshooting step.

I am able to ping, 192.168.1.1, and I can browse the routers config page, via my wireless connection. Neat.

However, even if I enter my nameserver, via netconfig, /etc/resolv.conf, etc; nothing will resolve correctly, and I can't get out to the Internet(s) (joke).

Obviously, my ISP DNS is working (I can get to LQ from my windows machine), I'm on the LQ forums. Any ideas why I may not be able to resolve via DNS?

My /etc/resolv.conf looks like:

nameserver 127.0.0.1
nameserver 64.xx.xx.xx
nameserver 64.xx.xx.xx



Any ideas and thanks!

Mike

Last edited by mikedeatworld; 11-28-2006 at 02:59 AM.
 
Old 11-28-2006, 02:51 AM   #2
mikedeatworld
Member
 
Registered: Nov 2003
Location: Farmington Michigan
Distribution: UBUNTU - Slackware - SuSE 9.1 - Knoppix - Fedora
Posts: 828

Original Poster
Rep: Reputation: 30
tried dhclient ath0 -

didn't help.

I'm reading most of the post I see on LQ, if any of you can help, that would be awesome!
 
Old 11-28-2006, 02:55 AM   #3
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
can you clarify what's not working? if your ISP DNS is working as you say, then what's the problem?
 
Old 11-28-2006, 02:57 AM   #4
mikedeatworld
Member
 
Registered: Nov 2003
Location: Farmington Michigan
Distribution: UBUNTU - Slackware - SuSE 9.1 - Knoppix - Fedora
Posts: 828

Original Poster
Rep: Reputation: 30
On my Windows box, I can route just fine. On my Slackware box, I can't.

I just checked my /etc/host.conf

it looks like

order host, bind
multi on

Is that correct? Just to clarify, All other machines, but my slackware box, are routing correctly.

Okay, from the slackware box, I logged into my router and updated my DHCP clients table. For some reason, my slackware machine is NOT showing up in the routers client table? Weird? But I AM able to get to the routers config page from my slackware machine.



1 traceroute to 192.168.1.105 (192.168.1.105) ,30 hops max,40 byte packet
2 192.168.1.105 (192.168.1.105) 10. 0 ms 0. 0 ms 10. 0 ms
Traceroute Complete.


PING 192.168.1.105 ( 192.168.1.105 ) : 56 data bytes
64 bytes from 192.168.1.105: icmp_seq=0, ttl=64 times=0. ms
64 bytes from 192.168.1.105: icmp_seq=1, ttl=64 times=0. ms
Request timed out. - it is wireless remember
64 bytes from 192.168.1.105: icmp_seq=3, ttl=64 times=0. ms
64 bytes from 192.168.1.105: icmp_seq=4, ttl=64 times=0. ms
--- 192.168.1.105 ping statistics ---
packets transmitted = 5 , packets received = 4 packet loss = 20%
round-trip min/avg/max = 0/0/0

Last edited by mikedeatworld; 11-28-2006 at 03:12 AM.
 
Old 11-28-2006, 03:09 AM   #5
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
I'm not certain what you are saying doesn't work. One thing you haven't posted is your routes. What is the output of the /sbin/route command? Do you have a default route set? Can you ping other hosts or one of the ISP nameserver addresses. You said "my nameserver". Are you running your own nameserver?
 
Old 11-28-2006, 03:16 AM   #6
mikedeatworld
Member
 
Registered: Nov 2003
Location: Farmington Michigan
Distribution: UBUNTU - Slackware - SuSE 9.1 - Knoppix - Fedora
Posts: 828

Original Poster
Rep: Reputation: 30
Thanks for the reply jschiwal

To clarify more, what my issue is.

I Can't route to the Internet, via URL (i.e. google.com).

I Can, ping my router, other machines on the network, and get a reply from them. I Can get to my router via the wireless connection that I am working from.


But I am unable to get to the Internet.

About the term nameserver - that is my settings for my ISP's DNS.


Does that help?

Thanks again!!!

Mike

Last edited by mikedeatworld; 11-28-2006 at 03:20 AM.
 
Old 11-28-2006, 03:20 AM   #7
mikedeatworld
Member
 
Registered: Nov 2003
Location: Farmington Michigan
Distribution: UBUNTU - Slackware - SuSE 9.1 - Knoppix - Fedora
Posts: 828

Original Poster
Rep: Reputation: 30
route

Code:
Destination  Gateway   Genmask        Flags Meteric  Ref  Use Iface
localnet     *         255.255.255.0  U     0        0    0   ath0
loopback     *         255.0.0.0      U     0        0    0   lo
from /sbin/route

I must have used nameserver wrong.

Last edited by mikedeatworld; 11-28-2006 at 03:21 AM.
 
Old 11-28-2006, 03:28 AM   #8
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,524

Rep: Reputation: Disabled
With a static IP address, you need to configure your default gateway. The netconfig command explicitly asks you for one, but your "route" output shows that none has been configured.

By a dhcp client such as dhcpcd (on Slackware we do not use dhclient by default) the gateway is automatically set.

Eric
 
Old 11-28-2006, 03:31 AM   #9
mikedeatworld
Member
 
Registered: Nov 2003
Location: Farmington Michigan
Distribution: UBUNTU - Slackware - SuSE 9.1 - Knoppix - Fedora
Posts: 828

Original Poster
Rep: Reputation: 30
Alien Bob-

I used the netconfig command, and entered in one. I have used the netconfig all along and setup each entry it asked for.

Why would my route table, not be be updated with the gatway I entered? Is there another way to configure the gateway?

Last edited by mikedeatworld; 11-28-2006 at 03:35 AM.
 
Old 11-28-2006, 03:45 AM   #10
mikedeatworld
Member
 
Registered: Nov 2003
Location: Farmington Michigan
Distribution: UBUNTU - Slackware - SuSE 9.1 - Knoppix - Fedora
Posts: 828

Original Poster
Rep: Reputation: 30
I just looked in /etc/rc.d

vi rc.inet1.conf

and noticed my wireless card was not in this file?

any reason? i did add this nic - ath0, and saw where the gateway was set to 192.168.1.1. but this did not help
 
Old 11-28-2006, 03:46 AM   #11
Youri
Member
 
Registered: Oct 2004
Distribution: slamd64-current, slackware-current, clfs 6.1, arch-current, ubuntu dapper
Posts: 144

Rep: Reputation: 15
had the same problem the trick for me was to put te following in your resolv.conf:
Code:
nameserver (ip-of-router)(in your case its 192.168.1.1 i think?)
search (domain-or-ip-of-isp)
cuz if you can browse your router config pages wireless is obviously working.

Last edited by Youri; 11-28-2006 at 03:48 AM.
 
Old 11-28-2006, 06:47 AM   #12
mikedeatworld
Member
 
Registered: Nov 2003
Location: Farmington Michigan
Distribution: UBUNTU - Slackware - SuSE 9.1 - Knoppix - Fedora
Posts: 828

Original Poster
Rep: Reputation: 30
Thanks, Youri

But as I suspected, this did not work.

Any other ideas?

Mike
 
Old 11-28-2006, 07:46 AM   #13
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,524

Rep: Reputation: Disabled
PLease post contents of:
/etc/rc.d/rc.inet1.conf stripped of content (use the command cat /etc/rc.d/rc.inet1.conf | grep -v "^#" | grep -v "^$" to produce that) /etc/resolv.conf as you have them currently.
The netconfig command can not configure any other interface but eth0. For your ath0 interface you will have to do some manual work.
Did you require any wireless configuration (ESSID, channel, WEP/WPA key)?

Eric
 
Old 11-28-2006, 10:20 AM   #14
Youri
Member
 
Registered: Oct 2004
Distribution: slamd64-current, slackware-current, clfs 6.1, arch-current, ubuntu dapper
Posts: 144

Rep: Reputation: 15
what is the interface of your wireless again?
 
Old 11-28-2006, 02:17 PM   #15
mikedeatworld
Member
 
Registered: Nov 2003
Location: Farmington Michigan
Distribution: UBUNTU - Slackware - SuSE 9.1 - Knoppix - Fedora
Posts: 828

Original Poster
Rep: Reputation: 30
bumb? any idea?

I may reinstall, and recompile my kernel.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't Resolve DNS IP shipon_97 Linux - Networking 1 08-25-2006 10:51 PM
Connected to wireless network but cannot resolve dns scrondle Linux - Wireless Networking 1 01-30-2006 04:09 PM
DNS can't resolve gmail.com but can resolve everything else? TongueTied Linux - Networking 2 01-24-2006 03:39 AM
DNS Resolve? b0rgri0t Slackware 1 01-04-2006 02:00 PM
dns client cannot resolve on dns server jtvillegas Linux - Software 1 10-20-2003 04:18 AM


All times are GMT -5. The time now is 04:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration