-   Slackware (
-   -   Winecfg *crashing* on sound tab? (

Tisch 10-15-2006 03:21 PM

Winecfg *crashing* on sound tab?
Hi ppl,

tried to search around for this but could not find anything.

Problem: After compiling and installing wine, i run winecfg to set up the sound but as soon as i click on the sound tab winecfg crashes with following error:

wine: Unhandled page fault on write access to 0x003ffd80 at address 0x61eb6103 (thread 0009), starting debugger...
Unhandled exception: page fault on write access to 0x003ffd80 in 32-bit code (0x61eb6103).

I am running slack 11 (2.4), wine 0.9.23 (same error with 0.9.22)

Can it be coz am running ALSA and not OSS?

if yes, do i have to recompile the kernel to get the OSS?

any help would be greatfull...


Mega Man X 10-17-2006 05:39 AM


It looks like it is a very common bug with wine. I'm having the exact same issue in Slackware 10.2. However, this does not appear to be Slackware specific. I've found a few links addressing this issue. It worked for a few peoples (not for me though)

Basically, do this:

- make sure that snd-seq module is loaded (modprobe snd-seq)
- make sure that is not being loaded. Rename it (mv <path_to_wine>/lib/ /<path_to_wine>/lib/

There are some patches around to fix this issue. Apparently, wine tries to load all available drivers now and that is why it is crashing.

Good luck!

All times are GMT -5. The time now is 11:52 AM.