-   Slackware (
-   -   Wine Slack Package (

vexer 06-02-2003 04:56 PM

Wine Slack Package
I downloaded the slack pkg from and also something called wine-builder.

I did an installpkg Wine-2003508.tgz and ran it getting and no .wine error, so I created a wine directory hope that it would generate it's own config file, but sure enough it didn't

I downloaded the source from to compile it, and I kept getting a Kernel BUG. So I used wine-builder on the file. And it didn't work..
Warning: no valid DOS drive found, check your configuration file.
Warning: could not find wine config [Drive x] entry for current working directory /usr/src; starting in windows directory.
Invalid path L"c:\\windows" for L"windows" directory: does not exist.
Perhaps you have not properly edited or created your Wine configuration file,
which is (supposed to be) '/home/vexer/.wine/config'.

I would like to know if anyone has actually gotten it to work and if so could you help me out?


dcm 06-03-2003 04:00 AM

Wine neds a configuration file called config in /home/you/.wine
Create the .wine directory in your home and copy the sample config file that is supplied with the package. You then need to edit it to suit your setup; see man wine and man wine.conf for help

Getting wine installed is easy enough; I found that getting the Slack version to run anything was a different matter and I've given up with it. Specifically, I was addicted to MSHearts and played this no problem for the last 3 years with RedHat. The latest Slack wine won't do it - probably a good thing, we should write a Linux implementation really!

labr@ 06-03-2003 06:58 AM

Check this out

Scroll to the bottom of the page there is the distro for Slack 9.0. I installed it and it worked fine. Of course I quickly uninstalled it and had to apologize to all of my computers for running a Window$ program on them (solitaire). My recommendation is "installpkg wine-20030408-i686-1.tgz " and then quickly "removepkg wine-20030408-i686-1" :D

vexer 06-03-2003 09:11 PM

labr@, it's nice that you found a package, which I had, but it doesn't help solve the no config file

north49er 06-05-2003 06:13 PM

OK, I'm pressing on trying to get wine to work on slack9.0. A noobie question,,,according to the wine howto from winehq, I'm supposed to create directories, one of them being "Program Files". However, mkdir can't make such a file as it will create two separate files. Or, should that be "Program_Files"? How can one create "Program Files" through mkdir? As a note, the sample config, system.ini and win.ini are located in /usr/doc/wine-20030508/samples.

labr@ 06-05-2003 10:42 PM

mkdir Program\ Files

kazuni 06-06-2003 06:16 AM


mkdir "Program Files"
will do too

north49er 06-06-2003 10:57 AM

Thanks for the tips. I think I've got it half-way working right as invoking wine does not complain something about config. However, I tried running mshearts as a test and it gives me something incompatible then goes through "font metrics" which goes and on. I'm not running kde and that is the only package not installed in this system. Any thoughts?

figadiablo 06-06-2003 11:22 AM

I got it working the other day, but i downloaded the source files from After uncompressing I executed the /tools/wineinstall script and it did everything for me. It created the windows system folders and the config files. It just worked perfectly. I would highly recommend installing from sources.


north49er 06-07-2003 10:51 AM

Not finding the wineinstall script, I downloaded winesetuptk from (all the way down near the bottom of the page), and compiled it. On my slow machine, it was a test of faith...but in the end the set up was a cinch. A look at the config looks like it's all set up to go. Thanks for the help.

All times are GMT -5. The time now is 12:19 PM.