LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-07-2010, 01:04 PM   #1
jobleep
LQ Newbie
 
Registered: Aug 2008
Posts: 26

Rep: Reputation: 15
Wine doesn't run "nicely"


Hi, I'm running slackware64-13.1. I've made my system multilib, and ugraded/installed both 32 bit and 64 bit graphics drivers on my system. I've installed iTunes on my system using 64 bit Wine, from Alien's repo. But it just doesn't work well at all, the window keeps disappearing, and then reappears but won't allow me to click on anything. Has anyone had any similar problems? Any dependencies that anyone installed?

I mean, it's not just with iTunes, all the other programs give me similar behavior.
 
Old 06-07-2010, 02:19 PM   #2
dimm0k
Member
 
Registered: May 2008
Location: Brooklyn ZOO
Distribution: Slackware64 14.2
Posts: 506

Rep: Reputation: 50
If I'm not mistaken, iTunes has a long way to go before it's usable under Wine. Looking iTunes up on www.winehq.com shows that there has not been much success at all getting iTunes to run after a successful install.
 
Old 06-07-2010, 02:34 PM   #3
manwichmakesameal
Member
 
Registered: Aug 2006
Distribution: Slackware
Posts: 804

Rep: Reputation: 110Reputation: 110
I had to run xp in a vm in order to get itunes to work. It's still kind of buggy (e.g. sloooow transfers and random disconnects) but it gets the job done.
 
Old 06-07-2010, 03:36 PM   #4
Gerard Lally
Senior Member
 
Registered: Sep 2009
Location: Brú na Bóinne, IE
Distribution: Slackware, NetBSD
Posts: 1,550

Rep: Reputation: 1025Reputation: 1025Reputation: 1025Reputation: 1025Reputation: 1025Reputation: 1025Reputation: 1025Reputation: 1025
Quote:
Originally Posted by manwichmakesameal View Post
I had to run xp in a vm in order to get itunes to work. It's still kind of buggy (e.g. sloooow transfers and random disconnects) but it gets the job done.
I use iTunes in XP in a KVM-Qemu vm and it works fine. I need it for those songs I bought which had DRM. I access them in a Samba share on the Slackware host. The virtual ethernet adapter model in the vm needs to be something like e1000 to get the necessary speed. The default NIC model is very slow. Not sure if you use KVM or Virtualbox but this should apply across the board.
 
Old 06-07-2010, 10:28 PM   #5
jobleep
LQ Newbie
 
Registered: Aug 2008
Posts: 26

Original Poster
Rep: Reputation: 15
Alright, thanks you guys.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error when trying to run wine: "/usr/bin/wine: No such file or directory" Lolwhut Linux - Software 9 08-20-2016 04:10 AM
"IOPL not enabled" error trying to run Wine bjharker Linux - Software 4 03-02-2011 12:42 PM
I've can't get "Wine" to run .exe files on my linux, no response at all. What to do? sallieestes Linux - Newbie 6 12-22-2009 04:23 PM
"View new posts" working very nicely now catkin LQ Suggestions & Feedback 2 09-28-2009 11:03 AM
Beautiful Non-AA "Crisp" Fonts in Programs run within Wine Toods Slackware 0 03-04-2009 03:27 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration