-   Slackware (
-   -   Win7 Installed, Slackware64 13.0 Installed BOOTMGR is missing (

tronayne 01-14-2010 07:32 AM

Win7 Installed, Slackware64 13.0 Installed BOOTMGR is missing
Arrgghh! I discovered that I could not install Win7 64-bit in VirtualBox (because an Intel T4300 doesn't have VT-x/AMD in it, drat) so, OK, let's just install Win7 64-bit then install Slackware 13.0 64-bit and dual-boot the thing for a while.

Win7 worked fine -- got all those important security updates and all that. Installed Slackware. Works fine. Shut down Slackware, reboot, select Windows from the Lilo start-up, BOOTMGR is missing, press ctrl+alt+del to restart...

Any clues?

Srikanth VM 01-14-2010 07:44 AM

I also got stuck in the same way , couldnt figure out anything so i just rolled back to Windows XP :(
I had configured lilo in the same manner as for xp but still it said no boot manager

SqdnGuns 01-14-2010 07:58 AM

Read on here:

Good luck...

dugan 01-14-2010 11:15 AM

You can solve this easily, if you're willing to use Windows' boot manager:
  1. Boot into Slackware, change lilo.conf to put lilo on the front on the HD, rerun LILO, and reboot. You'll end up back in Windows.
  2. Install EasyBCD ( Have it overwrite the MBR, and use it to create a boot menu with both Linux and Windows on it.

It only takes a few minutes, will work, and won't cost you any data.

Didier Spaier 01-14-2010 11:30 AM

I have a dual boot Windows 7 + Slackware64-13.0.

1) Format your HDD (with gparted, fdisk, cfdisk, whatever):
- Keep one partition for W7 (the installer will probably add a small boot partition in it during install and will use the remaining space as another partition for W7 itself)
- Format remaining space for Slackware as you see fit.
2) Install Slackware
3) Make Windows boot partition not bootable but Slackware's root partition bootable with fdisk or cfdisk
4) create or edit /etc/lilo.conf including:


boot=/dev/sda4 # Adapt to your layout, here sda4 is Slackware's root partition

other = /dev/sda1 # Here sda1 is Windows' boot partition (*not* bootable)
  label = Windows
  table = /dev/sda

Should work. At least, works here ;)

tronayne 01-14-2010 04:08 PM

I've just finished installing Win7 (after wiping the entire drive completely clean). It created

no-name        pir/log Free Space    1.06M
sda1      boot primary ntfs        104.86M
sda2          primary ntfs      20866.87M

and left me free space of 229084.17M for installing Slackware 13.0 64-bit.

From what you suggest, I'll turn off the boot flag on sda1, leave everything else alone, install Slackware starting at sda3 with the root partition bootable.

And, with crossed fingers and toes, that ought to work.


Didier Spaier 01-14-2010 04:20 PM

I hope you will succeed. Let us know the outcome.


tronayne 01-14-2010 04:56 PM

So far, so good -- installed Slackware and at the initial reboot, Win7 started up, shut it down and booted Slackware and I'm in the middle of adding back man gigabytes of stuff backed-up on DVD.

All appears to be well and thank you again for your help.

Callin' it good -- everything works as expected.

atlantaswl 11-17-2012 12:38 PM

lilo Windows 7 boot says BOOTMGR is missing
Hi all,
Got the latest Slackware distr. and loaded it onto /dev/sdb1, Windows 7 was already on /dev/sda1 and had lilo already on /dev/sda working fine.

Now, Linux boots, but when I attempt to boot Windows 7, lilo reports "Loading Windows", then the screen shows "BOOTMGR is missing, press ctrl-alt-del to reboot". I've tried the suggestions above to no avail. I wrote lilo to /dev/sda and /dev/sdb, made /dev/sdb the first drive in the boot sequence.

lilo relevancies:

boot = /dev/sdb
# Windows bootable partition config begins
other = /dev/sda1
label = Windows
table = /dev/sda
# Windows bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/sdb1
label = Linux
# Linux bootable partition config ends

I did overwrite the older lilo (which would boot Windows 7) with the the lilo from the Slackware install (probably the real issue, but don't know how to fix).

All help is greatly appreciated.

All times are GMT -5. The time now is 01:57 AM.