-   Slackware (
-   -   Win7 and lilo (

rm%rf 11-29-2010 12:09 AM

Win7 and lilo
Hi All,

I have a laptop that I have installed Slack-current on, I am currently using the usb image to boot from.

Windows7 is installed on sda2 and sda2 has been marked with the bootable flag,
I would like to use lilo to boot the laptop do i install lilo to sda or to sda2?
Will win7 still be able to boot using lilo as the boot loader ?

Another issue i noted during install is that the kernel panicked using the dvd to install with an error stating it could not read from the booting device, I eventually used the usb-pxe install to load the system however since 13.1 i have not been able to load a system using the dvd.

Thanx for the help if any.

Squall90 11-29-2010 12:37 AM

To sda. Some people say it is safer not to install it in the MBR but for me, it always worked and I had never problems. If you install it to sda2 I don't know what will happen. It should be safer to install to sda.

mcnalu 11-29-2010 02:09 AM

I have slackware-current and win7 coexisting happily together on partitions on /dev/sda with lilo in the mbr.

The laptop came with win7 preinstalled and the trickiest bit was persuading win7 to resize its own partition due to a splodge of blocks used for system purposes near its end. A quick search of the web revealed a number of solutions to this, including buying third part software, but I found it enough to turn off the pagefile and hibernate.

I can check that laptop's setup if there are any other details you'd like to know.

tronayne 11-29-2010 07:03 AM

I don't know if this will help you, but this is the disk partitioning of my Win7/Slackware-64 laptop (one disk, sda).

The laptop came with XP (before Win7 was available). When the Win7 disk came I did a fresh install then added Slackware-64. The first three partitions were automagically created by Win7 and the only way I could get the thing to work properly was by making sda3, the root partition, bootable (don't know why, but it works this way and doesn't work any other way). When Slackware was installed, I ran lilo to the MBR (in sda, edited /etc/lilo.conf to switch the Win7/Slackware positions so Slackware would be the default instead of Win7.

Been working fine.

                                              Unusable                                    1.05  *
    sda1                          Primary    NTFS                                      104.86  *
    sda2                          Primary    NTFS                [^B]                20866.67  *
    sda3          Boot          Primary    Linux ext3                              10001.95  *
    sda5                          Logical    Linux swap                                5996.23  *
    sda6                          Logical    Linux ext3                              20003.89  *
    sda7                          Logical    Linux ext3                              20003.89  *
    sda8                          Logical    Linux ext3                              20003.89  *
    sda9                          Logical    Linux ext3                              20003.89  *
    sda10                        Logical    Linux ext3                              20003.89  *
    sda11                        Logical    Linux ext3                              113066.60  *

The tail end of /etc/lilo.conf looks like this:

# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda3                                                                                 
  label = Linux                                                                                   
# Linux bootable partition config ends                                                             
# Windows bootable partition config begins                                                         
other = /dev/sda1
  label = Windows
  table = /dev/sda
# Windows bootable partition config ends

Hope this helps some.

rm%rf 11-29-2010 07:10 AM

Hi All,

Thanx for the help, will give it a bash tonight, btw is there any advantages to running Slack64 as opposed to Slack32 ?


tronayne 11-29-2010 08:05 AM


Originally Posted by rm%rf (Post 4174570)
Thanx for the help, will give it a bash tonight, btw is there any advantages to running Slack64 as opposed to Slack32 ?

Well, yes and no: depends (mostly) on what you're doing.

With Slackware-64 you can address more than 4G of RAM without having to recompile your kernel, plus, if you're doing heavy math (as in engineering and scientific calculations), it's going to be faster/better/slicker. The downside is that you won't be able to use 32-bit applications; e.g., GoogleEarth, Adobe Reader and the like, without adding Multilib (from Alian BOB at which give you the capability to use 32-bit software directly (and, yes, it works just fine and is not a lot of hassle to install or use).

Note that there are not many 32-bit only software packages and, if you're adding software of your own or the packages from, say, pretty much everything will build and run on either platform. I understand that some games and the like may present a problem but I cannot vouch for that.

I use 64-bit VirtualBox to run 32-bit XP as a guest operating system on my 64-bit boxes and have zero problems doing that if XP or some other OS matters to you.

The world is going to catch up and more and more 64-bit applications will become available, negating the need for things such as Multilib but, for now, that's the solution for mixing 32- and 64-bit software on the same platform.

If you've got a 64-bit box, I'd go with 64-bit Slackware -- 32-bit will install and work just fine on 64-bit hardware (including multi-core processors). And, if you buy the dual-side DVD ( you can try both and see what you think -- doesn't take that long to install and you can always do a clean install of the other if you don't like the first one.

So, I guess I'm saying, go with 64-bit unless you have a particular need for 32-bit.

Hope this helps some.

sjampoo 11-29-2010 08:39 AM

- removed because already answered -

dugan 11-29-2010 10:15 AM

I would install LILO on the Slackware partition (not the MBR), and use EasyBCD to manage the dual-booting.

rm%rf 11-30-2010 12:06 AM

Hi all

Thanx Tronayne for the 64 bit info,

Installed lilo into sda and all is workinf fine.

All times are GMT -5. The time now is 11:08 AM.