LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-14-2011, 05:14 AM   #1
beeyatchslapp
LQ Newbie
 
Registered: Jan 2011
Posts: 6

Rep: Reputation: 0
wifi wep connection problem..


I can't connect to any wep secured routers.. no clue why. When I disable the wep security it works fine, on both routers even but still nothing when the wep is enabled. Its been awhile since I've used linux but I have quiet a bit of wireless setup experience due to problems in the past but I'm stumped. I've searched for about 2-3 hours now and no luck..

Funny thing is it was working just fine yesterday. Freshly installed Slackware 13.1 and had all my drivers working, came home this morning and had no internet . Wifi on my android works fine with the wep also.

HELP PLEASE
 
Old 01-14-2011, 05:40 AM   #2
truboy
Member
 
Registered: Oct 2010
Location: Switzerland
Posts: 84

Rep: Reputation: 9
Quote:
Originally Posted by beeyatchslapp View Post
I can't connect to any wep secured routers..
Does Slackware throw an error ?
 
Old 01-14-2011, 05:47 AM   #3
beeyatchslapp
LQ Newbie
 
Registered: Jan 2011
Posts: 6

Original Poster
Rep: Reputation: 0
None at all. there is no signal level at all when everything is configured correctly. Only when I disable the security
 
Old 01-14-2011, 06:33 AM   #4
yooy
Senior Member
 
Registered: Dec 2009
Posts: 1,387

Rep: Reputation: 173Reputation: 173
probably your wireless router needs restart?
 
Old 01-14-2011, 06:52 AM   #5
beeyatchslapp
LQ Newbie
 
Registered: Jan 2011
Posts: 6

Original Poster
Rep: Reputation: 0
Already tried.. have tryed with 2 completely different routers
 
Old 01-14-2011, 07:57 AM   #6
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
Which wireless card/chipset? Which drivers? What application / how are connecting? And what options have you put in?

Have you tried the iwconfig approach?

ifconfig wlan0 down
iwconfig wlan0 essid "YOURSSID"
iwconfig wlan0 key "$KEY"
ifconfig wlan0 up
dhcpcd wlan0

$KEY needs to be hex or prefix it with s:
iwconfig wlan0 key "s:$WEPKEY"

You either have something that works great, sort of works, or is complete trash.
My experience -

Atheros - great, fabulous, works 100% (Laptop miniPCIe)

Intel - same as Atheros. (Have used 22xx, 39xx, 49xx, and 51xx laptop miniPCI and miniPCIe)

rt73usb - kernel drivers suck. I use upstream drivers from ralink. Kernel drivers cause the connection to drop, or to only sync at 1-5mb/s. Upstream gives constant sync rate and speed. (Linksys usb stick)

rtl818x - sort of works. But this chipset is junk. (common $5 usb sticks)

BCM43x - kernel drivers can be flaky. Upstream driver works great. (Another common miniPCI miniPCIe chipset)

Innopro - works almost as good as Intel and Atheros with ndiswrapper. (Linksys PCMCIA card.)
 
Old 01-14-2011, 08:02 AM   #7
dh2k
Member
 
Registered: Jan 2006
Distribution: Slackware 13.0 (KDE 3.5.10 from 12.2; Xfce 4.6; Fluxbox); Slackware 13.1 (KDE 4.5)
Posts: 211

Rep: Reputation: 52
Are you using 'wicd' from ./extra
 
Old 01-14-2011, 08:07 AM   #8
cin_
Member
 
Registered: Dec 2010
Posts: 281

Rep: Reputation: 24
rfkill

Device might be acting up.
try...
Code:
# rmmod ath5k
# rfkill block all
# rfkill unblock all
# modprobe ath5k
# rfkill unblock all
# ifconfig wlan0 up

# iwconfig wlan0 essid ""
# wicd
...note: make sure you use the correct driver; in my case it was ath5k.

Code:
# man rmmod
# man rfkill
# man modprobe
 
Old 01-14-2011, 06:17 PM   #9
beeyatchslapp
LQ Newbie
 
Registered: Jan 2011
Posts: 6

Original Poster
Rep: Reputation: 0
its a intel card and it works fine from what i can tell.. didnt have this problem when i first set it up and the card actually installed right out of the box. worked right away no problems right after installing slack.

Code:
bash-4.1# iwconfig eth1 essid 2WIRE243 channel 11
bash-4.1# iwconfig eth1 key 7027719414    
bash-4.1# iwconfig eth1
eth1      IEEE 802.11bg  ESSID:"2WIRE243"  Nickname:"shibbie"
          Mode:Managed  Frequency:2.462 GHz  Access Point: Not-Associated   
          Bit Rate:0 kb/s   Tx-Power=20 dBm   Sensitivity=8/0  
          Retry limit:7   RTS thr:off   Fragment thr:off
          Encryption key:7027-7194-14   Security mode:restricted
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
nothing.... but with the security disabled...

Code:
bash-4.1# iwconfig eth1 enc off
bash-4.1# iwconfig eth1
eth1      IEEE 802.11bg  ESSID:"2WIRE243"  Nickname:"shibbie"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:1B:5B:5F:C6:F1   
          Bit Rate:11 Mb/s   Tx-Power=20 dBm   Sensitivity=8/0  
          Retry limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=67/100  Signal level=-60 dBm  Noise level=-85 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:4  Invalid misc:0   Missed beacon:0

bash-4.1# dhcpcd eth1
dhcpcd: version 5.2.2 starting
dhcpcd: eth1: rebinding lease of 192.168.1.213
dhcpcd: eth1: acknowledged 192.168.1.213 from 192.168.1.254
dhcpcd: eth1: checking for 192.168.1.213
dhcpcd: eth1: leased 192.168.1.213 for 86400 seconds
dhcpcd: forking to background
works fine!


this is why i cant figure it out... its not a router or driver problem from what i can tell...
 
Old 01-14-2011, 06:44 PM   #10
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
You're not entering the key correctly.
iwconfig key "s:$YOUR.PHONE.NUMBER"
Since you entered your phone number in ASCII for the wep key, it must be prefaced with s:. iwconfig -h and my post above state this
Our use wicd / networkmanager which will handle the keys for you.

BTW, I'd edit out your key
 
Old 01-14-2011, 06:50 PM   #11
cin_
Member
 
Registered: Dec 2010
Posts: 281

Rep: Reputation: 24
Yeah if it works when you turn the security off, then I'd also suggest double checking your syntax.

But why are you locking down your router? I mean I'm sure your neighbors without the income appreciate your philanthropy.
If its a sensitive information issue, then I'd suggest using WPA. WEP has too many simple exploits...
 
Old 01-14-2011, 06:58 PM   #12
beeyatchslapp
LQ Newbie
 
Registered: Jan 2011
Posts: 6

Original Poster
Rep: Reputation: 0
um its definitely the default 10-digit hex key.... ill try but i never had a problem entering it like that before. and i dont really care about posting it ether. there not mine, thats why you shouldnt use WEP to begin with.
 
Old 01-14-2011, 07:02 PM   #13
beeyatchslapp
LQ Newbie
 
Registered: Jan 2011
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by cin_ View Post
Yeah if it works when you turn the security off, then I'd also suggest double checking your syntax.

But why are you locking down your router? I mean I'm sure your neighbors without the income appreciate your philanthropy.
If its a sensitive information issue, then I'd suggest using WPA. WEP has too many simple exploits...
i am that neighbor with no income lmao. i cant take down the security for to long so i dont raise any suspensions.. im the guest here and would like to keep my access for awhile

Last edited by beeyatchslapp; 01-14-2011 at 10:20 PM. Reason: typo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wifi-radar and wep Pedroski Linux - Wireless Networking 7 01-29-2008 07:52 AM
Boot connection problem with WEP Tyante Linux - Wireless Networking 0 11-01-2006 08:52 PM
Wireless Connection Problem with Home WEP Network tmort Linux - Wireless Networking 4 04-12-2006 10:11 PM
wifi problem ral + WEP coltree *BSD 1 03-05-2006 02:23 PM
wifi wep... almost done kermit Linux - Wireless Networking 12 03-15-2005 07:39 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration