-   Slackware (
-   -   wifi on slackware (

slinky2004 10-05-2005 08:01 PM

wifi on slackware
i've been trying for a while to get my wifi card working on my laptop with slackware and i've got it all setup except that for some reason i can "connect" to an access point, but i cant use dhcpcd to grab an ip. i've heard that it's possible to work around this by setting my ip and gateway manually, but that's only good for my home network. anyway, i recently installed ubuntu, because i heard it was good for laptops and stuff, linux on my laptop and the wifi card worked perfectly.

now i want to go back to using slackware and i'm trying to figure out what the difference could be. i was using the same ipw2200 firmware and drivers on both slackware and ubuntu. the kernels were different: a that i compiled myself on slackware and something based on a 2.6 in ubuntu, i think they modify it or something. the dhcp clients were also different: dhcpcd on slackware and dhclient on ubuntu.

anybody think switching to dhclient or using an older, more stable 2.6 kernel will solve my problem?

noxious 10-05-2005 09:45 PM

I'm using a kernel with the ipw2100 drivers and firmware with nice results... I tried 2.6.13 with the 2.6.14-rc3 patch - I got it to work, but I found the ATI drivers would not install with it.

Somewhere, in my reading about how to get the ipw2100 drivers to work, I remember coming across a post saying that the older (pre-2.6.10) kernels worked best. I haven't experimented much beyond this, but I know for a fact that the works great with the ipw2100 drivers, and loads the ATI video drivers great.

towsonu2003 10-06-2005 01:02 AM

I've got a problem with my wifi as well, although it does not seem similar. Please let us know if anything you try works out. thanks.

slinky2004 10-06-2005 10:23 AM

yeah, 2.6.10 solved it. i guess there is a bug between 2.6.13.*, dhcp, and ipw2200/wireless.

towsonu2003 10-13-2005 08:12 PM

update: switching to ubuntu 5.04 made wlan0 work fine here.

mjjzf 10-14-2005 04:51 AM

I heard the same issue with the later kernels. That is why I have kept a patched 2.4.31.

sn9ke_eyes 10-14-2005 12:29 PM

Just saw your thread here, I had the same issue with Slackware 10.2 and kernel 2.6.13-2

Check out this thread

the 1.07 version of ipw2200 driver will contain a fix, but you can patch it yourself since that isn't out yet. Instructions at the end of that thread.

All times are GMT -5. The time now is 11:00 PM.