-   Slackware (
-   -   wicd network manager issues. (

BashTin 08-29-2012 09:58 AM

wicd network manager issues.
Hello again. So I want to connect to different wifi networks and haven't really figured out how/if I can have profiles in inet1.conf. Thought I would give wicd a try. The little app starts up great, nice little window, but precious little else.

I ask it to find my essid via 'find hidden network' and nothing seems to happen. I make changes to preferences such as wired interface = eth0, wireless ineterface = wlan0, dns, etc. Click 'apply' and next time I check the settings are not saved, just blank.

I know the interfaces are not meant to be configured via inet1.conf so commented them out.

What am I missing or doing wrong?

Thanks in advance, BashTin.

Oh, PS, when I start it up from the command line I get

Could not open  "active"
QMetaObject::invokeMethod: No such method KUniqueApplication::loadCommandLineOptionsForNewInstance()

Any connection??

xflow7 08-29-2012 10:12 AM

Have you run the rc.wicd startup script in /etc/rc.d?

As root:


sh /etc/rc.d/rc.wicd start
If you like wicd, you should probably then do:


chmod +x /etc/rc.d/rc.wicd
so that it will be started at boot time.

BashTin 08-29-2012 10:17 AM

yep, tried that. I get '/etc/rc.d/rc.wicd: No such file or directory'

Mine is located at /usr/bin/wicd-client-kde


xflow7 08-29-2012 10:38 AM


Originally Posted by BashTin (Post 4767452)
yep, tried that. I get '/etc/rc.d/rc.wicd: No such file or directory'

Mine is located at /usr/bin/wicd-client-kde


That is a client. There is a daemon that needs to run. The fact that /etc/rc.d/rc.wicd doesn't exist leads me to believe the package isn't installed correctly. Did you install the wicd package from extra/?

dsotm 08-29-2012 02:17 PM

Did you install wicd-client-kde from SlackBuilds? Uninstall that and install wicd from /extra... I had the same problem initially

ReaperX7 08-29-2012 03:46 PM

Is your user account a member of the "netdev" group?

ahlr 08-29-2012 05:54 PM



chmod +x /etc/rc.d/rc.networkmanager

/etc/rc.d/rc.networkmanager start

And config KDE NetWorkmanager!


BashTin 08-29-2012 06:36 PM

Thanks guys. Uninstalled it and installed the one from the /extra dir. Added myself to netdev, rebooted and all is fine. Looks a good little app. Will give it a more thorough road test. Have a few other issues which I will start another thread on.

Thanks, BashTin.

All times are GMT -5. The time now is 04:58 AM.