-   Slackware (
-   -   Wicd in current won't connect to wireless network. Fixed it with rebuilding (

grissiom 03-05-2010 03:22 AM

Wicd in current won't connect to wireless network. Fixed it with rebuilding
After I upgraded to current(Tue Mar 2 19:07:31 UTC 2010), I could not connect to any wireless network. It will always failed in obtaining IP address. When I rebuild the package and upgrade with the new one, the problem gone. Does anyone have the same experiences?

Also I notice that the package I rebuild is different with the one on the stock tree:

..ckware-mirrors/slackware64-current% md5sum /tmp/wicd-1.7.0-x86_64-1.txz
446ff631eee4c862263ad0488e3a38be  /tmp/wicd-1.7.0-x86_64-1.txz

        grissiom 2010-03-05 17:21 @darkstar
..ckware-mirrors/slackware64-current% md5sum ./extra/wicd/wicd-1.7.0-x86_64-1.txz
921c46e085fc7a32a4f3260ade327bba  ./extra/wicd/wicd-1.7.0-x86_64-1.txz

Does anyone have some idea of this?

mRgOBLIN 03-05-2010 08:20 PM

Worked fine for me without any rebuild.

Not sure what you mean about the packages being different. The md5sums will never match if you build a package yourself.

The md5sum I have is 921c46e085fc7a32a4f3260ade327bba which is correct according to CHECKSUMS.md5

grissiom 03-05-2010 11:34 PM

Really? AFAIK, the same files will give the same md5sum. Why packages build locally will never match the ones provided by Pat?

GrapefruiTgirl 03-05-2010 11:46 PM

It's an interesting question indeed. I would think that MrGoBlIN is quite right -- things like binaries have meta-data in them (don't they?), for one thing, which includes stuff like build-time & date (which will definitely be different) and you've got things like different $CFLAGS on one persons system vs another, slightly different CPU optimizations on one CPU vs another, etc..

I can't put it into one clear-cut sentence as to why two identical packages on two different systems will have different checksums, but it really does seem unlikely to be able to build the same package, even on two identical systems, perhaps even the same package built at two different times on the same machine, and get the same checksum.

I'm inclined to try it!

GrapefruiTgirl 03-05-2010 11:58 PM


574b716a5d64d96b4dc39ebcc83cfc47  testpackage1.tgz
7c6fbb3123e505a376f95a513e109040  testpackage2.tgz
2f086b41da6ae869f196c074065fe30d  testpackage3.tgz

The above are three identical packages of my WM. I made each of them in the same directory, from the same sources, by doing `make clean; make; makepkg` and as we can see, the md5sums are all different. Even though the filename doesn't affect the checksum, I re-made package #3 several times anyways, and gave it the same name over and over, and still the checksum was different each time.


disturbed1 03-06-2010 12:00 AM

Built wicd awhile ago

ls -la /tmp/wicd-1.7.0-x86_64-1.txz
-rw-r--r-- 1 root root 355936 2010-03-05 20:32 /tmp/wicd-1.7.0-x86_64-1.txz
bash-3.1$ md5sum /tmp/wicd-1.7.0-x86_64-1.txz
ac9042a494628beb748463d2b6e6f116  /tmp/wicd-1.7.0-x86_64-1.txz

Just rebuilt after reading GrapefruiTgirl's post

bash-3.1$ ls -la /tmp/wicd-1.7.0-x86_64-1.txz
-rw-r--r-- 1 root root 355888 2010-03-06 00:56 /tmp/wicd-1.7.0-x86_64-1.txz
bash-3.1$ md5sum /tmp/wicd-1.7.0-x86_64-1.txz
c6f18521165a58a15c06fc2522f7d38d  /tmp/wicd-1.7.0-x86_64-1.txz

Each and every time you build/rebuild a package the md5sum will change because of the time stamps.

What's really strange is the size difference. Another quick rebuild -

bash-3.1$ ls -la /tmp/wicd-1.7.0-x86_64-1.txz
-rw-r--r-- 1 root root 355816 2010-03-06 00:58 /tmp/wicd-1.7.0-x86_64-1.txz
bash-3.1$ md5sum /tmp/wicd-1.7.0-x86_64-1.txz
0b45929da87ae614edf979a77a99482b  /tmp/wicd-1.7.0-x86_64-1.txz

Notice that just a 2 minute difference produced a package with a different size and a different md5sum. Hard to explain, but easy to understand.

grissiom 03-06-2010 12:16 AM

Thanks very much for explainings on this topic! The meta-data theory is a way to explain the reason. Thanks! Now I feel I understood more than before ;D

All times are GMT -5. The time now is 11:52 PM.