LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-24-2010, 07:55 AM   #1
seflyer
Member
 
Registered: Apr 2010
Distribution: Slackware32-13.37
Posts: 58

Rep: Reputation: 16
why settings for 'eth0' go to 'pan1'


Hi all, I don't know if it is safe to post all the ip address information online, if it may cause security issues, pls kindly remind me...
I switch between two ip configurations, a dhcp one and another with static ip. The problem is that, when I changed the 'eth0' part of /etc/rc.d/rc.inet1.conf file to use dhcp, and restart rc.inet1, I get the original ip address unchanged in eth0 interface, and the newly gotten ip address goes to 'pan1'.
I can surf the internet as usual, I have noticed this problem because I can not ping to the default gateway or use the network printer.
Code:
bash-4.1# /etc/rc.d/rc.inet1 restart
Polling for DHCP server on interface eth0:
dhcpcd: version 5.2.2 starting
dhcpcd: eth0: broadcasting for a lease
dhcpcd: eth0: offered 202.112.85.** from 202.112.85.99
dhcpcd: eth0: acknowledged 202.112.85.** from 202.112.85.99
dhcpcd: eth0: checking for 202.112.85.**
dhcpcd: eth0: leased 202.112.85.** for 86400 seconds
dhcpcd: forking to background
bash-4.1# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:23:54:1c:a3:a8  
          inet addr:172.16.56.**  Bcast:172.16.56.255  Mask:255.255.255.0
          inet6 addr: 2001:da8:207:5085:223:54ff:fe1c:a3a8/64 Scope:Global
          inet6 addr: fe80::223:54ff:fe1c:a3a8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:29497 errors:0 dropped:0 overruns:0 frame:0
          TX packets:17880 errors:0 dropped:0 overruns:0 carrier:6
          collisions:0 txqueuelen:1000 
          RX bytes:14250439 (13.5 MiB)  TX bytes:2493541 (2.3 MiB)
          Interrupt:28 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:623 errors:0 dropped:0 overruns:0 frame:0
          TX packets:623 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:85811 (83.7 KiB)  TX bytes:85811 (83.7 KiB)

pan1      Link encap:Ethernet  HWaddr e2:c8:92:a7:93:83  
          inet addr:202.112.85.**  Bcast:202.112.85.255  Mask:255.255.255.0
          inet6 addr: fe80::e0c8:92ff:fea7:9383/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:362 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:44670 (43.6 KiB)
Any idea? Thanks!
 
Old 06-25-2010, 09:12 AM   #2
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Debian
Posts: 8,577
Blog Entries: 31

Rep: Reputation: 1196Reputation: 1196Reputation: 1196Reputation: 1196Reputation: 1196Reputation: 1196Reputation: 1196Reputation: 1196Reputation: 1196
What is the command you are using to "restart rc.inet1"? Restarting eth0 alone should be enough: /etc/rc.d/rc.inet1 restart_eth0

If that doesn't solve the problem, please post one of your two rc.inet1.conf files (without the empty lines and comments -- use grep -E -v '^$|^ *#' /etc/rc.d/rc.inet1.conf) and a diff between that one and the other.

No problem posting 172.16.x.x addresses in full (they are private; lots of people use the same addresses) but the leading part of the 202.112.85.x addresses should be removed if you want privacy. For example 202.112.85.8 would become X.X.85.8 and 202.112.85.255 would become X.X.85.255. That way nobody could pick a random address in the 202.112.85.x range and discover that the whole 202.112.80.0 - 202.112.95.255 range is assigned to one organisation.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ifcfg-eth0 file settings srns Linux - Networking 6 09-07-2013 08:41 AM
[SOLVED] OEL5.4 OS, eth0 has private IP, eth0:0 has routable IP, internet access don't work Hiroshi Linux - Networking 7 06-02-2010 12:49 PM
Copy SuSE eth0 settings to Mandrake davonz Linux - Networking 5 10-25-2005 08:30 AM
eth0 (ADSL) settings don't stick, MDK10.0 otish1000c Mandriva 4 06-22-2004 08:45 PM
eth0 IP settings cannot be determined krinor1966 Fedora - Installation 3 05-11-2004 04:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration