-   Slackware (
-   -   Why MPlayer require Samba? (

NightSky 11-09-2013 08:13 PM

Why MPlayer require Samba?
When I try to run MPlayer I get the following error:

mplayer: error while loading shared libraries: cannot open shared object file: No such file or directory
Why does MPlayer need Samba? I thought I would not be using samba so did not install it.

jprzybylski 11-09-2013 08:17 PM

Mplayer can use samba to play files off of a samba share without the file system being mounted.

Samba doesn't need to be running for mplayer to function, though, so just installing it and leaving it alone is an easy fix.

NightSky 11-09-2013 10:00 PM

Thank you. Installed Samba & MPlayer plays video music. Running slackware64-13.37 Xfce 4.6.2 with alien's MPlayer Pkg. and an Nvidia Video Card using xvideo driver.
Tested a dvd & screen froze. Alt Back space took me to text screen that said:

vidixlib: Probing mga_crtc2 with error and then pci scan: operation not permitted
gmplayer GTK Warning** GTKSpinButton:Setting an adjustment with non-zero page size is depricated

Never tried to watch DVD before and don't know what settings are required. What Commands do I need to find out what Codecs are installed and available? Thanks

jtsn 11-09-2013 11:53 PM

Just a hint: It would be wise to open a new thread for a new problem. Also marking a working solution, so a thread becomes [SOLVED] helps others using the forum.

NightSky 11-10-2013 12:04 AM

Going thru /usr/doc/MPlayer-20110624/ & it seems I ought to have codecs in /usr/local/lib but that folder is empty?

mlangdn 11-10-2013 01:32 AM

Get Alien's codec package here:

andrew.46 11-10-2013 01:39 AM

You could download these manually if you feel you need them. They are only of use with a 32bit build and MPlayer / libavcodec are getting to the stage where they really need them less and less...

Edit: I see you have a 64bit installation therefore do not bother...

NightSky 11-10-2013 04:27 PM

MPlayer DVD Play froze and crashed XFCE 4.6.2

Originally Posted by jtsn (Post 5061674)
Just a hint: It would be wise to open a new thread for a new problem. Also marking a working solution, so a thread becomes [SOLVED] helps others using the forum.

You're right, Thanks. Installing Samba Solved the MPlayer GUI Initialization Problem. Hope this thread helps lots of folks finish their MPlayer Installation and Configuration with more ease and joy than I did, as it is current & consolidated.

MPlayer-20110624-x86_64-1alien.tgz is the last 13.37 build that provides excellent DVD Play as a fully codec featured package for both Slackware64 & Slackware-13.37. Download from here:

MPlayer crashed Xfce when I tried to start DVD Play

ctr + alt + backspace
Placed me at at the error screen and then I went to a new login screen.

After having created a ~/.Mplayer/config I put this in it to start:



I, crashed Xfce by trying to open DVD Play - clicking 'Open Disc' from the inital GUI menu in combination with CLI Navigation Config Commands

$ mplayer dvd: //N
$ mplayer dvdnav://
$ mplayer -mouse-movements dvdnav://

All is working great now both on slack64 box and ThinkPad T500 after finding the "/usr/doc/MPlayer-20110624 for the new package /MPlayer.configuration output and Change Log.
Alien's slack package configures itself pretty accurately upon "installpkg MPlayer" -easy peasie. If only I had known;)

Here is a great sample to start from to customize MPlayer for your own resource:


$ xvinfo
Is great to see what video specs/setting Xserver is providing instead of your proprietary video card driver.

Check this out for more xfce, kde & Gnome:

Last but not least so you don't waste, as much time as, I. For Pure Video lovers' needs:

Thank you all for your time & input. Cheers

All times are GMT -5. The time now is 05:23 AM.