LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-03-2018, 09:11 PM   #1
hedron
Member
 
Registered: Jul 2009
Location: NYC
Distribution: Slackware, Bluewhite, SARPI
Posts: 254

Rep: Reputation: 26
Why is Samba so slow?


I'll open up Windows Explorer, and open my network drive, but it freezes and I have to wait about 10-30 seconds for it to open a folder. Then after opening that folder it takes 10-30 seconds to open that folder. Wash. Rinse. Repeat.

This is a samba server that is in a virtual drive with VirtualBox, and the network setup is kind of convoluted. I don't know if this is the problem or not.

This is the output of testparm:
Code:
# Global parameters
[global]
        server string = come in poor, walk out rich
        workgroup = workgroup
        name resolve order = wins lmhosts hosts bcast
        security = USER
        wins proxy = Yes
        wins support = Yes
        idmap config * : backend = tdb


[annex]
        path = /home/annex
        read only = No
        valid users = username
Note that this is not about transfer speed. Transfer speed is just fine. Whether uploading or downloading a file, the transfer speed is just fine. It's just accessing the file is the issue.
 
Old 06-03-2018, 09:34 PM   #2
gus3
Member
 
Registered: Jun 2014
Distribution: Slackware (x86 and ARM)
Posts: 118

Rep: Reputation: Disabled
My first (totally uneducated) guess is a delay in name resolution. Have you tested the response time for WINS and/or DNS?
 
Old 06-04-2018, 02:32 PM   #3
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware = Main OpSys for decades while testing others to keep up
Posts: 1,870

Rep: Reputation: 1768Reputation: 1768Reputation: 1768Reputation: 1768Reputation: 1768Reputation: 1768Reputation: 1768Reputation: 1768Reputation: 1768Reputation: 1768Reputation: 1768
Maybe because Windows is a Black Hole that sucks up the energy of any neighbor even remotely in the vicinity?

---
---
Sorry. Just couldn't resist.
 
3 members found this post helpful.
Old 06-04-2018, 07:27 PM   #4
glorsplitz
Member
 
Registered: Dec 2002
Distribution: slackware!
Posts: 604

Rep: Reputation: 118Reputation: 118
Quote:
Originally Posted by enorbet View Post
Maybe because Windows is a Black Hole that sucks up the energy of any neighbor even remotely in the vicinity?

---
---
Sorry. Just couldn't resist.
as posted here

Sorry. Just couldn't resist.
 
Old 07-08-2018, 03:59 PM   #5
hedron
Member
 
Registered: Jul 2009
Location: NYC
Distribution: Slackware, Bluewhite, SARPI
Posts: 254

Original Poster
Rep: Reputation: 26
Quote:
Originally Posted by gus3 View Post
My first (totally uneducated) guess is a delay in name resolution. Have you tested the response time for WINS and/or DNS?
How would I do that? I found something from GRC and some other open source program, but they seemed geared towards internet DNS and not local.

I use hosts file on windows for name resolution, which I assume is the quickest way. It's the easiest way, which is why I chose that method. It would be best that my router would do it, but then i'm not sure my router has that functionality. (TP-Link TL-WR720N)
 
Old 07-08-2018, 04:58 PM   #6
gus3
Member
 
Registered: Jun 2014
Distribution: Slackware (x86 and ARM)
Posts: 118

Rep: Reputation: Disabled
Your setup above indicates that your first resolver is "wins", not "lmhosts" or "hosts". If Samba is configured to double-check inbound connections, its first lookup will be through "wins", which is network-based. If there is no running WINS service, there's a time-out and the next resolver is tried.

(WINS in Samba is usually provided by nmbd, but it is optional.)

My quick-and-ignorant suggestion: change the global config section to contain

Code:
name resolve order = lmhosts hosts wins bcast
and see if that eliminates the delay.
 
1 members found this post helpful.
Old 07-11-2018, 11:32 PM   #7
hedron
Member
 
Registered: Jul 2009
Location: NYC
Distribution: Slackware, Bluewhite, SARPI
Posts: 254

Original Poster
Rep: Reputation: 26
Well, thanks for your help, but the problem was a "misconfigured" ethernet setting. I did:

Code:
ethtool -K eth0 tx-tcp-segmentation off
I found the solution here: https://www.raspberrypi.org/forums/v...71122#p1333422

Retrospectively, I guess I should have put this thread in the ARM section, but I didn't think the problem was specific and I had thought it was going to turn out to be Windows.

I hadn't really detected a distinct pattern until this morning when I realized it was just large files that were causing problems. Since the VDI file was a large file any communication with the VirtualBox disc image would cause my computer to lock up. I tried to copy the file and got a 0x8007003B error when copying files to windows, and that's how I found the above thread.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SAMBA Slow Down qwerty_tele Linux - Server 7 01-19-2009 04:00 PM
SAMBA very slow Sushy Linux - Networking 4 06-12-2006 10:21 AM
samba (very slow) stomach Linux - Software 1 10-26-2005 12:07 PM
Slow Samba..... benmay05 Linux - Networking 5 01-29-2005 08:07 PM
samba very slow Moebius Linux - Networking 2 08-25-2004 10:38 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration