LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-16-2012, 10:49 AM   #1
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,541

Rep: Reputation: 1060Reputation: 1060Reputation: 1060Reputation: 1060Reputation: 1060Reputation: 1060Reputation: 1060Reputation: 1060
Where to Find klocalizeddate.h or Nepomuk


There is a new release of Tellico, version 2.3.5, that I'm trying to compile (using tellico.SlackBuild with the version number changed). It fails with
Code:
/tmp/SBo/tellico-2.3.5/src/gui/kdatecombobox.cpp:31:28: fatal error: klocalizeddate.h: No such file or directory
compilation terminated.
make[2]: *** [src/gui/CMakeFiles/gui.dir/kdatecombobox.o] Error 1
make[2]: Leaving directory `/tmp/SBo/tellico-2.3.5/build'
make[1]: *** [src/gui/CMakeFiles/gui.dir/all] Error 2
make[1]: Leaving directory `/tmp/SBo/tellico-2.3.5/build'
make: *** [all] Error 2
I can't locate klocalizeddate.h anywhere in the 13.37 distribution (it ain't in any of the packages' .txt files).

The KDE web pages talk about Nepomuk including that file (can't find Nepomuk anywhere either and I'm not too sure that want it in any evert).

I don't really want to upgrade to Slackware-current if I don't have to (I try to stay at stable until there's another stable release) but I'm wondering if there's any way around, over, under or through to be able to build Tellico-2.3.5?
 
Old 01-16-2012, 01:11 PM   #2
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 3,942

Rep: Reputation: 1954Reputation: 1954Reputation: 1954Reputation: 1954Reputation: 1954Reputation: 1954Reputation: 1954Reputation: 1954Reputation: 1954Reputation: 1954Reputation: 1954
That header is also in the kdelibs package of alien's kde 4.6.5 for slackware 13.37, but I really don't know if that kde's version is enough to let latest Tellico build.
 
1 members found this post helpful.
Old 01-17-2012, 11:31 PM   #3
parys
LQ Newbie
 
Registered: May 2005
Posts: 5

Rep: Reputation: 0
Quote:
Originally Posted by tronayne View Post
I don't really want to upgrade to Slackware-current if I don't have to (I try to stay at stable until there's another stable release) but I'm wondering if there's any way around, over, under or through to be able to build Tellico-2.3.5?
Tellico uses KlocalizedDate which was added to KDE 4.6. So that would be a minimum version of KDE to use for Tellico.

But I didn't realize I had used a class that increased the minimum version of KDE necessary for Tellico, so I'll fix that for the next release and post an update to the Tellico release announcement about it.
 
Old 01-18-2012, 09:54 AM   #4
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,541

Original Poster
Rep: Reputation: 1060Reputation: 1060Reputation: 1060Reputation: 1060Reputation: 1060Reputation: 1060Reputation: 1060Reputation: 1060
Well, that's that. OK, so I've downloaded AlienBob's 4.6.x and will be upgrading to it sometime today (after I go move a foot of snow that arrived yesterday from one place to another -- this sort of thing happens when you live halfway to the north pole).

Thanks for the input.

All is well that ends.
 
Old 03-06-2012, 12:42 PM   #5
bstern
LQ Newbie
 
Registered: Apr 2009
Posts: 5

Rep: Reputation: 0
Same here, on both counts (needing a newer KDE, and therefore installing Alien BOB's).
 
Old 03-07-2012, 08:24 AM   #6
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,541

Original Poster
Rep: Reputation: 1060Reputation: 1060Reputation: 1060Reputation: 1060Reputation: 1060Reputation: 1060Reputation: 1060Reputation: 1060
Quote:
Originally Posted by bstern View Post
Same here, on both counts (needing a newer KDE, and therefore installing Alien BOB's).
Um, you probably don't want KDE 4.6 -- I've had a lot of trouble with it crashing and have switched to XFCE for the moment. You probably want 4.8, that you can find at http://alien.slackbook.org/ktown/4.8.1/.

Tellico, the original problem, builds fine with 4.6 and works properly in either KDE or XFCE after the build. I'm going to download 4.8 when I get some time to fiddle with it and see how that works.

Hope this helps some.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Purge nepomuk db's after disabling nepomuk/strigi raypen Slackware 1 12-01-2011 12:06 PM
Nepomuk Strigi snakepit:/# Slackware 29 08-13-2011 02:29 PM
What does Nepomuk Strigi do? MTK358 Linux - General 6 06-12-2010 04:45 PM
Is this normal? - Nepomuk/Strigi - again! samac Slackware 21 03-23-2010 01:19 AM
Nepomuk-enstein. cwizardone Slackware 4 10-05-2009 02:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration