-   Slackware (
-   -   Where is tcl / tk ? (

varaahan 02-17-2009 10:04 AM

Where is tcl / tk ?
I tried to install tkpppoe which required tcl / tk.
I installed tcl but could not find tk .
How to get it ?

Didier Spaier 02-17-2009 10:20 AM

The tk package is in the slackware/tcl directory of your installation media and on the Slackware mirrors.

I should be installed if you made a full install, which is recommended, if you use Slackware.

But I can't be sure I gave you a relevant information as you do not indicate for which distribution and version you miss it :scratch:

varaahan 02-17-2009 10:25 AM

I have installed the full dvd version of slackware 12.2 yet tcl / tk is not there. Downloaded the tar.gz packages and installed it. I had to login as root and invoke tkpppoe yet I could not connect to internet.

Invoking tkppoe from CLI gives this o/p.

root@darkstar:/home/sridhar# tkpppoe
No protocol specified
Application initialization failed: couldn't connect to display ":0.0"
Error in startup script: invalid command name "tk"
while executing
"tk appname TkPPPoE"
(file "/usr/bin/tkpppoe" line 40

Ilgar 02-17-2009 10:57 AM


Application initialization failed: couldn't connect to display ":0.0"
If you're trying to run it from a terminal while you're running an X session as a regular user, you may get this.

The command for tcl interpreter is "tclsh" and for Tk applications it is "wish". Do you have these in your path?

Didier Spaier 02-17-2009 11:34 AM


Originally Posted by varaahan (Post 3447062)
I have installed the full dvd version of slackware 12.2 yet tcl / tk is not there.

It should be there. May be a problem with your installation media ?

I suggest you try this, as root (I suppose you mounted your DVD as /media/dvd; change that to fit your DVD's mount point):

upgradepkg --install-new --reinstall /media/dvd/slackware/tcl/*tgz
This should install or reinstall all tcl/tk related packages.

FYI (I keep a local mirror of the distribution up to date with rsync):

bash-3.1$ cd /home/ne_pas_sauvegarder/slackware-12.2/slackware/tcl/
bash-3.1$ ls -1 *tgz

If you do not have one of these packages, you can get it using the Slackware Package Browser.

varaahan 02-17-2009 08:51 PM

When I login as root I could invoke tkpppoe and connec to internet. But I could not do so as ordinary user. I have marked "Allow non=root users" option in tkpppoe.
As ordinary user I get the tkpppoe running but it doesn't connect to net.
Checked file permissions for pppoe-start / stop and resolv.conf and they are ok.

root@darkstar:/home/sridhar# ls -l /etc/ppp/resolv.conf
-rwxr-xr-x 1 root root 54 2009-02-18 08:15 /etc/ppp/resolv.conf

root@darkstar:/home/sridhar# ls -l /usr/sbin/pppoe-start
-rwxr-xr-x 1 root root 5599 2009-02-17 22:11 /usr/sbin/pppoe-start

root@darkstar:/home/sridhar# ls -l /usr/sbin/pppoe-stop
-rwxr-xr-x 1 root root 2323 2009-02-17 22:11 /usr/sbin/pppoe-stop

root@darkstar:/home/sridhar# ls -l /usr/bin/tkpppoe
-rwxr-xr-x 1 root root 108493 2009-02-17 21:48 /usr/bin/tkpppoe

Ilgar 02-18-2009 02:43 AM

Then you obviously have Tcl/Tk. In the first example that you gave, you're trying to run tkpppoe as root. Please give the terminal output you get as an ordinary user.

guanx 02-18-2009 02:46 AM

A workaround: Try "ssh -Y root@" and run your script.

varaahan 02-18-2009 07:45 AM

Whe I ran tkpppoe as normal user I get the dialog box of tkppoe but when I press the start button nothing happens and I could not connect to net.

This problem is with slackware only. I can run this s/w successfully in other distros (Arch , PCLOS, Zenwalk etc. )

Ilgar 02-18-2009 10:11 AM

Are there any log files? I think we need more debugging info. But it's likely to be some sort of permissions problem.

varaahan 02-20-2009 05:56 AM

I agree. I tried changing to a+x for /etc/ppp , pap-secrets, resolv.conf etc but still the problem persists.

I don't have the log file .

Didier Spaier 02-20-2009 11:20 AM

chmod a+x only make theses files executable by all. That is not the point.

Check who is authorized to read/write on theses files instead.

All times are GMT -5. The time now is 08:35 PM.