LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 10-04-2006, 02:42 AM   #1
oneminizut
LQ Newbie
 
Registered: Jan 2006
Location: Washington, US
Distribution: Slackware 11.0 Kernel 2.6.17.13
Posts: 20

Rep: Reputation: 0
Where is my init.d?


Probably a very simple question, but I recently installed Slack 11 and am running 2.6.18 kernel. Everything is working fine or I am getting it there. My only real problem so far is that when adding the new kernel I used the .tgz package so I didn't get to opt for loading my acpi modules. No problem, did that later with insmod. Now to try to get the changes to stick I tried update-modules and I get the response
"command not found" so simple enough, it doesn't exist, but where do I find it? Also I wanted to add some power saving scripts to /etc/init.d
and it's not there. I know I fouled up somewhere but damned if I can figure it out.
 
Old 10-04-2006, 02:46 AM   #2
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,161
Blog Entries: 4

Rep: Reputation: 136Reputation: 136
In slackware you have the rc.d folder. There's no init.d folder. It uses BSD style init scripts.
 
Old 10-04-2006, 03:10 AM   #3
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 6,658

Rep: Reputation: 3976Reputation: 3976Reputation: 3976Reputation: 3976Reputation: 3976Reputation: 3976Reputation: 3976Reputation: 3976Reputation: 3976Reputation: 3976Reputation: 3976
Try adding "/sbin/modprobe" commands for your modules to the file /etc/rc.d/rc.modules
The command "update-modules" is something of Debian I think.

Eric
 
Old 10-04-2006, 04:38 PM   #4
oneminizut
LQ Newbie
 
Registered: Jan 2006
Location: Washington, US
Distribution: Slackware 11.0 Kernel 2.6.17.13
Posts: 20

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Alien Bob
Try adding "/sbin/modprobe" commands for your modules to the file /etc/rc.d/rc.modules
The command "update-modules" is something of Debian I think.

Eric
Ok, thanks for pointing that out. Now I want to load the modules like processor.ko, fan.ko, battery.ko. The rc.modules file states that it will look for them under /lib/modules/<version> But they are actually located in /lib/modules/<ver>/kernel/drivers/acpi

Do I assume that it will look that deeply into the directory?

Also, when I edit rc.modules would I include the .ko extension or no?

Like this maybe

### ACPI Power blah blah ###
/sbin/modprobe processor.ko

or

/sbin/modprobe processor

Any help I appreciate.
 
Old 10-04-2006, 04:41 PM   #5
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 6,658

Rep: Reputation: 3976Reputation: 3976Reputation: 3976Reputation: 3976Reputation: 3976Reputation: 3976Reputation: 3976Reputation: 3976Reputation: 3976Reputation: 3976Reputation: 3976
The module extension is not needed:
Code:
sbin/modprobe processor
Modprobe will know where to look.

Eric
 
Old 10-04-2006, 04:44 PM   #6
oneminizut
LQ Newbie
 
Registered: Jan 2006
Location: Washington, US
Distribution: Slackware 11.0 Kernel 2.6.17.13
Posts: 20

Original Poster
Rep: Reputation: 0
Thanks, your the best!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel Panic No init found. Try passing init..... Adrian Baker Mandriva 2 02-28-2005 11:47 AM
Redhat linux9.0:System hangs,if gives init 3 or init 4 Sailaja Reddy Linux - Newbie 4 09-16-2004 03:19 AM
Kernal Panic: No init found. Try passing init= option to kernel raees Linux - General 12 03-18-2004 11:10 PM
error: No init found. Try passing the init= option to the Kernel neylitalo Linux - Laptop and Netbook 3 01-22-2004 09:34 PM
error "Kernel panic: No init found. Try passing init= option Anauj0101 Linux - Newbie 3 05-06-2003 10:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration