LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-28-2020, 06:30 PM   #16
andrew.46
Senior Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 1,135

Rep: Reputation: 325Reputation: 325Reputation: 325Reputation: 325

In a '1st world problem' I can see my penguins on every boot but since I upgraded to a 16 core, 32 thread, CPU I do not see all of them; I have to imagine them trailing off into the empty space next to the monitor
 
1 members found this post helpful.
Old 03-29-2020, 06:57 PM   #17
gus3
Member
 
Registered: Jun 2014
Distribution: Slackware (x86 and ARM)
Posts: 322

Rep: Reputation: Disabled
Or "Madagascar"?
 
3 members found this post helpful.
Old 06-28-2020, 08:32 AM   #18
3rensho
Member
 
Registered: Mar 2008
Location: Switzerland
Distribution: Slackware64-current
Posts: 421

Rep: Reputation: 106Reputation: 106
Hazel, did you ever get your penguins back? I was just modifying my /etc/default/grub file (after Didier Spaier gave me the fix for something) and found this that I had annotated some time ago (my old memory is going) -

Code:
#
# Added to get penguins back. https://www.linuxquestions.org/questions/slackware-14/kernel-4-19-x-no-more-tux-in-boot-screen-and-led-blinking-on-suspend-4175644736/page2.html
#
GRUB_CMDLINE_LINUX_DEFAULT="fbcon=nodefer"
Not sure if it would help in your case but worth a look maybe.
 
Old 06-28-2020, 09:14 AM   #19
hazel
Senior Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: LFS, AntiX, Slackware, OpenBSD
Posts: 4,383

Original Poster
Blog Entries: 11

Rep: Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474
No, I never got them back. And I just checked for an fbcon module and it isn't present. No mention of it in modules.builtin either. The only thing in the config file that seems relevant is CONFIG_DRM_VMWGFX_FBCON, which is on. I know there used to be an fbcon module in earlier kernels; I remember building it in LFS. I wonder if it still exists.

Maybe this is relevant:
Quote:
Originally Posted by kernel docs/latest/fb/fbcon
Unfortunately, if your bootline includes a vga=xxx parameter that sets the hardware in graphics mode, such as when loading vesafb, vgacon will not load. Instead, vgacon will replace the default boot console with dummycon, and you won’t get any display after detaching fbcon.
I've always put vga=normal on my command line. Is that no longer a good idea?

Last edited by hazel; 06-28-2020 at 09:17 AM.
 
Old 06-28-2020, 02:43 PM   #20
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 2,506

Rep: Reputation: 749Reputation: 749Reputation: 749Reputation: 749Reputation: 749Reputation: 749Reputation: 749
Where have my penguins gone?

That will stop the penguins from appearing.
 
1 members found this post helpful.
Old 06-28-2020, 05:32 PM   #21
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware14.2 64-Bit Desktop, Devuan 2.0 ASCII Toshiba Satellite Notebook
Posts: 2,913

Rep: Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838
I mistakenly attributed the disappearance due to the nouveau driver - and when I installed the blacklist , my framebuffer and penguins would now remain - it is not the case on --Current as it always disappears after a certain point. Overall I never made a fuss about it, but since this thread I guess I will post what I see; and can confirm the penguins up and disappear:


Click image for larger version

Name:	VirtualBox_Slackware_28_06_2020_17_29_20.png
Views:	34
Size:	40.0 KB
ID:	33521Click image for larger version

Name:	VirtualBox_Slackware_28_06_2020_17_29_26.png
Views:	32
Size:	25.5 KB
ID:	33522
 
Old 06-28-2020, 07:13 PM   #22
fido_dogstoyevsky
Member
 
Registered: Feb 2015
Location: Victoria, Australia
Distribution: Slackware 14.2
Posts: 392
Blog Entries: 2

Rep: Reputation: 473Reputation: 473Reputation: 473Reputation: 473Reputation: 473
Quote:
Originally Posted by Richard Cranium View Post
Nobody responded with "Antarctica"?
That's because it's winter now, so most Antarctic penguins take the opportunity to migrate north to Australia. The driver isn't the cold in Antarctica, it's because the marine drop bears are dormant this time of year.
 
Old 06-28-2020, 08:34 PM   #23
jr_bob_dobbs
Member
 
Registered: Mar 2009
Distribution: Slackware,Linux From Scratch
Posts: 443
Blog Entries: 64

Rep: Reputation: 75
I'm not sure if this helps or not, but I've always had the opposite situation of wanting to get rid of the penguins. Currently (Slackare 64, Current installed in March) I added "logo.nolog" to the "append" line in my lilo.conf. I don't see how one could *accidently* do that but what do I know?

p.s. Remember the Bugs Bunny cartoon where Bugs meets a lost penguin and then helps him get home?
 
Old 06-29-2020, 02:43 AM   #24
pchristy
Member
 
Registered: Oct 2012
Location: UK
Distribution: Slackware
Posts: 492

Rep: Reputation: Disabled
Quote:
Originally Posted by hazel View Post
I've always put vga=normal on my command line. Is that no longer a good idea?
Most of my systems use an EFI bios these days, but on one older machine I've set vga=791 (1024x768x64K) and I get penguins on it. It currently uses a cheap Radeon gfx card, but also worked when I had an old NVidia card in it.

--
Pete
 
1 members found this post helpful.
Old 06-29-2020, 12:17 PM   #25
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware14.2 64-Bit Desktop, Devuan 2.0 ASCII Toshiba Satellite Notebook
Posts: 2,913

Rep: Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838
Quote:
Originally Posted by Jeebizz View Post
I mistakenly attributed the disappearance due to the nouveau driver - and when I installed the blacklist , my framebuffer and penguins would now remain - it is not the case on --Current as it always disappears after a certain point. Overall I never made a fuss about it, but since this thread I guess I will post what I see; and can confirm the penguins up and disappear:


To clarify - in 14.2 my actual machine - when I first installed Slackware nouveau was installed by default and at a certain point the same behavior would occur, I would have the penguins and then at one point the screen would refresh and the penguins would be gone; once I blacklisted the nouveau driver, that stopped and I had the penguins all the way through. I don't know why that is, and I do not know why in current that is no longer the case; then again Current is in a vm. *shrug*
 
Old 06-29-2020, 12:29 PM   #26
pchristy
Member
 
Registered: Oct 2012
Location: UK
Distribution: Slackware
Posts: 492

Rep: Reputation: Disabled
On all my machines, the penguins only appear for the initial part of boot. Once the proper graphics driver loads (rather than the frame buffer used for the initial part of boot), the penguins disappear.

--
Pete
 
Old 06-29-2020, 12:39 PM   #27
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware14.2 64-Bit Desktop, Devuan 2.0 ASCII Toshiba Satellite Notebook
Posts: 2,913

Rep: Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838
Quote:
Originally Posted by pchristy View Post
On all my machines, the penguins only appear for the initial part of boot. Once the proper graphics driver loads (rather than the frame buffer used for the initial part of boot), the penguins disappear.

--
Pete
I am dumb so this is why I am asking - I thought the driver (graphics) itself is not at all loaded until xorg starts? At least that as what I thought since if you boot Slackware as is, you are not automatically placed in an xsession. If I am wrong and the driver is loaded prior even xorg is started (either automatically or startx) I'd like to have that clarified.
 
Old 06-29-2020, 12:47 PM   #28
pchristy
Member
 
Registered: Oct 2012
Location: UK
Distribution: Slackware
Posts: 492

Rep: Reputation: Disabled
I'm no expert here, but my understanding is that the vesa frame buffer is used initially, then at some point the graphics driver gets loaded by the kernel. X eventually *configures* it, but up to that point it just uses a default setting.

Certainly, the screen blanks momentarily at the point that the penguins disappear, and then comes back in a completely different resolution. This appears to be the point at which the graphics driver proper takes over from the vesa frame buffer.

However, I stand to be corrected!

--
Pete
 
Old 06-29-2020, 02:27 PM   #29
hazel
Senior Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: LFS, AntiX, Slackware, OpenBSD
Posts: 4,383

Original Poster
Blog Entries: 11

Rep: Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474
Quote:
Originally Posted by Jeebizz View Post
I am dumb so this is why I am asking - I thought the driver (graphics) itself is not at all loaded until xorg starts? At least that as what I thought since if you boot Slackware as is, you are not automatically placed in an xsession. If I am wrong and the driver is loaded prior even xorg is started (either automatically or startx) I'd like to have that clarified.
Graphics doesn't necessarily mean X. Yes, it's true that Slackware starts at a virtual console by default (though I believe you can easily configure it to use kdm for a graphical login), but the Linux kernel includes a thing called a framebuffer that can provide read-only graphics.

There are quite a few command line display programs that use framebuffer graphics.

Last edited by hazel; 06-29-2020 at 02:32 PM.
 
Old 06-30-2020, 05:50 AM   #30
hazel
Senior Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: LFS, AntiX, Slackware, OpenBSD
Posts: 4,383

Original Poster
Blog Entries: 11

Rep: Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474
To get back to my original beef, taking "vga=normal" off my kernel command line doesn't bring my penguins back. I get the impression that the earliest stage of the boot (before the first kernel messages appear)becomes a bit slower, but there is no other change.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: How Can Cool Penguins Have Such Hot Heads? LXer Syndicated Linux News 0 11-21-2009 10:01 PM
Why does my GRUB menu screen sometimes have dancing penguins? statguy SUSE / openSUSE 6 09-21-2007 01:26 PM
LXer: Penguins die after truckload of penguins spill on Texas highway LXer Syndicated Linux News 0 08-09-2006 03:33 PM
kde sound options gone except for root, login sound gone memphisSuseUser Linux - Distributions 2 12-10-2004 05:55 PM
RPM was gone, Now it's back Though it might as well be gone Null Linux - Software 1 03-02-2003 03:55 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration