LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-24-2009, 04:58 PM   #1
lumacho
LQ Newbie
 
Registered: Sep 2009
Location: Turin
Distribution: Slackware 13.0
Posts: 23

Rep: Reputation: 15
Where alsa looks for the default sound card??


Like topic, I need to know where alsa looks for the default audio card... I've got a webcam that works well, and an intel sound card that (maybe) works... The fact is that my webcam (that works, please don't reply me to disable it...) is seen as sound card, and it's the default one (number 0), and the true sound card is seen as sound card number 1...
If i run
Code:
alsamixer
I can see the levelless (is this english? :P ) mixer for the webcam (eheh)
If I run
Code:
alsamixer -c 1
I can see the levels of the sound card (this make me think that the sound card can works...)
So, how can I say to alsa that the default card is the #1??

Fabio.
 
Old 09-24-2009, 05:14 PM   #2
kukibl
Member
 
Registered: Jun 2008
Distribution: Slackware64
Posts: 68

Rep: Reputation: 20
I believe you should check /etc/modprobe.d/sound (or alsa file). I'm not at Slack machine right now.
 
Old 09-24-2009, 05:42 PM   #3
GazL
Senior Member
 
Registered: May 2008
Posts: 4,480
Blog Entries: 7

Rep: Reputation: 1960Reputation: 1960Reputation: 1960Reputation: 1960Reputation: 1960Reputation: 1960Reputation: 1960Reputation: 1960Reputation: 1960Reputation: 1960Reputation: 1960
I had the same issue on my box. Create yourself a /etc/modprobe.d/sound.conf containing something along the lines of:

Code:
options snd slots=snd-hda-intel,snd-usb-audio
This tells alsa to use the hda-intel driver as card 0 and the usb webcam as card 1. If your system doesn't use the hda-intel driver you'll need to replace that with whatever driver is appropriate for your hardware.
 
Old 09-24-2009, 05:54 PM   #4
lumacho
LQ Newbie
 
Registered: Sep 2009
Location: Turin
Distribution: Slackware 13.0
Posts: 23

Original Poster
Rep: Reputation: 15
Great!!! Thank you GazL, it works
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Default Sound card replica9000 Linux - Hardware 3 08-25-2008 12:59 PM
Sound card conflict with Vid-Capture card ALSA Optimistic Debian 5 11-06-2007 12:20 AM
USB sound card not detected by ALSA but is by lsusb, using alsa 1.0.15 mjkelly93 Linux - Hardware 1 10-20-2007 11:23 AM
ALSA not working for Creative Sound Blaster Live 24 Bit sound card vishalsonu Linux - Hardware 7 08-20-2005 02:02 PM
No sound with a CM8738 sound card -- alsa installed istar80 Linux - Hardware 1 06-17-2005 03:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration