LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-21-2007, 02:23 PM   #1
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),OpenSuse 13.2 (Laptop & Desktop),, OpenSuse 13.2 on the wifes lappy
Posts: 781

Rep: Reputation: 98
When session locked by kde screensaver, password not recognised


Hi all,
A quick description of my problem. When the KDE screensaver cuts in, I would like to have the ability to lock the session unless the user password is entered, just as it looks as though it is possible to do fron the Kcontrol centre. Trouble is, although the session gets locked, when inputting the user password, and without exception, the screensaver fails to unlock, with an 'incorrect password' being the reason given. The KDE docs say that the pasword to enter is just the users password, so now I am stuck with my pc not able to be session locked when the screensaver kicks in. As I use this pc in an office, and because this function doesn't seem to work, at the moment I do not have session lock enabled. This is not very secure as you can understand. Anyone any ideas why this happens, and how to put it right.
BTW, normal login for users from KDM works fine, as does console login.

Also tried the suggestion from KDE forum about setting kcheckpassword suid root, but it is still the same. All other suggestions I have found via google recommend using PAM, which PV doesn't include in Slack.

Last edited by vdemuth; 07-21-2007 at 02:47 PM.
 
Old 07-21-2007, 05:43 PM   #2
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 6, KDE Neon
Posts: 4,313

Rep: Reputation: 212Reputation: 212Reputation: 212
I once had that problem and found out my keyboard settings were not correct when I logged into my desktop, therefore the incorrect characters was being used when I typed my password to unlock my screensaver.
 
Old 12-02-2007, 03:49 AM   #3
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),OpenSuse 13.2 (Laptop & Desktop),, OpenSuse 13.2 on the wifes lappy
Posts: 781

Original Poster
Rep: Reputation: 98
Anyone got any more ideas as the keyboard is set correctly
 
Old 12-05-2007, 03:57 PM   #4
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
Is your password made only from latin (ASCII charset) letters? Actually, I don't know if it's possible to include other languages letters in your password, but it's better to make sure.

When you enter kcheckpass into the terminal, does it work for you or not?

Last edited by Alien_Hominid; 12-05-2007 at 04:02 PM.
 
Old 12-05-2007, 06:50 PM   #5
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 6, KDE Neon
Posts: 4,313

Rep: Reputation: 212Reputation: 212Reputation: 212
Quote:
Originally Posted by Alien_Hominid View Post
kcheckpass
Cheers for that command
 
Old 12-06-2007, 01:25 AM   #6
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),OpenSuse 13.2 (Laptop & Desktop),, OpenSuse 13.2 on the wifes lappy
Posts: 781

Original Poster
Rep: Reputation: 98
Password is only composed of latin characters. Running kcheckpass returns authentication failure. Any idea why this is. As I said, login from KDM is fine, and the password is recognised there and at the cli.

TIA
 
Old 12-10-2007, 04:13 PM   #7
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
Does su(-ing) to another user work or not?
 
Old 12-12-2007, 11:45 AM   #8
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),OpenSuse 13.2 (Laptop & Desktop),, OpenSuse 13.2 on the wifes lappy
Posts: 781

Original Poster
Rep: Reputation: 98
Yep, su to root then running kcheckpass works fine, so must be some file somewhere presumably with some permission that needs setting. I have added myself to the shadow group just in case it was as simple as that, but with no luck. Have also changed permissions on the /etc/password and /etc/shadow file, again with the same result. Any more ideas?

OK, a combination of the above, with setting a new password seems to have done the trick.

Last edited by vdemuth; 12-12-2007 at 01:55 PM. Reason: problem solved
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Session close when screensaver start on FC6 japega Linux - Laptop and Netbook 1 06-13-2007 08:45 PM
is it possible to reload a locked x-session (kde) from another terminal nass Slackware 5 06-10-2007 02:50 PM
Making screensaver run when screen is locked akurtis Fedora 2 06-04-2005 09:15 PM
SuSE 9.1 'Switch User' when screensaver is locked Cichlasoma Linux - Distributions 1 07-20-2004 07:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration