-   Slackware (
-   -   When Ever I Update to Current (

FXRS 04-16-2004 09:15 PM

When Ever I Update to Current
I crash something. Here are my errors that I am getting........

1- Mixer_Applet2 Process 2441 has crashed

2- OAIFD:Gnome_MixerApplet Details: Unknown Corba excetion id: :1.0

I also don't have a "speaker Icon" or mixer. (Probably caused it crashed)

Here is my lsmod..............

bash-2.05b$ lsmod
Module Size Used by Not tainted
snd-pcm-oss 37860 0 (unused)
snd-mixer-oss 12536 0 [snd-pcm-oss]
keybdev 2052 0 (unused)
mousedev 4212 1
hid 21092 0 (unused)
usbmouse 2040 0 (unused)
input 3200 0 [keybdev mousedev hid usbmouse]
uhci 24508 0 (unused)
ehci-hcd 17644 0 (unused)
usbcore 59436 1 [hid usbmouse uhci ehci-hcd]
i810_rng 2528 0 (unused)
snd-intel8x0 18888 0 (unused)
gameport 1420 0 [snd-intel8x0]
snd-mpu401-uart 3200 0 [snd-intel8x0]
snd-rawmidi 12768 0 [snd-mpu401-uart]
snd-seq-device 3888 0 [snd-rawmidi]
snd-intel8x0m 9892 0
snd-pcm 55880 0 [snd-pcm-oss snd-intel8x0 snd-intel8x0m]
snd-timer 13572 0 [snd-pcm]
snd-page-alloc 6324 0 [snd-intel8x0 snd-intel8x0m snd-pcm]
snd-ac97-codec 44508 0 [snd-intel8x0 snd-intel8x0m]
snd 30340 0 [snd-pcm-oss snd-mixer-oss snd-intel8x0 snd-mpu401-uart snd-rawmidi snd-seq-device snd-intel8x0m snd-pcm snd-timer snd-ac97-codec]
soundcore 3396 7 [snd]
ohci1394 24112 0 (unused)
ieee1394 42372 0 [ohci1394]
8139too 14216 1
mii 2272 0 [8139too]
crc32 2880 0 [8139too]
ds 6612 1
yenta_socket 10336 1
pcmcia_core 39972 0 [ds yenta_socket]
ide-scsi 9360 0
agpgart 44036 0 (unused)

Now if I just leave it alone after installing and don't update I have no problems at all.

Any ideas?

Thanks again for the help.


motub 04-17-2004 02:52 AM

Are you using Slackware GNOME, or Dropline GNOME? What are you using to update...swaret? Slapt-get? If so, and you're using Dropline, have you excluded the GNOME files installed by Dropline from any update facilities? They are designated *.1dl.tgz for this very reason.

It sounds to me like your update is trying to overwrite Dropline files with Slackware files while they are in use... and if Dropline was completely compatible with GNOME-standard, it wouldn't need to be a separate installer and set of processes, it seems to me.

FXRS 04-17-2004 10:30 AM

Nope just striaght up regular old Gnome.


tigerflag 04-17-2004 11:39 AM

As motub asked, what tool are you using to update? Swaret?
If you're using Swaret there have been a LOT of problems updating v9.1 to -current. Use the Search feature at the top of the page, and you might find some answers already posted. I'm not trying to scold about searching first before asking a question, I'm just saying that there's already a lot of information about this upgrade problem in the boards, in particular to losing sound/Alsa. Some of us have decided to use Swaret just to keep v9.1 up to date, and wait for the next official release, rather than upgrade to -current with Swaret.

Siri Amrit

FXRS 04-17-2004 03:35 PM

Well I just installed and updated on the wifes laptop and it works great. Course she has a Dell Latitude C600 with maestro (spelling) sound deal and seems to work great. Maybe I'll just reinstall Slack on my laptop and leave it as is until the official comes out like stated.

Yes I was using Swaret too. Sorry for not answering that the first time around.

Thanks for the help anyways.


FXRS 04-19-2004 02:13 AM

Here is a update on my laptop. Like I said everything with the upgrade on the wifes laptop went without a hitch, but on mine I had a ruff time with the sound.

Hopefully this will help others out. Not sure if I did this in the correct manner or not, but its working, so here it goes....................

After doing alot of reading I kind of pieced this all together.

Update swaret with the "current" in the conf. file
Then upgrade, even the kernel, so "comment" out the "Exclude" for the kernel and let it update.

So run "swaret --upgrade"
Let it do its thing.

When asked for "y" or "n" on packages I said "y" to all EXCEPT anything to do with alsa. I DID NOT upgrade alsa at all.

When it was done with its upgrading I ran "updatedb" and then "/sbin/lilo" for the kernel upgrade. Just to be sure. I have read where swaret or the upgrade process will do this automatically, but I ran it just to be sure.

Now I didn't have sound on the reboot so what I did, after reading alot is I went to and got the latest drivers, lib and utils and downloaded them into a dir I made called "alsa"

From there I went to this page
and followed it step by step.

Now I have "intel8x0 sound and it worked for me. Now I'd imagine if anyone else is having this trouble would pick out thier card in the database there and followed the install instructions they would have just as good as luck as me.


All times are GMT -5. The time now is 05:19 AM.