LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-07-2005, 05:02 AM   #1
coal-fire-ice
Member
 
Registered: Nov 2004
Location: SE England
Distribution: Debian, SUSE, Ubuntu, Slackware
Posts: 147

Rep: Reputation: 15
wheel on usb mouse doesnt work


Basically i have a usb mouse with a wheel, and i keep trying to use it to scroll up and down pages, but it doesnt work, so any tip to help me to get it to work would be much appreciated, im a newbie to using linux, so the more specific the info, the better
thanks in advance.
 
Old 07-07-2005, 05:35 AM   #2
Mirari
LQ Newbie
 
Registered: Feb 2005
Location: CT
Distribution: Slackware 10.1
Posts: 21

Rep: Reputation: 15
In xorg.conf
Find "Input Device"
Add this line to your xorg.conf file.
Option "ZAxisMapping" "4 5"
Then restart X. Should fix that problem.
 
Old 07-07-2005, 05:54 AM   #3
coal-fire-ice
Member
 
Registered: Nov 2004
Location: SE England
Distribution: Debian, SUSE, Ubuntu, Slackware
Posts: 147

Original Poster
Rep: Reputation: 15
im a complete linux idiot, so how do you find xorg.conf, and then how do you restart x without rebooting?

Last edited by coal-fire-ice; 07-07-2005 at 06:23 AM.
 
Old 07-07-2005, 09:29 AM   #4
ghight
Member
 
Registered: Jan 2003
Location: Indiana
Distribution: Centos, RedHat Enterprise, Slackware
Posts: 524

Rep: Reputation: 30
xorg.conf should be in /etc/X11. All "conf" files will be somewhere under /etc. If it's not obvious, you will need to be root to edit it.

To restart X without rebooting hit CTL-ATL-BACKSPACE.

If the ZAxisMapping doesn't work, let us know, there are a few other things you can try, but it would be helpful to know what kind of mouse it is and if it's attached to a desktop or a laptop. If it's a laptop, what kind? More info never hurts to get the best answer possible.
 
Old 07-07-2005, 10:27 AM   #5
coal-fire-ice
Member
 
Registered: Nov 2004
Location: SE England
Distribution: Debian, SUSE, Ubuntu, Slackware
Posts: 147

Original Poster
Rep: Reputation: 15
it didnt work,

its an old 450mhz piii desktop, and the mouse is a usb wheelmouse from labtec, just two buttons and a wheel.
 
Old 07-07-2005, 10:35 AM   #6
maginotjr
Member
 
Registered: Aug 2004
Location: BR - Floripa
Distribution: Ubuntu 9.10 - 2.6.x.x
Posts: 661

Rep: Reputation: 34
go to command line type

su, and login as root.


now you type "mc -e /etc/X11/xorg.conf"

now find the Section "InputDevice"

in this section is where is you mouse configuration. Now you have to add a line like this

Code:
Option "ZAxisMapping" "4 5"
be aware to look if these two option are seted:
Code:
Option      "Protocol"      "imPS/2"
Option      "Emulate3Buttons"
if dont create them.

restart your X server ( ctrl-alt-backspace )

ps: next time try searching in the forum, there is many post with your same question, a simple search for "mouse wheel" can return a lot of results.

Last edited by maginotjr; 07-07-2005 at 10:37 AM.
 
Old 07-07-2005, 11:32 AM   #7
coal-fire-ice
Member
 
Registered: Nov 2004
Location: SE England
Distribution: Debian, SUSE, Ubuntu, Slackware
Posts: 147

Original Poster
Rep: Reputation: 15
'now you type "mc -e /etc/X11/xorg.conf"'

when i did that, it said "ERROR - Cannot open file for reading: /etc/x11/xorg.conf'
 
Old 07-07-2005, 11:34 AM   #8
Namaseit
Member
 
Registered: Dec 2003
Distribution: Slackware
Posts: 325

Rep: Reputation: 30
in /etc/x11/xorg.conf the 'x11' should be 'X11' in uppercase. It's case sensitive.
 
Old 07-07-2005, 12:22 PM   #9
coal-fire-ice
Member
 
Registered: Nov 2004
Location: SE England
Distribution: Debian, SUSE, Ubuntu, Slackware
Posts: 147

Original Poster
Rep: Reputation: 15
nope still dont work, thanks anyway, ill try the search thingy
 
Old 07-07-2005, 12:42 PM   #10
maginotjr
Member
 
Registered: Aug 2004
Location: BR - Floripa
Distribution: Ubuntu 9.10 - 2.6.x.x
Posts: 661

Rep: Reputation: 34
Quote:
Originally posted by coal-fire-ice
nope still dont work, thanks anyway, ill try the search thingy

if you write it right will work, there is no secret about it, this is the way to make your scroll wheel work, see if you're typing everything right, you may try change the mc -e for pico

e.g:
Code:
 root@maginotjr:~# pico /etc/X11/xorg.conf
the mouse section look like this:
Code:
Section "InputDevice"
Identifier "mouse0"
Option "Driver" "mouse"
Option  "Protocol"  "imps/2"
Option  "Device" "/dev/mouse"
Option "Emulate3Buttons"
Option "ZAxisMapping" "4 5"
EndSection

Last edited by maginotjr; 07-07-2005 at 12:43 PM.
 
Old 07-07-2005, 01:21 PM   #11
coal-fire-ice
Member
 
Registered: Nov 2004
Location: SE England
Distribution: Debian, SUSE, Ubuntu, Slackware
Posts: 147

Original Poster
Rep: Reputation: 15
thankyou - i thought about it for a while, then noticed that i shouldnt have been putting hashes in front of each line, - thankyou for the help, it works fine now.
 
Old 07-07-2005, 01:22 PM   #12
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
You shouldn't use Emulate3Buttons option unless you've a 2 button mouse which I guess you don't, and also, try using "ExplorerPS/2" as protocol and putting a Option "Buttons" "5" before Zaxismapping.
 
Old 07-07-2005, 01:37 PM   #13
maginotjr
Member
 
Registered: Aug 2004
Location: BR - Floripa
Distribution: Ubuntu 9.10 - 2.6.x.x
Posts: 661

Rep: Reputation: 34
Quote:
Originally posted by gbonvehi
You shouldn't use Emulate3Buttons option unless you've a 2 button mouse which I guess you don't, and also, try using "ExplorerPS/2" as protocol and putting a Option "Buttons" "5" before Zaxismapping.

Its not right use ExplorerPS/2 if he are using an USB mouse, the right is imps/2 or he may have problems with the scrool wheel forwarding pages in Firefox, and I said to use the emulate3buttons cause he sayd have a 2 buttons old mouse.... and besides this options dont make no harm if he has a 3, 4 or more buttons mouse, like me for example.
 
Old 10-18-2005, 01:05 PM   #14
kitcatcher
LQ Newbie
 
Registered: Sep 2004
Location: columbus, oh
Distribution: Slackware 10.2, College 2.5, Knoppix 4.0.2, Coyote Router
Posts: 11

Rep: Reputation: 0
Smile This worked for me

Thank you maginotjr!


This solution also worked for me.

I was having trouble with Slackware 10.2 with a logitech (Dell) usb mouse with wheel.
So I did the search and found this thread, followed its advice, and everything is cool now!

Kit Catcher

Last edited by kitcatcher; 10-18-2005 at 01:11 PM.
 
Old 10-18-2005, 03:01 PM   #15
maginotjr
Member
 
Registered: Aug 2004
Location: BR - Floripa
Distribution: Ubuntu 9.10 - 2.6.x.x
Posts: 661

Rep: Reputation: 34
you welcome!

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Usb mouse doesnt work in slack10.2 samgu3990 Linux - Laptop and Netbook 2 11-06-2005 03:23 PM
Why doesnt my USB mouse doesnt work? barkha Linux - Hardware 2 08-16-2005 12:31 PM
usb mouse doesnt work, light comes on youneedaclue Linux - Laptop and Netbook 17 09-16-2004 10:07 PM
Can't get Dell USB wheel mouse to work cscott *BSD 8 06-13-2004 11:28 AM
wheel trigger on the Mouse doesnt run?? emin Linux - General 7 10-07-2002 12:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration