-   Slackware (
-   -   whats wrong with my sound (

sio 02-08-2005 11:07 AM

whats wrong with my sound
installed 10.1 (2.4.29 k) yesterday and today it just occured to me i have no sound (office computer)

and I'm stumped. If i let the hutplug system detect hardware everything registers fine. I could use alsamixer, kmix everything acts just like it should. If i play something, nothing argues with me about anything. From a console if i run mpg123 song.mp3 it acts like its playing. But I have no sound.

And I know what this sounds like, and I can say no, its not a I didn't set the volume levels in the mixers right. There's only one lead I have and thats in gnome (running stock 2.6). The volume control says "sorry no mixer elements and/or devices found" but its there! i swear!

anyone have any thoughts?

I also meant to say, If I disable hotplug and run alsaconf to have it setup the modules.conf file appropriately, everything behaves exactly as above.

keefaz 02-08-2005 11:33 AM

Have you a ~/.asoundrc file ?
Or did you try to mv /etc/asound.state /etc/asoundrc.bak and
then run alsaconf again ?

sio 02-08-2005 12:59 PM

I do not have a ~/.asoundrc file as user or root
I moved the asound.state file and reran alsaconf, normally in the past I wouldn't need to reboot but it didn't work so i rebooted, and it still isn't working.

I'm stumped, I get no errors from anything anywhere anyhow except from gnome's volume control, everything else acts like its all normal.

keefaz 02-08-2005 01:10 PM

Did you check audio cables, etc...
Did you try play sound with the alsa tool : aplay <sound file>

sio 02-08-2005 02:15 PM

Yeah, ive tried aplay and it acts totally normal like its playing. Ive also taken the speakers and plugged them into another computer and they work fine, and to boot this pc has an internal speaker that kicks on when externals are unplugged and that still doesn't play. *shakes head* I think maybe I'll just try a different kernel/alsa combo some time or another. Sound was working fine before i went from 10 to 10.1 ( I formatted and did a clean install of 10.1 ) as I listen to music throughout the day. Today has been one quiet day though..

Gato Azul 02-09-2005 01:26 AM

I have the exact same problem -- sound was working great before on 10.0 and now did a fresh install of 10.1 and no sound whatsoever. I even have the same issue where volume control says "sorry no mixer elements and/or devices found" too! I've gone through and run alsaconfig, alsamixer (followed by alsactl store), downloaded the alsadriver archive and ran the snddevices script just in case the sound devices weren't set up properly, made sure my user account was under the audio and sys groups and still nothing. I had the same problem when I tried to upgrade alsa to the current version 1.0.8 when I was running VidaLinux, so that makes me suspect alsa as the culprit. My card uses the ens1371 module and alsaconfig picked it up and loaded the module (verified by lsmod). Still no sound though and I'm stumped :confused: I guess we both are...:scratch:

Just to verify that it's not some really bad timed hardware problem, I loaded up Slax to verify that sound works, and it does. Working on compiling Kernel 2.6.10 to see if Alsa likes that one a bit better. I'll let you know how it turns out...

zord 02-09-2005 06:50 AM

@sio: Did you try runnin alsaconf as root?

sio 02-09-2005 08:42 AM

finally im not alone in the world of no sound! You've done pretty much everything I've done Gato! and still no sound, I was suspecting ALSA as well as I've just seen so many weird things from it in the past, and I wasn't sure of the specifics on ALSA and the said kernel but it seemed like I remember that certain versions paired together. For example, in the past you couldn't always just update to a major revision of the alsa driver and not touch the kernel, otherwise no sound. Thus why I was saying I'll try a new kernel/alsa combo.

Hmm in this case mayhaps I'll just go ahead and upgrade to the 2.6.10 kernel under /testing would only take 5 minutes to setup. *shrugs* I'll think about it :D

Gato Azul 02-09-2005 04:25 PM

Eh, no luck with 2.6.10 and its associated alsa driver. I tried the ones in /testing, and then went ahead and compiled my own, but still no sound...I'm almost tempted to go back to 10.0...

But anyway, it does sound like we are having the same sort of problem, sio. I wonder if it's a bug in Alsa? :scratch:

sio 02-09-2005 04:39 PM

Hmm, tomorrow morning I'm going to try and fall back to the old kernel and alsa combo 10. If that doesn't work maybe I'll just go back to 10.0 *shrugs* not to many choices, this is just waaaayyy to weird.

Gato Azul 02-10-2005 11:09 AM

I just checked the output of dmesg | grep ALSA because I thought I saw something about an ALSA error while booting, and I saw these messages:

ALSA ../../alsa-kernel/pci/ac97/ac97_codec.c:1907: AC'97 0 does not respond - RESET
ALSA ../../alsa-kernel/pci/ac97/ac97_codec.c:1970: AC'97 0 analog subsections not ready

I'm really tempted to think that this all is a bug with ALSA because it used to work flawlessly for me with Slackware 10.0 (until I upgraded to the newest version of ALSA of course), but now it's completely dead. I Googled for others that had this problem and found some, but so far haven't come up with any solutions...

hammer29 02-12-2005 09:03 PM

Slackware > whats wrong with my sound
Slackware 10.1, 2.6.10 kernel KDE 3.3.2 Soundblaster Live
same {Sorry, no mixer elements and/or devices found}
error when I select volume control from KDE
playing streaming audio via XMMS as I type
audio CD's play with no problem.
I can change volume settings in KMIX

LinuxLuvr 02-13-2005 09:23 AM

I have the same problem. I have temporarily solved the problem by reverting back to the 2.4.26 kernel and alsa packages. Although I prefer Gnome, I'm also running KDE and everything is working. I suspect that the "Sorry, no mixer elements and/or devices found" is a problem with Gnome (Volume control does not work) and sound is a problem with the 2.4.29 kernel/modules. I'm going to uninstall Gnome from 10.1 and reinstall the '10.0' version. Has anyone tried compiling custom kernel and alsa?

roAder 02-13-2005 09:52 AM

I have the exact same problem(s).
I have met 2 other Slack 10.1 users who have thesame problem as us to.
Most likely a bug in ALSA.
Is there any way to contact the developers of ALSA?

soylentgreen 02-13-2005 10:26 AM

i had to re-compile ALSA when i did my kernel.

also, run alsamixer, and make sure you're not <MM> Muted

All times are GMT -5. The time now is 10:01 PM.