LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-07-2003, 04:04 AM   #1
jimdaworm
Member
 
Registered: Aug 2003
Location: Spain
Distribution: Ubuntu
Posts: 897

Rep: Reputation: 30
What am I doing wrong in my Fstab? Mounting for Users


I must have done somthing stupid wrong here... when I log in as a user and try to access the two vfat partitions it says permission denied.

Here is my fstab:

/dev/hda8 swap swap defaults 0 0
/dev/hda7 / ext2 defaults 1 1
/dev/hda6 /mnt/red ext2 defaults 1 2
/dev/hda5 /mnt/backup vfat auto,user,ro 0 0
/dev/hda1 /mnt/win98 vfat auto,user,ro 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,user,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,user,rw 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

I only need read access because I want to listen to my MP3īs !

Thanks
Adam
 
Old 11-07-2003, 04:08 AM   #2
Y0jiMb0
Member
 
Registered: Jul 2003
Location: Valencia (Spain)
Distribution: slackware 11, FEDORA CORE 4, RHEL3, Gentoo...
Posts: 361

Rep: Reputation: 30
Hi!
maybe this can help you

http://www.linuxquestions.org/questi...hreadid=112941

Regards
 
Old 11-07-2003, 10:18 AM   #3
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
I think 'auto' and 'user' means that it's being mounted at boot (so by root, in essence) and is restricted to the 'user' who mounted it. So just change 'user' to 'users' and you should be able to access it as a normal user.
 
Old 11-07-2003, 11:38 AM   #4
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
For a FAT32 filesystem I'd use:

defaults,umask=000

in the 4th field of the relevant entries in /etc/fstab
 
Old 11-07-2003, 01:46 PM   #5
jimdaworm
Member
 
Registered: Aug 2003
Location: Spain
Distribution: Ubuntu
Posts: 897

Original Poster
Rep: Reputation: 30
Thanks for the info!

Thanks guys I am going to give these ideas ago... I am pretty sure I will get it to work now, but will get back to you with my results!


Thanks again for the help Skyline digiot and Y0jiMb0

Adam
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Whats wrong with this line of fstab Boffy Linux - General 4 02-25-2005 04:32 PM
what is wrong with this /etc/fstab entry? d1l2w3 Linux - Hardware 10 01-31-2005 11:15 PM
fstab defaults sets wrong permissions dibblethewrecke Linux - Newbie 3 12-11-2004 02:10 PM
fstab entry changed by system to wrong device cmbguy Linux - General 2 08-19-2004 09:04 PM
fstab error in line 11, what's wrong? EPa Linux - Networking 4 03-06-2004 10:46 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration