LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 10-24-2018, 10:46 AM   #1
The_Dark_Passenger
Member
 
Registered: Apr 2018
Distribution: Slackware64 14.2 & -Current
Posts: 91

Rep: Reputation: Disabled
wget always requires --no-check-certificate


Hello,

I have several systems running Slackware64 14.2, and all exhibit the same behavior.

Whenever I try to download anything over a secure connection with wget, I must use --no-check-certificate, or else I get an error locally verifying the certificate.

For example:
Code:
wget https://github.com/linode/longview/archive/v1.1.5.tar.gz
--2018-10-24 11:37:10--  https://github.com/linode/longview/archive/v1.1.5.tar.gz
Resolving github.com... 192.30.253.112, 192.30.253.113
Connecting to github.com|192.30.253.112|:443... connected.
ERROR: cannot verify github.com's certificate, issued by 'CN=DigiCert SHA2 Extended Validation Server CA,OU=www.digicert.com,O=DigiCert Inc,C=US':
  Unable to locally verify the issuer's authority.
To connect to github.com insecurely, use `--no-check-certificate'.
This is problematic in this case, as I am running a script provided by Linode, and cannot pass on the --no-check-certificate. How do I resolve this, as it appears that wget just isn't able to find the certs locally to verify with at all?

My openssl.cnf file is left default.

Any help is appreciated! Thank you!

Last edited by The_Dark_Passenger; 10-25-2018 at 09:06 AM.
 
Old 10-24-2018, 11:15 AM   #2
mralk3
Slackware Contributor
 
Registered: May 2015
Distribution: Slackware
Posts: 1,798

Rep: Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996
wget always requires --no-check-certificate

Try as root:

update-ca-certificates -f

Then retry the download. You may need to update the ca-certificates package first. If you apply all system updates this shout not be a problem.

Last edited by mralk3; 10-24-2018 at 11:20 AM.
 
3 members found this post helpful.
Old 10-25-2018, 05:00 AM   #3
ehartman
Senior Member
 
Registered: Jul 2007
Location: Delft, The Netherlands
Distribution: Slackware
Posts: 1,674

Rep: Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886
Quote:
Originally Posted by mralk3 View Post
You may need to update the ca-certificates package first.
As he's still on 14.2, that won't work, all of the 14.? releases have ca-certificates-20161130 as their latest update. He probably has to get the one from slackware[64]-current (ca-certificates-20180409) and update to that by hand. It is a no-arch package and will work in 14.? too (I know, I did that).
The thing to watch out after that is that slackpkg (etc) will just as happily DOWNgrade you again to the older package.
 
1 members found this post helpful.
Old 10-25-2018, 06:44 AM   #4
l0f4r0
Member
 
Registered: Jul 2018
Location: Paris
Distribution: Debian
Posts: 900

Rep: Reputation: 289Reputation: 289Reputation: 289
Quote:
Originally Posted by The_Dark_Passenger View Post
This is problematic in this case, as I am running a script provided by Linode, and cannot pass on the --no-check-certificate.
Maybe it's not the best option because you would not check certificate but please, out of curiosity, why can't you pass on the --no-check-certificate option?
Can't you modify the script?
 
Old 10-25-2018, 08:10 AM   #5
montagdude
Senior Member
 
Registered: Apr 2016
Distribution: Slackware
Posts: 1,983

Rep: Reputation: 1594Reputation: 1594Reputation: 1594Reputation: 1594Reputation: 1594Reputation: 1594Reputation: 1594Reputation: 1594Reputation: 1594Reputation: 1594Reputation: 1594
You should be able to solve this without having to type --no-check-certificate by adding check_certificate = off in ~/.wgetrc.
 
Old 10-25-2018, 09:06 AM   #6
The_Dark_Passenger
Member
 
Registered: Apr 2018
Distribution: Slackware64 14.2 & -Current
Posts: 91

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by mralk3 View Post
Try as root:

update-ca-certificates -f

Then retry the download. You may need to update the ca-certificates package first. If you apply all system updates this shout not be a problem.
After installing perl and running this as root, that solved the issue. Thanks everyone!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Adding wget check certificate functionality to the mini rootfs Linux.tar.gz Slackware - ARM 2 10-11-2017 06:38 AM
wget certificate error z9721 Debian 9 02-26-2014 03:05 PM
Check certificate of a server frater Programming 7 11-18-2012 07:12 AM
wget -c website's certificate verification TheIndependentAquarius Linux - Software 15 08-29-2011 02:46 PM
Adobe Acrobate Reader Requires A Plugin-That Requires Open LDAP That Requires Berkely Old_Fogie Slackware 10 05-08-2006 05:04 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration