-   Slackware (
-   -   Westell Versalink model 327W; Cannot setup wireless or wired connection. (

$Linuxnoob 06-13-2007 12:27 PM

Westell Versalink model 327W; Cannot setup wireless or wired connection.
Hello all,

Let me say out front, I searched this forum and attempted to resolve this with the previous posts about the similar topic. However, I have had no luck with google or that solution. I tried netconfig, but I don't believe I'm using a DCHP connection because I haven't set anything like this up.

Forgive my naiivity but I am sincerely lacking on this subject insofar as knowledge is concerned.

on Windows it works stellar my wireless and wired to the router connection, here at slack 11 it won't recognize my Ethernet connection out of the box nor will it my wireless which I didn't think it would.

here is some info which may be necessary for any help:
RealtekRTL8139 Family PCI Faster Ethernet NIC #2
Broadcom 802.11b/g WLAN

here is my output of ifconfig:

etho0 Link encap: Ethernet Hwaddr 00:C0:9f:Ad:69:AA
inet addr: Bcast: 255:255:255:255
up broadcast notrailers running multicast
MTU 1500 Metric:1
RX packets: 0 errors:0 dropped:0 overuns:0
TX" "carrier:- collision:0 txquelen:0
RX bytes:0 (0.0b) tx bytes 0 (0.0b)

lo link encap:local loopback
inet addr: Mask:
up loopback running mtu 16436 metric:1
rx packets " same as etho0"
tx packets " same as etho0"
rx bytes " " tx bytes " "

I also tried:
ping -c3
(which by the way I don't know if thats my ip, but, I found that when using ifconfig)

64 bytes from icmp_seq1 ttl=64 time-.022ms
64 bytes from icmp_seq2 ttl=64 time-.005ms
64 bytes from icmp_seq3 ttl=64 time-.002ms

--- ping statistics ---
3 packets transmitted, 3 recieved, 0% packet loss, time 2016 ms rtt min/avg/max/mdev .002/0.009/0.022/.009ms

if there are any ridiculous errors in that bare in mind I typed it, because its on my other machine the slackware/win xp, which slackware won't get internet, obviously enough not this one.

H_TeXMeX_H 06-13-2007 12:34 PM

The 'RealtekRTL8139' uses the '8139too' or '8139cp' module. So:

What kernel are you using ? Did you install the modules ? What is the ouput of 'lsmod' and 'lspci' ?

$Linuxnoob 06-13-2007 12:40 PM

first off
thank you thank you thank you.


module size used by not tainted
ds 6612 1 yenta-socket 10532 1
pcmcia_core 39492 0 [ds yenta_socket]
ide-scsi 9392 0
8139too 13672 1
mii 2304 0 [8139too]
crc32 2880 0 [8139too]

kernel -> default for slackware 11 I believe 2.4

&& do you need lspci still its a lot of typing, but i'll do it if it can help you help me.


00:00:0 Host bridge: ATI technologies inc RS480 host bridge (rev 01)
0:01:0 PCI bridge: ATI technologies INC rs480 pci bridge
0:12:0 USB controller:ATI technologies INC SB400 USB host controller
0:13:0 USB controller:ATI technologies INC SB400 USB host controller
0:13:1 USB controller:ATI technologies INC SB400 USB2 host controller
SMBus: ATI technologies INC IXP SB400 SMBus Controller (rev 11)
00:14:1 IDE Interface: ATI technologies INC standalone dual channel PCI IDE controller ATI
00:14:3 ISA bridge: ATI technologies INC ixp sb400 pci-isa bridge
00:14:4 PCI bridge: ATI technologies INC ixp sb400 pci-isa bridge
00:14:05Multimedia audio controller: ATI technologies INC IXP sb400 AC'97 audio controller (rev 02)
00:14:6Modem: ATI technologies INC ati sb400- ac'98 modem controller (rev 02)
00:18:00Host Bridge: advanced micro devices (AMC) k8 [Athlon 64/opteron] hypertransport technology configuration
00:18.02 Host Bridge: advanced micro devices (AMC) k8 [Athlon 64/opteron] address map
00:18:03Host Bridge: advanced micro devices (AMC) k8 [Athlon 64/opteron] DRAM controller
00:18:05 Host Bridge: advanced micro devices (AMC) k8 [Athlon 64/opteron] misc. control
1:05.0 VGA compatible controller: ATI technologies INC ATI Radeon XPress 200m 5955 (PCIE)
5:00.0 Ethernet controller: Realtek semiconducter co ltd. ltd-8139/8139c/9139c+ (rev 10)
5:02.0 network controller braodcom corp. BCM4318 [Airforce one 54g] 802.11g wireless lan controller rev 02

H_TeXMeX_H 06-13-2007 01:16 PM

It looks as if the NIC should be working properly


8139too 13672 1 <this is the right module>
5:00.0 Ethernet controller: Realtek semiconducter co ltd. ltd-8139/8139c/9139c+ (rev 10)
So, now all you need to do is configure it properly. You should run 'netconfig' as root to configure it. Make sure to use DHCP, don't enter any IP addresses, you want it to get those automatically. So all you enter is a hostname and a domain name, then use DHCP for the rest.

You can read more about how to do this here:

Also, I hope you didn't type all the output of those commands out. Usually you can copy and paste, or redirect to a file, open that, and copy and paste.

$Linuxnoob 06-13-2007 01:56 PM

for the dchp (i always thought that was for special cases....) never realized thats what my router was shooting out.

For for network name just leave it blank??

I did netconfig. however, when I try to go to a website it says an error occured while loading given site, unknown host of given site.

H_TeXMeX_H 06-13-2007 02:02 PM

No, you should not leave it blank. You probably should leave the DHCP hostname blank in most cases.

So your machine is directly hooked up to a router, and the router uses DHCP, right ?

$Linuxnoob 06-13-2007 02:19 PM

I don't know if the router uses DHCP ( I barely understand what that is let alone if my machine uses it ) I'm simply going off your extensible understanding. You say DHCP I say ok. But i dunno. My compy is directly connected to the aforementioned router.

thank you again. but as of now my internet still is inactive.

$Linuxnoob 06-13-2007 02:21 PM

thus far it won't allow me to leave the hostname blank nor will it allow me to leave the domain name blank. I then select dhcp and leave that part blank.

H_TeXMeX_H 06-13-2007 03:18 PM

One thing you can do, if DHCP doesn't work, is check the settings on Window$. It's somewhere in the settings. Then apply those settings to Slackware.

$Linuxnoob 06-13-2007 04:04 PM

what is window$

Where can I find it? Sorry if you made it obvious and I just didn't understand.

H_TeXMeX_H 06-13-2007 04:26 PM

You seem to be at least triple booting (Fedora core 5 Ubuntu 6 Slackware 11(if and when I get it running)). Does this card work on there with this router ? If so, get the settings that those distros use.

P.S. By Window$, I mean the one made and distributed by Bill Gate$, and $teve Ballmer. (yes, they should probably change their names, so I stop replacing S with $)

$Linuxnoob 06-13-2007 04:31 PM

only dual boot, just haven't got around to changing the ubuntu and fedora yet. I have slackware and xp on this machine currently. xp works flawlessly, it has the nessesary drivers and they woprk. slackware apparently has the essential drivers, they just decide not to work I suppose. Or I'm not telling them properly how if/and when to work.

$Linuxnoob 06-13-2007 04:34 PM

windows simply takes my sid and my web code off the back of my router and then picks up the single, also it sences the single off the bat, unlike slack which doesn't even recognize a wireless single or recognize and ethernet plug in my compy.

H_TeXMeX_H 06-13-2007 04:35 PM

Yes, in XP, check the network setting. I haven't used it in quite a while. There should be settings on there that may help you set up the connection on Slackware. Then you could use a static IP and fill the rest in.

If you don't use DHCP (and as it seems, it doesn't work), you'll have to use 'netconfig', but enter all the details manually. You can get all these details by booting into XP, opening up your network settings or information or whatever (somewhere in the control panel, I'm betting) and writing it down.

$Linuxnoob 06-13-2007 05:02 PM

ok that will work i'll try that and come back on tomorrow and tell you how that goes, thank for the assistance, hopefully it will work. Later for now i'm off to work.

All times are GMT -5. The time now is 06:14 AM.