-   Slackware (
-   -   weird ps/2 mouse behaviour (

macbeth8 04-04-2008 05:57 AM

weird ps/2 mouse behaviour
I'm running current Slackware and have some sort of trouble with my ps/2 mouse. I use generic kernel and use rc.modules to load psmouse module. The problem is that when kde is loaded, the mouse moves faster than it should and when I click once, it generates double click, so for example if I click on a word in browser or text editor, it is selected or when I click on the top of some window, it always maximizes, etc.
However when I am in KDE and run
modprobe -r psmouse
modprobe psmouse

then suddenly everything is normal and mouse works fine.

The strange behaviour comes back if I switch from X to another console using ctrl+alt+f#num and then back to X with ctrl+alt+f7...

I tried to use "IMPS/2" or "Auto" protocols in xorg.conf,
to comment out proto=imps in rc.modules on the line with /sbin/modprobe psmouse (but it makes no difference)
also tried to put
modprobe -r psmouse
modprobe psmouse
into rc.local, but nothing of these seems to work...

Any ideas appreciated...

dive 04-04-2008 11:11 AM

Have you tried other protos, like ExplorerPS/2 ?

macbeth8 04-04-2008 11:48 AM

I've tried only proto=imps or without proto option yet. And to be honest, I don't know where to change it... in /etc/rc.d/rc.modules or /etc/modprobe.d/psmouse ? I think both should work...
In rc.modules, it is written that these options should be specified in modprobe.d/psmouse

Is there any simpler way to find out which proto should work? I don't want to restart once for every try of the proto option... when I reinsert the module in KDE, it works with option proto=imps, why doesn't it work when it is inserted during boot?

I forgot to mention before that I have Genius NetScroll optical ps/2 mouse, maybe that helps...

PS: Very good photos ;)

dive 04-05-2008 10:34 AM

Yes change it in /etc/modprobe.d/psmouse:

options psmouse proto=exps

You could try changing it xorg.conf too to see if that works on its own:

Option "Protocol" "ExplorerPS/2"

Glad you like the photos - thanks.

All times are GMT -5. The time now is 04:32 PM.