-   Slackware (
-   -   Weird Hangups: Slackware 12.0, E17 (

trashbird1240 09-05-2007 08:43 AM

Weird Hangups: Slackware 12.0, E17
Howdy Forum,

The last two nights, I've left my workplace machine in xlock and have come back in the morning to find it totally non-responsive: the monitor light is blinking, indicating it's getting no signal, and no keyboarding can rescue it. I've also pinged from elsewhere in the network here, with no response. It's still running (I can hear it and the light's on ;)).

I'm using:

*Slackware 12.0
*Enlightenment DR17 from Slacke17
*xlock (not Xscreensaver)

I've previously had uptimes of a couple months where nothing substantially went wrong.

I've looked at .xsession-errors, Xorg.#.log and other places. Where should I look for any potential error logs?


perry 09-05-2007 11:04 AM

Could be anything!
Have you done your updates? Have you configured a kernel to fit your processor ?

Feel free to take a look at my how-to (see below) and do a check list...

- Perry

trashbird1240 09-05-2007 11:43 AM


Originally Posted by perry (Post 2882109)
Have you done your updates? Have you configured a kernel to fit your processor ?

Fit? Aint it the same size as all the others?

In all seriousness, it's a Pentium 4, should I require any customization? I'll take a look at your guide.


I'm a little skeptical that this would have anything to do with the processor because the system has run smoothly on generic kernels for nine months. I switched window managers and then this problem came up. How would switching window managers suddenly make the kernel unfit? Wouldn't that be a problem for the Enlightenment developers, instead of the kernel developers, and me?

Please explain more.


trashbird1240 09-05-2007 11:48 AM

Okay, I see your question differently now. No, I have not customized the kernel, I'm using a generic kernel, and everything has worked fine.

I'm a little concerned about your statement about the kernel packages: I have had no problems with USB or any other devices on either machine, and my home machine has all USB peripherals except for the monitor (duh).


dracolich 09-05-2007 04:35 PM

What window managers did you switch to and from? And what kind of graphics card does the machine use? I remember one time I was going to try XFCE on my laptop, which has the infamous ATI IGP320M, and the laptop would always freeze just as XFCE was beginning to load. Have you tried switching back to the previous wm to see if the problem goes away?

trashbird1240 09-06-2007 09:12 AM

I solved this by preventing auto suspend. I did two things, one of
which solved this, although using both is probably heavy-handed, I'm
rather safe and logged in, with remote access to my machine than

In the Enlightenment Configuration Panel, go to Screen, and un-check
any Power Management or Screen Saver options --- as in DO NOT use the

Then, edit (or ask your administrator to edit)
/etc/enlightenment/sysactions.conf. The file includes an explanation
of how to edit so as to allow and deny particular users the right to
suspend or reboot the computer. I just added


user: joel  deny: *
to this file, thereby denying myself the authority to reboot, suspend
or "hibernate" the computer.

I'm pretty sure the screensaver did it, because without editing the
.conf file, I have not had this problem at home. Either that or there
is some hardware based difference between the machines (my home
machine is much newer).

Thanks for weighing in,

All times are GMT -5. The time now is 02:28 AM.