LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   wee bit laggish (https://www.linuxquestions.org/questions/slackware-14/wee-bit-laggish-69220/)

php_rocks 07-01-2003 02:44 AM

wee bit laggish
 
hello,

i have had slackware 9 on my system for about a week now and in that time the biggest change i made was i reconfigured my kernel and am now using 2.4.21 instead of the 2.4.20.

my problem is, when i first boot my computer and run mozilla it lags my mouse and keyboard somewhat but i dont remember it doing that before i re-configed my kernel.

it's not just with mozilla... it lags when i untar something (normal, i know.. but it seems a little too laggish).

does anyone know what i could have configured wrong or any clue as to what is causing the lag?

i have a pretty slim kernel too, boots pretty quick, its nice... and, i use a lightweight wm--fluxbox.

i have a decent system:

P4 2.4 GHz 533 FSB
DDR333 512 MB RAM
80 GB 7200/RPM HDD

thanks,
-sean

php_rocks 07-01-2003 08:47 PM

no one knows?

DrOzz 07-01-2003 08:50 PM

i know my uncle had the same problem with the laggy mouse and whatnot, and i told him to issue the command as root "killall magicdev" at the prompt to kill that daemon and it went away...for some reason it was hogging alot of his memory and that ended being the problem so we took it outta his startup...
and just too show specs also he has a gig of ram with an xp2400+ also with an 80gig drive.., so its not like his machine was a piece of junk either.
just give it a try and see if that helps you too..

contrasutra 07-01-2003 09:18 PM

Maybe your mouse sensitivity is too low. Try raising it. That helps my "lag" feeling. Unfortunatly, I dont know how to change it for all of X. I always just use the util that comes w/ XFCE4. Oh well, im sure you can find out how. Its probobly in the mouse section of XF86Config.

Also, run "top" and see if a certain process is running really high memory or CPU. Sometimes a process can just be eating up your CPU for strage reasons.

Azmeen 07-02-2003 10:33 AM

Check your IDE, ATA and ATAPI Block devices settings in the kernel configs. It's advisable to enable Generic PCI bus-master DMA support and Use PCI DMA by default when available options.

Another thing your might want to consider is optimizing your Hard Disk access settings using hdparm... A nice reference can be found here.

Hope this helps :)


All times are GMT -5. The time now is 09:23 PM.