LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-16-2005, 03:53 PM   #1
steveel
LQ Newbie
 
Registered: Nov 2005
Posts: 13

Rep: Reputation: 0
webcam problem pwc install


loaded pwc onto 2.4.26, ran make menuconfig, make modules, make modules_install, seemed ok. ran modprobe pwc, failed with
insmod /lib/modules/2.4.26/kernel/drivers/media/videodev.o.gz no such file, (same) failed, insmod pwc failed.

Any offers on what it is looking for? Video4linux perhaps? How do I fix? (for reasons I won't go into, I cannot use any other kernel). Help appreciated.
 
Old 11-16-2005, 04:01 PM   #2
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Yes, it's looking for Video for Linux module. Select it as module under Multimedia devices -> Video for Linux and run make modules && make modules_install
 
Old 11-16-2005, 04:43 PM   #3
steveel
LQ Newbie
 
Registered: Nov 2005
Posts: 13

Original Poster
Rep: Reputation: 0
thanks for the reply, I have checked menuconfig and video support is installed as standard. I checked the folder and video.o is there, but not video.o.gz, which is what modprobe pwc is complaining about. I wonder if there is a problem in the calling modules or whatever (sorry, newbie guess) If the code line is calling video.o.gz instead of video.o because of a typo, that would do it, although I notice that video.o.gz magically turns into video.o after modprobe runs over the folder. (either that or linux magically turns .o.gz to .o) Sigh. Can't understand why it asks for video.o.gz when video.o is already there.
 
Old 11-17-2005, 10:22 PM   #4
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Well, I don't know about your configuration, but remember the changes you make, must be modules if you're not reinstalling the whole kernel, be sure of that.
Usually, the modules are compressed with gzip to save space since they're not accesed often (only when loading), so if you see a .o module, try gzipping it with: gzip file.o
Remember that pwc was complaining about videodev, not video.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How To Install A Usb Webcam [Genius WebCam on Suse 9.1 Personal] ofvergara SUSE / openSUSE 4 11-29-2006 12:09 PM
Pwc : philips webcam installation bytesurfer Linux - Hardware 0 10-01-2005 10:41 AM
pwc driver for webcam won't compile on debian silex_88 Linux - Software 2 08-30-2005 02:07 PM
PWC PWCX Logitech Webcam! Help! jamieunb Linux - Hardware 1 08-19-2004 01:13 AM
Creative Webcam 5 (PWC) & Mandrake 9.1 veletron Linux - Hardware 3 03-12-2004 05:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration