-   Slackware (
-   -   Webcam on slackware using KDE (

zyrtech 12-03-2003 06:42 AM

Webcam on slackware using KDE
I have a Logitech Quickcam zoom with USB.

It is recognized by slackware. But what do i do now ?

I tried to mknod the usb bus, and cat /dev/video0 > foo.png, but it didnt work.

Anybody want to tell me how to do this?

mrpdaemon 12-03-2003 01:06 PM

Get the latest Quickcam USB driver (it is actively developed, get it often) from CVS:

cvs login

(Just press enter, no password)

cvs -z3 co qc-usb

compile the driver with 'make all' , it needs to find your kernel headers (you have kernel source do you? get it if not) so either make the almighty symlink /usr/src/linux -> /usr/src/linux-2.your.version , or export LINUX_DIR=/path/to/your/linux

If all goes well, you end with quickcam.o , the quickcam module. Copy it to:


replacing 2.4.23 with your kernel version. Now 'insmod quickcam' will insert the module to the kernel. Hopefully, your camera will work perfectly at this point, launch gnomemeeting or camorama or (insert KDE video software here) and enjoy.

You might want to write 'insmod quickcam' in rc.modules, so that it happens at boot.

Good luck.

zyrtech 12-04-2003 04:20 AM

I tried with the PRO 4000 cam. It worked. I got it responding with 'stream' from the xawtv package. I used 'stream' to capture 1 frame, but all i got was a very blurred up green/black image. It is taking pictures because the blurr changes as i turn the camera :) What can i do to fix this ?

angelushu 10-15-2004 08:59 AM

Hi mrpdaemon
I've installed my quickcam just the way you said and then tryed to use xawtv and i got a bunch of errors:

bash-2.05b# xawtv
This is xawtv-3.94, running on Linux/i686 (2.4.26)
WARNING: Your X-Server has no DGA support.
/dev/video0 [v4l]: no overlay support
v4l-conf had some trouble, trying to continue anyway
Warning: Cannot convert string "-*-ledfixed-medium-r-*--39-*-*-*-c-*-*-*" to type FontStruct
ioctl: VIDIOCMCAPTURE(frame=0;height=120;width=160;format=7): Invalid argument
ioctl: VIDIOCSYNC(int=0): Input/output error
ioctl: VIDIOCMCAPTURE(frame=0;height=120;width=160;format=9): Invalid argument
ioctl: VIDIOCMCAPTURE(frame=0;height=120;width=160;format=5): Invalid argument
ioctl: VIDIOCMCAPTURE(frame=0;height=120;width=160;format=4): Invalid argument
ioctl: VIDIOCMCAPTURE(frame=0;height=120;width=160;format=1): Invalid argument
ioctl: VIDIOCMCAPTURE(frame=0;height=120;width=160;format=13): Invalid argument
no way to get: 384x288 32 bit TrueColor (LE: bgr-)

Can you please tell me what did i missed?!

All times are GMT -5. The time now is 10:11 PM.