-   Slackware (
-   -   was: `invalid slackpkg data base'; is: `overheating problem' (

w1k0 09-19-2012 01:31 AM

was: `invalid slackpkg data base'; is: `overheating problem'
Something wrong happened to my slackpkg data base. During the work of ‘slackpkg update’ command the machine halted because of the overheat. When I started ‘slackpkg update’ for the next time the program displayed the information that the ChangeLog.txt didn’t changed since my last update. Unfortunately the command ‘slackpkg upgrade-all’ downloads the files and immediately after the downloading removes the *.txz files leaving *.asc files alone. After the first pass that command starts to download all the packages anew removing them immediately after the downloading, etc. As a result I can’t update the system.

How can I repair the slackpkg data base in order to install the patches in the system?

markush 09-19-2012 02:00 AM


in a similar case I deleted all files in /var/lib/slackpkg/ and ran

slackpkg update
again (which rebuilds the database).

But be sure that the packagelist /var/log/packages isn't damaged.


w1k0 09-19-2012 11:57 AM

You meant of course /var/lib/slackpkg and /var/cache/packages/patches/packages.

There’s something wrong with my secondary machine. It isn’t able to finish ‘slackpkg update’. It breaks the work reaching the critical temperature (from 93°C to 95°C) and shuts down. I copied the above directories from the primary to the secondary machine in order to skip ‘slackpkg update’ command and the packages downloading. Unfortunately my secondary machine is unable to finish ‘slackpkg upgrade-all’ as well. It reaches the critical temperature and shuts down.

I can upgrade the packages installing them manually one by one but now it isn’t my biggest problem. The real problem is the overheating machine. Either old fan became inefficient or the silicon paste dried up.

Anyway thank you for the tip. The problem with upgrading the packages is solved. In the meantime the problem concerning the overheating arose.

markush 09-19-2012 12:09 PM


Originally Posted by w1k0 (Post 4784246)
You meant of course /var/lib/slackpkg and /var/cache/packages/patches/packages.

No, I meant only the files in /var/lib/slackpkg/ because these are the files which are renewed with "slackpkg update". Afterwards the issues due to a broken run of "slackpkg update" should be solved.


BTW: check if the ventilation is working correctly! Is the cooling disabled by some dust? I had this issue once with a laptop.

w1k0 09-19-2012 07:05 PM

It’s ThinkPad T40 that I bought a few years ago as a secondhand machine. According to Lenovo website it was released January 19, 2005. A few months ago the fan started to make a noise so I cleaned and oiled it. That machine works usually as a server. When I started Window Maker on it the CPU and the GPU temperatures seemed reasonable as well as the fan speed. But when I ran a few applications and started intensive browsing with Firefox the CPU temperature approached dangerously to 90°C. Maybe it wasn’t good idea to install Slackware 13.37 and the current Firefox on that machine. It seems it’ll be better to use it as a server only as I did so far.

TobiSGD 09-19-2012 08:29 PM

Which software you run on it is irrelevant, the cooling system should have been designed (and on IBM/Lenovo usually is) to keep the temperature in a reasonable range even when the CPU is working at 100%.
I would strongly recommend to check the cooling system.

w1k0 09-19-2012 08:39 PM

Thank you. I will.

schmatzler 09-20-2012 08:50 AM

I suggest you replace the thermal pad on the integrated graphics chip. The rubber pad.

If the laptop has been manufactured in 2005, it has dried out in the 7 years that followed.

90° are definitely too high.

I think this one would fit:

If you look further, you maybe find a cheaper alternative. But don't use the red ones, they only make it more worse.

w1k0 09-20-2012 01:12 PM

@ markush, TobiSGD, schmatzler,

Taking into consideration your suggestions I’ll refresh the entire cooling system. My problem has a broader perspective. I use three ThinkPad machines (in the post #5 I apparently misinterpreted the date of the release of my oldest ThinkPad):

1. T40 made August, 2003.

2. T60 made June, 2007.

3. X60s made May, 2007.

I bought all of them secondhand.

The T40 is well designed machine apart of the location of the fan that heats the left palm.

The T60 had two years of warranty when I bought it. During these two years the service replaced broken fan two times. So it seems the fans are the Achilles’ heel of T60 ThinkPads.

The X60s is a very small laptop. The parts inside are stuffed tightly. As a result it’s hot all the time especially from below and under the right palm.

That year the fans in all of these machines started to fail. I cleaned up and oiled the fans in T40 and T60. The T40 fan works silently now. The T60 fan produces some noise. As for X60s – the machine I like the most despite of the flaws of the design – I didn’t decide to disassemble it completely in order to clean and oil the fan so I put it away till I’ll buy a brand new fan.

The last year all these machines started to shutdown randomly when I don’t use them (at night). I couldn’t determine the cause of these shutdowns though I suspected the overheating. I confirmed that hypothesis trying to upgrade the packages on T40 and seeing the message about reaching the critical temperature. The /var/log/messages file registers only shutdown in such a case:


Sep 19 04:17:42 home logger: ACPI group processor / action CPU0 is not defined
Sep 19 04:17:53 home shutdown[10852]: shutting down for system halt
Sep 19 04:17:53 home logger: ACPI group thermal_zone / action THM0 is not defined
Sep 19 04:17:53 home init: Switching to runlevel: 0
Sep 19 04:17:53 home logger: ACPI group processor / action CPU0 is not defined

The other log files don’t register any relevant information.

The bottom line is I should refresh the entire cooling systems in all my machines. It’ll be expensive taking into consideration the prices of the secondhand ThinkPads but I don’t see the alternative.

The modern machines – including ThinkPads – don’t meet my demands. Old ThinkPads have three strong points: non-reflective 4:3 size screen, keyboard layout similar to the traditional keyboard, and very precise TrackPoint. All modern machines have so called “wide screens” and only some Dell Precision models offer the traditional keyboard including TrackPoint. (The modern ThinkPads in the best case have Insert key in a wrong place.)

Thank you guys for your kind assistance.

All times are GMT -5. The time now is 10:31 PM.