LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-30-2008, 03:26 PM   #16
Cuetzpallin
Member
 
Registered: Feb 2008
Location: Monterrey, MX
Distribution: Slackware since 3.4 and love it!!!
Posts: 162

Rep: Reputation: 31
Thumbs up


Quote:
Originally Posted by tramni1980 View Post
Actually I set the jumper to "cable select" because I did not see how to set it to "slave". At the instructions at the hard drive there is a specification for "master=on, slave=off" and "cable select". I did not see an option for "master=off,slave=on" or something like that. Probably I will ask a friend of mine to solve this.
As I remember, most of HD with this legend "master=on, slave=off", means that you can remove the jumper for a slave disk.

I saw on Seagate, and Samsung Disks
 
Old 05-30-2008, 04:03 PM   #17
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Quote:
Originally Posted by Cuetzpallin View Post
As I remember, most of HD with this legend "master=on, slave=off", means that you can remove the jumper for a slave disk.

I saw on Seagate, and Samsung Disks
Excellent point -- I missed the obvious there, but believe that to be correct, and also valid on Maxtor HDDs I have used in the past.
 
Old 05-30-2008, 06:44 PM   #18
onebuck
Moderator
 
Registered: Jan 2005
Location: Summer Midwest USA, Central Illinois, Winter Central Florida
Distribution: Slackware«
Posts: 13,213
Blog Entries: 29

Rep: Reputation: 2423Reputation: 2423Reputation: 2423Reputation: 2423Reputation: 2423Reputation: 2423Reputation: 2423Reputation: 2423Reputation: 2423Reputation: 2423Reputation: 2423
Hi,

The IDE drive jumpers will depend on drive manufacture. Most set the Master/Single with no jumper. Then for multiple drives you would select a Master/Slave with a jumper setting. You should google for the drive manufacture & model to get the jumper table settings. If you use the 'cs' then the position on the cable will decide device assignment. Some manufactures provide a jumper table physically on the drive. You might find a mask labeling on the PCB of the drive.

OP, you seemed to have a contention problem. The device jumpers were not set properly, if you want a Master/Slave then set the jumpers properly. Place the Master at the end of the cable.

If the drive is a current IDE then be sure to use a '80 conductor' cable, place the index (red/blue stripe) pointing to the power supply connector, most new drives have a key on the connector to prevent the connector from being placed incorrectly.
 
Old 05-30-2008, 11:15 PM   #19
armanox
Member
 
Registered: Sep 2005
Location: Baltimore, MD, USA
Distribution: Fedora, Gentoo, Debian, Slackware, IRIX, OS X
Posts: 192

Rep: Reputation: 32
A lot of drives will default to slave if the master jumper is not set. Many drives do not include a jumper to set for slave - they assume if master is off, slave is on, with CS being the exception to the rule.
 
Old 05-31-2008, 04:12 AM   #20
tramni1980
Member
 
Registered: Jul 2006
Location: Gie▀en, Germany
Distribution: Slackware64-14.2 & -current
Posts: 799

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by onebuck View Post
You should google for the drive manufacture & model to get the jumper table settings. If you use the 'cs' then the position on the cable will decide device assignment. Some manufactures provide a jumper table physically on the drive. You might find a mask labeling on the PCB of the drive.
Thank you for the advice. I found these:
http://www.seagate.com/images/suppor...5_family_1.gif
instructions for the jumper settings and just removed the jumper from the slave drive (which is SEAGATE,ST3160812A).
Quote:
Originally Posted by onebuck
OP, you seemed to have a contention problem. The device jumpers were not set properly, if you want a Master/Slave then set the jumpers properly. Place the Master at the end of the cable.
Actually the drives' jumpers were set properly previously. In fact the only change I made was to put the drives at their correct places on the 80-conductor cable. So far after several reboots things seem to be ok. Time will show.

Thank all of you for your responsiveness and collaboration.

Regards,
Martin
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Partition problems: half of my hard drive turned useless Executor21 Linux - Newbie 12 10-30-2007 06:13 PM
Hard Drive Problems: timeout waiting for DMA; error waiting for DMA mintee Linux - Hardware 10 09-21-2007 05:06 AM
"DMA on your hard drive was turned off" what is it? trainee Slackware 12 12-27-2005 04:17 PM
dma turned off? true_atlantis Linux - General 3 10-20-2004 08:48 AM
dma can't be turned on linoox Slackware 11 08-06-2004 11:42 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration