-   Slackware (
-   -   Wacom tablet on Slackware 12.1 (

sleekslack 05-04-2008 10:03 AM

Wacom tablet on Slackware 12.1
Hi, fellow slackers. I have a problem for making my Wacom Graphire
4 to work on 12.1. It's looks like my routine process doesn't work any more. Here's how I always do it on Slackware 12.0 and it's just work fine.

Using wacom driver from Linux Wacom project version 0.7.8-3

./configure --enable-wacom
make install

Copy prebuilt from prebuilt to /usr/lib/modules/input/

Create a 10-wacom.rules in /etc/udev/rules.d and add following to the file.

KERNEL=="event*", ATTRS{idVendor}=="056a", NAME="input/%k", SYMLINK+="input/wacom"
Add devices in xorg.conf then reboot.

That's all how I do it on 12.0, but in 12.1 it's just not work. First, I can't compile driver version 0.7.8-3, It gave me some errors, so I use 0.8.0, which can compile and follow the routine, but after reboot, my tablet seem to not working. I guess because this new kernel don't detect my usb Tablet.

It's not a big deal. I just reinstall Slackware 12.0 back on, where everything seem work to me. But if anyone got some solution on this issue, I'd be grateful.


Carpo 05-04-2008 12:19 PM

i compile and install the module and then add a line to rc.modules for it to modprobe it at boot up

Franklin 05-04-2008 01:02 PM

I'm running the following version with

linuxwacom-0.7.9-11 (development version)

I was also getting errors when building the stable version of the driver with the -current (now 12.1) kernel. This version builds clean with


Edit: Make sure you replace the kernel's wacom.ko with the wacom.ko from /linuxwacom-0.7.9-11/src/2.6.24
You did not say you did this in your initial post.

sleekslack 05-04-2008 02:30 PM

Thank you guys. I'll try it next time I install 12.1. Because of just reinstall 12.0 like this, so I don't wanna switch back and forth so often like that (^_^")

furryspider 05-14-2008 11:17 AM

I don't have the exact same problem, but I think it's close enough to continue this thread. If that's against any rules here (which I don't think) or established conventions that I'm not aware of, feel free to split the thread (or tell me so and I'll open another).

Here goes.
I'm using a Wacom Intuos 1 on the serial port with the X driver provided by linuxwacom. Up to Slack 12.0, this worked nicely, now after my switch to 12.1, it does not anymore. I've tried it with both linuxwacom 0.8.0-1 and 0.7.9-7 (both of which compiled flawlessly), but both yield the same results, which are these:

Wacdump and xidump report all pen movements and buttons correctly. There are no wacom related error messages that I can see when starting X. But I can't move the pointer or do clicks with the pen in the desktop environment. The mouse cursor just sits there. This is true for KDE and Xfce (standard 12.1 packages) as well as Enlightenment 16, so it doesn't seem to be a KDE glitch.

However! When I open GIMP or Krita, I can actually paint on their canvas areas with the pen. While doing this, I still don't see the mouse pointer move, so I have no indication of where I'm drawing. Immediately outside of the canvas (e. g. GIMP menu bar), the pen has no functionality.

Does anyone have an idea what's going on? I hope I'm just overlooking something stupid on my part, 'cause I'm not so thrilled by the thought of, like, having to recompile X with some option or other. ;-)

Thanks in advance!

Some more tidbits of information, if needed:
The server layout in xorg.conf (which I didn't change from 12.0) sends core events to the pen (InputDevice "pen1" "AlwaysCore"). My machine is a AMD Athlon 64 X2 4200 with 2 GB RAM and an nforce4 based board. Kernel and packages are standard 12.1 (with the exception of a few of my own packages which were already there when upgrading).

furryspider 05-17-2008 04:49 PM

After successfully double-checking the tablet's function with xinput, I discarded the faulty-X-theory and started fiddling with all kinds of configuration stuff.

Turns out that in the server layout in xorg.conf, AlwaysCore does now not any longer have the same effect as SendCoreEvents. With the latter, it works, like so:

#    InputDevice "pen1" "AlwaysCore"
#    InputDevice "eraser1" "AlwaysCore"
    InputDevice "pen1" "SendCoreEvents"
    InputDevice "eraser1" "SendCoreEvents"

Just in case someone stumbles upon the same problem.

mina86 08-14-2008 08:31 AM

I have the very same problem as sleekslack, except for that I'm not really keen on switching to 12.0. I'm running a slackware-current and my Bamboo works rather like mouse then a tablet.

I'm running a 2.6.25 kernel. I've tried to compile wacom drive into a kernel, compile it as a module and using a wacom.ko from linuxwacom (as suggested by Franklin) but nothing worked.

After running X I'm getting the following error message:

pad Wacom X driver grabbed event device
WACOM: unable to ioctl max values.
eraser Wacom X driver grabbed event device
WACOM: unable to ioctl max values.
stylus Wacom X driver grabbed event device
WACOM: unable to ioctl max values.

which is not logged in X server log file.

Anybody have any idea what to do about it?

mina86 08-14-2008 10:50 AM

OK, I've just found a solution -- I had to change /dev/input/event0 in /etc/X11/xorg.conf to /dev/input/event4. If one uses udev something like /dev/input/wacom should work as well.

Carpo 08-15-2008 03:24 PM

go to they have a buildscript for it and a link for you to add info to the xorg.conf file to get it working :)

Carpo 08-15-2008 03:27 PM

nevermind double post

sleekslack 08-15-2008 05:25 PM

Actually I got it working on Slackware 12.1 for quite sometime now as you can see the date of my first post, so I didn't dig this one up.

here's how I did it and my tablet is Wacom Graphire 4 on Slackware 12.1 with linuxwacom-0.8.0-3

1. Run ./configure --enable-wacom, make, make install as usual

NOTE: I didn't replace from prebuilt to /usr/lib/xorg/modules/input/

2. Copy wacom.ko from src/<kernel version> to
/lib/modules/<kernel version>/kernel/drivers/usr/input/

NOTE: "input" is a directory from mkdir, if it isn't there.

3. Run "depmod -a" without quotes but don't run modprobe yet.

4. Create a file /etc/udev/rules.d/10-wacom.rules and put udev's rule below in it.

KERNEL=="event*", ATTRS(idVendor)=="056a", NAME="input/%k", SYMLINK+="input/wacom"
5. Edit xorg.conf, add devices in ServerLayout section with

        InputDevice    "stylus"    "SendCoreEvents"
        InputDevice    "eraser"    "SendCoreEvents"
        InputDevice    "cursor"    "SendCoreEvents"
        InputDevice    "pad"

6. Still in xorg.conf, define all added devices, in my case, they look like below

Section "InputDevice"
  Driver        "wacom"
  Identifier    "stylus"
  Option        "Device"        "/dev/input/wacom"  # USB ONLY
  Option        "Type"          "stylus"
  Option        "USB"          "on"                  # USB ONLY

Section "InputDevice"
  Driver        "wacom"
  Identifier    "eraser"
  Option        "Device"        "/dev/input/wacom"  # USB ONLY
  Option        "Type"          "eraser"
  Option        "USB"          "on"                  # USB ONLY

Section "InputDevice"
  Driver        "wacom"
  Identifier    "cursor"
  Option        "Device"        "/dev/input/wacom"  # USB ONLY
  Option        "Type"          "cursor"
  Option        "USB"          "on"                  # USB ONLY

Section "InputDevice"
  Driver        "wacom"
  Identifier    "pad"
  Option        "Device"        "/dev/input/wacom"  # USB ONLY
  Option        "Type"          "pad"
  Option        "USB"          "on"                  # USB ONLY

7. Run "modprobe wacom" without quotes, checking /dev/input for wacom that if it's linked to event or not (for me is event2, but I guess it could be any numbers)

8. Restart X then configure preference in GIMP or use it as the way you like.

android1654 06-22-2009 05:31 PM

success in slackware 12.2
sleekslack's approach worked perfect for me using Slackware 12.2, wacom drivers 0.8.3-5, and an intuos2 tablet.

Thanks sleekslack!

snaketek 08-30-2009 12:49 AM

Thanks for the great post. I have been using this a a guide to get the wacom drivers to work on 13.0. I have been having some difficulty as there was no xorg.conf file to edit only the xorg.conf -vesa. I ran xorgsetup with root and it created the xorg.conf file that i needed to edit. I added what was directed and it resulted in a error saying something along the lines of "2 is not supported".

I configured and installed the linuxwacom 0.8.4 package.

I am a noob, any help would be greatly appreciated.


em21701 08-30-2009 09:23 AM

I am also trying to work through getting a wacom Intuos working on 13. So far there are some HAL fdi files that you can download that will get it working pretty well, but I have not gotten GIMP to recognise it as it used to.

samkook 10-15-2009 05:29 PM

I'm trying to install my graphire 4 CTE-440 using sleekslack instructions, but modprobe can't find the wacom module. The only thing I did different is putting wacom.ko into "/lib/modules/<kernel version>/kernel/drivers/input/" instead of "/lib/modules/<kernel version>/kernel/drivers/usr/input/" since I don't have the usr folder(I tried creating it and running depmod and modprobe again, but it still couldn't find it). And yes I substituted "<kernel version>" with my kernel version.

My linux kernel is in slackware 12.1(I think, I'm sure it's 12 something) and linux wacom drivers 0.8.4.

If I load in manually with insmod, it works like a mouse and I need to touch the tablet to be able to move which is not really great.

Anyone knows what could be wrong?

All times are GMT -5. The time now is 04:07 PM.