-   Slackware (
-   -   VyprVPN (

pchristy 04-26-2013 01:13 PM

Has anyone managed to get VyprVPN working under Slackware? If so, how?

All the instructions are aimed at Ubuntu users, and try as I might, I'm not making any headway with NetworkManager! I've added NetworkManager-openvnp-0.9.4 (haven't been able to locate a more recent version, and it seems pretty old), and think I've added all the needed information. But when I try and connect, I get a very helpful message in the syslog simply saying that "VPN plugin failed: 0" - which is nearly as helpful as most windoze error messages!

I've tried to get it to work on a Mageia machine, and that's even worse - it doesn't even offer half the required options in the menu! But it DOES have a script in /etc/sysconfig/network-scripts/vpn.d/openvpn/VyprVPN openvpn.conf which looks like it does something useful. But where should I copy that to on Slackware?

If anyone has got this to work, I would love to hear from them!


chrissi29 04-26-2013 03:15 PM

Hello Pete,

you can modifiy the slackbuild from for version 0.9.8 of networkmanager-openvpn. This one is working for my openvpn connections.

pchristy 04-27-2013 03:40 AM

Hi Chrissi29,

Thanks for the info. I have a working slackbuild script - what I couldn't find was any source code newer than 0.9.4! Where did you find 0.9.8?



chrissi29 04-27-2013 04:15 AM the same location as 0.9.4 in the slackbuild.

What I often do, is simply try to modifiy info and slackbuild to the newest version via sbopkg and try to run. Though the GPG check will fail then with all its drawbacks, mostly it's working.

pchristy 04-28-2013 09:25 AM

OK, finally cracked it! First of all, openvpn is an extra cost option on my service, with pptp being the default. This isn't immediately obvious from the sales blurb, which goes on at great length about the advantages of openvpn and how to set it up, without mentioning it being an extra cost option!

To make pptp vpn work on Slackware involves adding quite a few packages. For a start, if you roll your own kernel, make sure ppp is enabled. Then you need to compile and add NetworkManager-pptp. You will also need to compile pptp - a vpn client that is not part of the standard Slackware distribution. I'd done the first two, but didn't know that this third item was needed as well. Indeed, I didn't even know it existed! It was the syslog that gave me the clue!

During the course of all this, I recompiled all the NetworkManager stuff to 0.9.8 - the latest version. The base NetworkManager is in -current at the latest version, but you can't just install the package. Some of the dependencies have changed and it complains! I had to compile it from the -current source against my otherwise stock system. With 20/20 hindsight it would probably have worked with the stock 0.9.4 version....

Anyway, its all up and running now, though there seems to be quite a speed hit when using it!

Thanks for the hints and tips, Chrissi29!


All times are GMT -5. The time now is 12:16 AM.