-   Slackware (
-   -   vmware slackware13 guest with lvm root -> no boot :-( (

cosmonate 11-12-2009 07:29 AM

vmware slackware13 guest with lvm root -> no boot :-(
Hi folks,

i read and tried everything out now for 2 days but i can't get my virtual slack 13 to boot with a lvm root!

always the same problem

initrd works...
kernel loaded...
lvm modules are loaded...
scanning for lvms....
nothing happens for some seconds...
mount error! in my case:

"mount: mounting /dev/VolGroup00/root on /mnt failed: No such file or directory"

i even changed the setup and followed the readme_lvm.txt step by step because i thought i'm allready crazy! no chance!

current setup
1 virtual harddrive 10G (/dev/sda)
1 partition -> /dev/sda1
did all lvm stuff EXACTLY like in readme_lvm.txt for at least 20 times now!

used filesystems xfs, ext3 and ext4 -> no differences at all!!

i used an extra 100M boot partition, played around with lilo... no chance.. nothing works... the machine seems to boot but cannot "find/mount" the root volume after scan...

and why is he trying to mount the root volume to /mnt and not / ??

i'm on slackware since version 8.0 and not a linux noob overall! but this problem seems to be unsolvable to me at the moment! hopefully just because i cannot see the wood with so many trees in front of me (old german saying gg)

plz could anyone do some wood chopping :-)

any ideas or suggestions are very very appreciated!


disturbed1 11-12-2009 04:09 PM

What did you use for your initrd command?

mkinitrd -c -k -f ext4 -m ext4:mptspi:shpchp -r /dev/group01/root -L

For vmware you need the mptspi and shpchp modules.

cosmonate 11-17-2009 06:04 AM

thx a lot! worked perfectly!!!! slack now running in fusion.. next is to try opengl slack13 in virtualbox 3... wish me some luck :-D

All times are GMT -5. The time now is 03:38 PM.