-   Slackware (
-   -   VMWare on Slackware Current: massive display corruption (

senorsnor 02-21-2005 03:09 AM

VMWare on Slackware Current: massive display corruption
I used to run VMWare on Slackware current, well, not totally current: with XOrg 6.8.1, kernel 2.6.9, NVidia-drivers 6229, and that went ok.

Now I reinstalled with Slack 10.1, upgraded to current (xorg 6.8.2, kernel 2.6.10, NVidia-drivers 6229). Installed VMWare (both 4.5 and 5 Beta, latest version) and whenever I run it there's massive display corruption both inside and outside of the VMWare-window: there's two vertical purple bars on the right of the screen, and it looks like the color palette drops down to 256 colors for parts on the screen. Within the VMWare-screen there's less corruption but there are still some colors all over the place there that shouldn't be there. The corruption is on other desktops as well. Restarting the X-server makes it ok again. I tried downgrading XOrg to 6.8.1 and this didn't help, in fact it only made it worse ...

Anyone know what's going on?

tazdevil77 02-21-2005 04:25 AM


i have the same problem(since before 10.1).

"solved" it with:
right click on kde-desktop/click configure desktop/click display
and all is fine, but i dont know why.


senorsnor 02-21-2005 07:33 AM

Hmmm, I do have kde installed but never use it, I always use XFCE 4.2. I'll try to start up KDE and do as you told.

senorsnor 02-21-2005 06:22 PM

Well, I removed KDE completely (was about to do that anyway) but that didn't solve the problem. However, when I power on a virtual machine, the display becomes corrupt. If I start nvidia-settings then, suddenly all is back to normal, just before the nvidia-settings screen pops up. So I don't change anything, just starting up the nvidia-settings dialog makes the problem disappear ... I tried switching a few nvidia-settings but that didn't help.

Does anyone know what this means? Clues to solve it?

senorsnor 02-24-2005 01:30 PM

Yeah! I solved it, with thanks to the people at the vmware-forum :: I booted with framebuffer at 256 colors. Seems there's a bug in the framebuffer that changes registers "without telling" when vmware probes hardware, so there's wrong codings in the framebuffer-registers. Running framebuffer at 64k colors or more solves the problem! You can change this in lilo.conf.

All times are GMT -5. The time now is 06:59 AM.