-   Slackware (
-   -   Vmware for Slackware 11 (

the-yikes 05-07-2007 12:58 PM

Vmware for Slackware 11
Hi all before i start i want to point out that i have visited both of these sites and carreid out all the suggested methods for installing vmware on slackware 11.

none of them work!

When i try to configure vmware i get the following error:

root@darkstar:~/Desktop/vmware/vmware-server-distrib# /usr/bin/ --compile
Making sure services for VMware Server are stopped.

sh: /etc/vmware: is a directory
sh: /etc/vmware: is a directory
Unable to stop services for VMware Server

Execution aborted.

root@darkstar:~/Desktop/vmware/vmware-server-distrib# /usr/bin/
Making sure services for VMware Server are stopped.

sh: /etc/vmware: is a directory
sh: /etc/vmware: is a directory
Unable to stop services for VMware Server

Execution aborted.

N.B i get the same error with or without the compile argument. Has anyone ACTUALLY succeded in instaling VMware Server on slackware. If not can anyone recommend an alternative PLEASE:cry: .

The Yikes

H_TeXMeX_H 05-07-2007 01:18 PM

So you want a virtual machine. The only one I succeeded in installing was virtualbox.

You can install either the binary or from source.

the-yikes 05-07-2007 01:42 PM

Look's Promising!
Hey H_TeXMeX_h!

Sweet! just looked at the site looks promising, i'll give it a whirl and see what i think! Oh mna i've been tearing what litle hair i have left out over this! It's not that it's a life or death thing it's just that once i get an idea in my head i NEVER let go!

Well i'm finished downloading so chat to you soon!

Thanks Again! :)

the-yikes 05-07-2007 01:54 PM

What the !!!!????!!!!
Okay i just downloaded the package for All Distros, but it saved off witht the extenstion ".run" ? I thought okay I'll try renaming it...Didnt work....Maye i'll try the rpm package and rpm2tgz joy!

What the fudging brownie is a ".run" file?

Oh Man! i'm getting old!


is it like an sh thing?

ateam 05-07-2007 01:54 PM

H_TeXMeX_H 05-07-2007 02:05 PM

You run the .run just like a script or executable. Like


make sure it is executable.

the-yikes 05-07-2007 02:19 PM

Install complete....however!
Well as i had anticipated there was a hitch! and here it is in all it's glory!

Domain Name Server (DNS) for NAT networking could not be determined.
VBox status code: -3000 (VERR_NAT_DNS).

Result Code:
IConsole {1dea5c4b-0753-4193-b909-22330f64ec45}

The things i do in the name of I.T! why do i do it? because i love it! why do i love it? because i'm it's slave! :)

H_TeXMeX_H 05-07-2007 02:37 PM

Hmmm ... I guess check the users manual or their forums. I haven't done anything extensive with it ... so I wouldn't know too much on how to troubleshoot it.

the-yikes 05-07-2007 03:14 PM

Well you live and learn!
Well the best thing about being a complete halfwit is the fact thgat you learn new things everyday! I was running Virtualbox as root! and well aparently it has some issue with that?

So i logged onto my girlfriends account which i setup as just a standard account, now it's telling me there are no read or write privs for /dev/vboxdrv

I'm goona have a swing at setting up a new account. Have to say though i'm not all that clued in as far as that goes!

H_TeXMeX_H 05-07-2007 03:46 PM

you have to change the permissions of '/dev/vboxdrv'

see my post here:


# now you should give yourself read/write access to /dev/vboxdrv, I think the best way to do this is to chown it, but you can also chmod it, so you can do either or both:
chmod a+rw /dev/vboxdrv
chown $USER:users /dev/vboxdrv

hitest 05-07-2007 03:50 PM


Originally Posted by the-yikes

I'm goona have a swing at setting up a new account. Have to say though i'm not all that clued in as far as that goes!

enter the following command:


jong357 05-07-2007 09:23 PM


# Put this script in the same directory as the vmware tarball and then run it.
# You'll pretty much always need an "any-any" update from here:
# Thier's some screwy stuff going on with dbus. I have to kill it first
# before running vmware. Also, in order to ditch a warning, I do this:
# cd /usr/lib/vmware/lib/
# mv
# ln -sf /usr/lib/ .


if [ -a /var/log/packages/vmware* ]; then
  echo "Removing existing package..."
  removepkg /var/log/packages/vmware* > /dev/null 2>&1
if [ -d /usr/lib/vmware ]; then
  # Just incase
  rm -rf /usr/lib/vmware
if [ -d /etc/vmware ]; then
  rm -rf /etc/vmware

# We need these on the system first:
# We'll clean up at the end
mkdir -p /etc/rc.d/init.d
mkdir -p /etc/rc.d/rc{0,1,2,3,4,5,6}.d

rm -rf $PKG
mkdir -p $PKG/{install,usr,etc}
mkdir -p $PKG/usr/{lib,bin,doc,share,man/man1}
mkdir -p $PKG/usr/share/{applications,pixmaps,mime/packages,icons/hicolor}
mkdir -p $PKG/etc/rc.d

cd $TMP
rm -rf vmware-distrib
echo "VMware-workstation-$VERSION-$VMWAREBUILD.tar.bz2 is now extracting..."
tar xf $CWD/VMware-workstation-$VERSION-$VMWAREBUILD.tar.gz
cd vmware-distrib
# Temporarily disable the configurator. We
# want the user to run it, not the builder..
sed -i 's/' bin/
# Just incase this isn't your first time installing it..
# This shouldn't remove any Virtual Machines, just installer files.
perl -d
# Change the configurator back:
sed -i 's/IGNORE-THIS-ERROR/' /usr/bin/

mv /usr/lib/vmware $PKG/usr/lib
mv /usr/doc/vmware $PKG/usr/doc
mv /usr/man/man1/vmware.1.gz $PKG/usr/man/man1
mv /etc/rc.d/init.d/vmware $PKG/etc/rc.d/rc.vmware
chmod 755 $PKG/etc/rc.d/rc.vmware
mv /usr/bin/vmware-* $PKG/usr/bin
mv /usr/bin/vmnet-* $PKG/usr/bin
mv /usr/bin/{vmrun,vmplayer,vm-support,vmware} $PKG/usr/bin
chmod 755 $PKG/usr/bin/*
cp -a /etc/vmware $PKG/etc
# Remove any misc cruft...
sed -i 's/IGNORE-THIS-ERROR/' bin/
perl bin/ > /dev/null 2>&1

# This makes it easier to access the documentation...
( cd $PKG/usr/doc/vmware
  ln -sf ../../lib/vmware/help/workstation/index.htm Workstation
  ln -sf ../../lib/vmware/help/player/player_index.htm Vmware-Player
  ln -sf ../../lib/vmware/help-manual/index.htm General
  sed -i 's@href="@href="file:///usr/lib/vmware/help/workstation/@g' $PKG/usr/lib/vmware/help/workstation/index.htm
  sed -i 's@href="@href="file:///usr/lib/vmware/help/player/@g' $PKG/usr/lib/vmware/help/player/player_index.htm
  sed -i 's@href="@href="file:///usr/lib/vmware/help-manual/@g' $PKG/usr/lib/vmware/help-manual/index.htm
  # One of our links got changed that we didn't want to:
  sed -i 's@file:///usr/lib/vmware/help/player/#top@#top@g' $PKG/usr/lib/vmware/help/player/player_index.htm )

# When the user runs the configurator, some more stuff will
# get dropped on the system. Not good if we're using pkgtool..
# Let's try and get as much as we can in place now so we
# don't have a bunch of cruft if/when we 'removepkg'
install -m 644 $CWD/misc/vmware.xml $PKG/usr/share/mime/packages/
cp -a $PKG/usr/lib/vmware/share/icons/48x48 $PKG/usr/share/icons/hicolor
cp -a $PKG/usr/share/icons/hicolor/48x48/apps/vmware-workstation.png $PKG/usr/share/pixmaps
cp -a $PKG/usr/share/icons/hicolor/48x48/apps/vmware-player.png $PKG/usr/share/pixmaps
sed -i 's@/usr/share/icons@/usr/share/icons/hicolor@g' $PKG/usr/bin/

# We need to have SyVinit directories everytime is run:
cat << EOF > $TMP/vmware-config-slack.patch
--- ./        2005-03-23 06:54:21.000000000 -0500
+++ ./        2005-10-08 08:53:29.000000000 -0400
@@ -5,6 +5,11 @@
 # Host configurator for VMware
+# Slackware setup:
+!mkdir -p /etc/rc.d/init.d!;
+!ln -sf /etc/rc.d/rc.vmware /etc/rc.d/init.d/vmware!;
+!mkdir -p /etc/rc.d/rc{0,2,3,5,6}.d!;
 use strict;
 # Use Config module to update VMware host-wide configuration file
@@ -8560,6 +8565,13 @@
+  # Slackware cleanup:
+  !rm -f /etc/rc.d/init.d/vmware!;
+  !rmdir /etc/rc.d/init.d!;
+  !rm -f /etc/rc.d/rc{0,2,3,5,6}.d/K08vmware!;
+  !rm -f /etc/rc.d/rc{2,3,5}.d/S90vmware!;
+  !rmdir /etc/rc.d/rc{0,2,3,5,6}.d!;
  print wrap('The configuration of ' . vmware_longname() . ' for this ' .
              'running kernel completed successfully.' . "\n\n", 0);
  if ((vmware_product() ne 'wgs') && (vmware_product() ne 'server')) {

# sed a cat'ed patch.
sed -i 's@!@`@g' $TMP/vmware-config-slack.patch
( cd $PKG/usr/bin
  patch -Np1 -i $TMP/vmware-config-slack.patch )
#rm -f $TMP/vmware-config-slack.patch

# Make the menu launchers:
cat << EOF > $PKG/usr/share/applications/vmware-workstation.desktop
[Desktop Entry]
Name=VMware Workstation
Comment=Run virtual machines

cat << EOF > $PKG/usr/share/applications/vmware-player.desktop
[Desktop Entry]
Name=VMware Player
Comment=Run a virtual machine

# This is always a good idea.
( cd $PKG/usr/lib
  mv vmware vmware-${VERSION}_${VMWAREBUILD}
  ln -sf vmware-${VERSION}_${VMWAREBUILD} vmware
  cd $PKG/usr/doc
  mv vmware vmware-${VERSION}_${VMWAREBUILD}
  ln -sf vmware-${VERSION}_${VMWAREBUILD} vmware )

# 54.8 Mb of Redhat 7.3 binaries are utterly useless:
rm -rf $PKG/usr/lib/vmware-${VERSION}_${VMWAREBUILD}/modules/binary/*

cat << EOF > $PKG/install/
# Append to /etc/rc.d/rc.local if it's
# not already there, commented or not...
if ! grep /etc/rc.d/rc.vmware /etc/rc.d/rc.local 1> /dev/null 2> /dev/null ; then
  cat << EOF >> /etc/rc.d/rc.local

# Added by VMware install:
if [ -x /etc/rc.d/rc.vmware ]; then
  /etc/rc.d/rc.vmware start
echo "EOF" >> $PKG/install/
echo "fi" >> $PKG/install/
echo "# Begin Symlinks:" >> $PKG/install/

cat << EOF > $PKG/install/slack-desc
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also customary
# to leave one space after the ':'.

vmware: vmware (Virtual Machine Software)
vmware: VMware Workstation allows users to run multiple x86-based operating
vmware: systems, including Windows, Linux, and NetWare, and their applications
vmware: simultaneously on a single PC in fully networked, portable virtual
vmware: machines - no hard drive partitioning or rebooting required.
vmware: Before running VMware Workstation for the first time, you need to
vmware: configure it by invoking the following command:

# Restore the system. If you already had SysVinit
# scripts in place, this won't harm anything.
rmdir /etc/rc.d/init.d
rm -f /etc/rc.d/rc{0,2,3,5,6}.d/K08vmware
rm -f /etc/rc.d/rc{2,3,5}.d/S90vmware
rmdir /etc/rc.d/rc{0,1,2,3,4,5,6}.d

# Remove the extracted source:
rm -rf $TMP/vmware-distrib

# Build the package:
cd $PKG
makepkg -l y -c n $TMP/vmware-${VERSION}_${VMWAREBUILD}-$ARCH-$BUILD.tgz

zaert 05-08-2007 03:27 AM

I ran VirtualBox as root (in order to make it work under a user account more configuration is needed). Just configure the network as Host Interface Networking, not NAT (for NAT more configuration is needed too - TUN, ...,see 5.3.2 from User Manual)

the-yikes 05-08-2007 09:44 PM

VirtualBox running but no net?!?
Well as usual i have followed TO THE LETTER! the advice in this forum and it comes as no great surprise that i got VirtualBox running as a result! Sweet! Now in relation to zaert's comments i have set the network connections to Host Interface....just on problem.. what the heck does the following mean?
Host Interface Settings

Interface Name (i'm assuming it's ra0 like it is in slackware)

Setup Application (? what the !"$ is this)

Terminate Application (Again huh!?!)


oh man i think i should take up something easier like knitting!!!

EDIT: maybe i should make my question a little clearer,

isit possible to connect to the web or a network from within a virtual box?

Thanks The Yikes


ok so i've just read up about parprouted and apparently i need i it!?!

so i have it installed, so how now do i setup ip fprwoarding??

Thanks again the yikes

the-yikes 05-10-2007 12:05 PM

Hey All,
Okay the whole networking thing on VirtualBox seems pretty straight forward enough execpt when it comes down to tunctl and setting up the virtual device "tap0".

Iv'e installed Tunctl from a tgz package i rooted out on the web but it's failing to setup the device in /dev/net/ or in /dev/misc/net! anyone have any clues as to what the problem might be?

Thanks The Yikes

All times are GMT -5. The time now is 09:54 AM.