LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-24-2007, 05:35 AM   #1
ak-87
Member
 
Registered: Apr 2005
Posts: 68

Rep: Reputation: 15
VLC player - poor playing quality?


I've installed VLC from .tgz which I downloaded from linuxpackages.net. When I play some clip (avi, mpeg etc.) the quality is poor - video is blurry, it looks like "net" if you understand what I mean. In xine the quality is fine, but when it plays video it looks like it has problems opening it - skips frames, pauses etc. I don't know if the problem is with codecs, settings or xorg configuration. My video card is ATI Mobility Radeon x1600.
 
Old 05-24-2007, 12:38 PM   #2
quietguy47
Member
 
Registered: Mar 2003
Location: Everett
Distribution: Slackware
Posts: 794

Rep: Reputation: 34
This is from the FAQ at http://www.videolan.org/doc/faq/en/index.html#id266631 I hope this helps.
Quote:
1.7.

Video is choppy


Your system might be too slow to decode all pictures. It might be that your CPU basically is not fast enough. It can also be that the subsystem is misconfigured/misdriven, this happens for example under Redhat Linux. Here are some elements to improve speed:

*

Turn on DMA on your DVD device, for instance:
o

Under Linux:

# hdparm -d1 /dev/dvd

o

Under Windows, go to the System section of the control panel, and go to the Hardware manager (it is sometimes in a separate tab, and sometimes, you have to go to the Advanced tab. Then, righ-click on your DVD player, and check the DMA checkbox.
*

Upgrade to the latest driver for your video board

If you are running Linux, you can additionnaly upgrade to the latest XFree86 version. If supported, check that the xvideo plug-in is effectively used with:

% vlc -vvvv

*

Stop other running applications...
*

Try disabling framedropping. Framedropping allows VLC not to decode some pictures when the CPU is overloaded, but can result in choppier playback under certain conditions.

Framedropping behaviour can be configured in the Video preferences of VLC.
 
Old 05-24-2007, 01:42 PM   #3
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
I would try mplayer (it has more options as to video drivers and such).

The slackbuild works great:
http://slackbuilds.org/repository/multimedia/MPlayer/
 
Old 05-24-2007, 02:53 PM   #4
ak-87
Member
 
Registered: Apr 2005
Posts: 68

Original Poster
Rep: Reputation: 15
I've installed mplayer and playing quality is excellent. I just have problem setting it up to play every video in 16:9 aspect ratio by default(I need 16:10, but there is no such option).

Thank You, guys!
 
Old 05-24-2007, 02:59 PM   #5
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
If you run it fullscreen, doesn't it automatically resize to fit whatever screen you have ?

Remember to try out different drivers. For example, I find 'gl2' (if available) to give best video quality. And either ALSA or SDL for audio.

Last edited by H_TeXMeX_H; 05-24-2007 at 03:00 PM.
 
Old 05-24-2007, 05:29 PM   #6
ak-87
Member
 
Registered: Apr 2005
Posts: 68

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by H_TeXMeX_H
If you run it fullscreen, doesn't it automatically resize to fit whatever screen you have ?
No it doesn't, I have to change it manually.
 
Old 05-24-2007, 05:51 PM   #7
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
Then something like 'gmplayer -aspect 16:10'
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
For all those having problems playing with VideoLan Client (VLC media player) stees Linux - Software 2 01-04-2013 10:23 AM
Svideo out to TV quality is really poor vdemuth Linux - Hardware 6 01-01-2007 07:39 PM
poor sound quality slackware_03 Linux - Distributions 10 09-23-2004 05:17 PM
Poor Quality DVDs guygriffiths Linux - Software 13 12-03-2003 02:37 PM
Poor VHS quality niidea Linux - Hardware 8 09-16-2003 08:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration