LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-22-2019, 03:16 PM   #16
horizn
Member
 
Registered: Jan 2015
Location: UK and Poland
Distribution: Slackware + Debian + Ubuntu
Posts: 164

Original Poster
Rep: Reputation: Disabled

Quote:
Originally Posted by Alien Bob View Post
Perhaps you can elaborate on that, so I can point you to a way to get this working again.
What was the download URL for this VLC 3.0.6 package? What version of VLC did you have installed before? What was the exact error that you get when running this vlc binary?
Did you install all of the required dependencies on Slackware 14.2 from my repository (libinput, libwacom, libxkbcommon, qt5, qt5-webkit)?
I installed it using slackpkg from alienbob repo, then I have reinstalled from http://bear.alienbase.nl/mirrors/peo...lc/pkg64/14.2/ The previous version was the previous you shared: 3.0.4 as far as I remember. Error output from strace was about non-existing libs in /usr/lib64/

I had already installed: libinput, libwacom, libxkbcommon, qt5, qt5-webkit:
libinput-1.5.4-x86_64-1alien
libwacom-0.22-x86_64-1alien
libxkbcommon-0.7.1-x86_64-1alien
qt5-5.7.1-x86_64-1alien
qt5-webkit-5.7.1-x86_64-1alien

qt5 has been installed together with your last KDE5 release for 14.2.

Last edited by horizn; 01-22-2019 at 03:18 PM.
 
Old 01-23-2019, 12:39 AM   #17
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,974

Rep: Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231
It seems you need to update the deps as well
AlienBOB has updated some (if not all) of the deps to the latest version as well and VLC is built against those latest libraries.
 
Old 01-23-2019, 01:43 AM   #18
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,535

Rep: Reputation: 5901Reputation: 5901Reputation: 5901Reputation: 5901Reputation: 5901Reputation: 5901Reputation: 5901Reputation: 5901Reputation: 5901Reputation: 5901Reputation: 5901
Quote:
Originally Posted by horizn View Post
I installed it using slackpkg from alienbob repo, then I have reinstalled from http://bear.alienbase.nl/mirrors/peo...lc/pkg64/14.2/ The previous version was the previous you shared: 3.0.4 as far as I remember. Error output from strace was about non-existing libs in /usr/lib64/

I had already installed: libinput, libwacom, libxkbcommon, qt5, qt5-webkit:
libinput-1.5.4-x86_64-1alien
libwacom-0.22-x86_64-1alien
libxkbcommon-0.7.1-x86_64-1alien
qt5-5.7.1-x86_64-1alien
qt5-webkit-5.7.1-x86_64-1alien

qt5 has been installed together with your last KDE5 release for 14.2.
You don't have the latest packages fir Slackware 14.2 installed from my repository (libwacom-0.31, libinput-1.7.3, libxkbcommon-0.8.2, qt5-5.9.6, qt5-webkit-5.9.1) and that is why VLC fails to run because it was compiled against those newer package libraries.
 
Old 01-23-2019, 03:44 AM   #19
horizn
Member
 
Registered: Jan 2015
Location: UK and Poland
Distribution: Slackware + Debian + Ubuntu
Posts: 164

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Alien Bob View Post
You don't have the latest packages fir Slackware 14.2 installed from my repository (libwacom-0.31, libinput-1.7.3, libxkbcommon-0.8.2, qt5-5.9.6, qt5-webkit-5.9.1) and that is why VLC fails to run because it was compiled against those newer package libraries.
Will qt and qt-webkit upgrade break KDE5?
 
Old 01-23-2019, 05:50 AM   #20
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,535

Rep: Reputation: 5901Reputation: 5901Reputation: 5901Reputation: 5901Reputation: 5901Reputation: 5901Reputation: 5901Reputation: 5901Reputation: 5901Reputation: 5901Reputation: 5901
Quote:
Originally Posted by horizn View Post
Will qt and qt-webkit upgrade break KDE5?
You have KDE5 installed on Slackware 14.2? I assume then that this is the old version of KDE5 which I stopped updating end of 2017?
I have no idea if updating the qt5 and qt5-webkit packages will break this old version of KDE5, it is un-maintained as far as I am concerned. If you really want to use KDE5 you may consider a switch to slackware-current.

Of course, you can build VLC from source against the qt5 and qt5-webkit which you have installed, and that should work. However, it's likely that more and more binary packages will no longer work on your old KDE5 install with the passing of time...
 
Old 01-23-2019, 08:41 AM   #21
horizn
Member
 
Registered: Jan 2015
Location: UK and Poland
Distribution: Slackware + Debian + Ubuntu
Posts: 164

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Alien Bob View Post
You have KDE5 installed on Slackware 14.2? I assume then that this is the old version of KDE5 which I stopped updating end of 2017?
I have no idea if updating the qt5 and qt5-webkit packages will break this old version of KDE5, it is un-maintained as far as I am concerned. If you really want to use KDE5 you may consider a switch to slackware-current.

Of course, you can build VLC from source against the qt5 and qt5-webkit which you have installed, and that should work. However, it's likely that more and more binary packages will no longer work on your old KDE5 install with the passing of time...
Yes, that's the one you no longer maintain. I don't want to mess with that now. I am planning to upgrade to 15.0 (or whatever number it will be) once available. I hope that will happen soon.
 
Old 01-23-2019, 08:54 AM   #22
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,792

Rep: Reputation: Disabled
Quote:
Originally Posted by horizn View Post
Yes, that's the one you no longer maintain. I don't want to mess with that now. I am planning to upgrade to 15.0 (or whatever number it will be) once available. I hope that will happen soon.
note that in SBo too qt5 is at version 5.9.x, so if you have (or will have) any problems building anything that utilizes qt5 consider that you are using an unsupported setup.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Linux 4.4 seems to refuse to build IPv6 for the 64-bit build - 32-bit build works fine GameCodingNinja Linux From Scratch 2 02-07-2016 06:40 PM
[SOLVED] alienBOB's vlc keeps stoping build with this error... irgunII Slackware 14 11-19-2013 12:15 AM
Installing VLC using vlc-0.9.9a-4.el5.rf.i386.rpm--Error relating to Dependencies redhat5 Linux - Newbie 1 12-17-2009 04:23 PM
VLC error: VLC could not open the file "/usr/share/vlc/skins2/text.bmp". brjoon1021 Ubuntu 1 01-14-2009 10:48 PM
LXer: Build 'em Right, Build 'em Strong, Build 'em Linux LXer Syndicated Linux News 0 10-01-2007 09:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration