LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-07-2020, 07:55 PM   #406
hitest
Guru
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 6,244

Rep: Reputation: 2482Reputation: 2482Reputation: 2482Reputation: 2482Reputation: 2482Reputation: 2482Reputation: 2482Reputation: 2482Reputation: 2482Reputation: 2482Reputation: 2482

Quote:
Originally Posted by gus3 View Post
I'm running -current (on all machines!), fully updated to two days ago.
I am as well. Using Vivaldi from SBo. No stability issues here.
 
Old 05-08-2020, 02:42 AM   #407
Gerard Lally
Senior Member
 
Registered: Sep 2009
Location: Brú na Bóinne, IE
Distribution: Slackware, NetBSD
Posts: 1,738

Rep: Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223
Quote:
Originally Posted by gus3 View Post
Not "first rate" for me.

Seamonkey is my main browser, because Firefox suddenly became very crash-able for most of my news site bookmarks. Seamonkey was at least good enough for my Yahoo email. With the last update, Seamonkey is equally crash-able with my Yahoo email.

So I tried Konqueror, Dillo (from SBo), and now Vivaldi. All of them have become really unstable.

Next up, Opera. It couldn't even display its own Welcome page. Instant crash.

WTH?
I've had successive releases of Vivaldi lock up on me at random for a very long time now. Fully patched 14.2. I get fewer lockups when I disable GPU hardware acceleration in the browser, but the problem remains. I keep meaning to replace my AMD card with an Nvidia card running the proprietary driver.

Not sure if the other browsers you are using have hardware acceleration; I think Firefox does?

(uMatrix is the only extension I use.)

Last edited by Gerard Lally; 05-08-2020 at 02:57 AM.
 
1 members found this post helpful.
Old 06-10-2020, 01:00 PM   #408
mats_b_tegner
Member
 
Registered: Nov 2009
Location: Gothenburg, Sweden
Distribution: Slackware
Posts: 751

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
Vivaldi 3.1 (1929.29)
https://vivaldi.com/sv/blog/vivaldi-...gurable-menus/

Last edited by mats_b_tegner; 06-11-2020 at 02:59 AM. Reason: 3.1 stable is released
 
1 members found this post helpful.
Old 06-12-2020, 10:01 AM   #409
mats_b_tegner
Member
 
Registered: Nov 2009
Location: Gothenburg, Sweden
Distribution: Slackware
Posts: 751

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
Minor update for Vivaldi Desktop 3.1 (1929.34):
https://vivaldi.com/sv/blog/news/min...p-browser-3-1/
Quote:
The following improvements were made since the initial 3.1 stable release:
[Themes] Dropdown content invisible in dark themes (VB-68461)
[Translations] Several languages updated
I would also suggest updating the chromium-codecs-ffmpeg-extra in the SlackBuild to version 83.0.4103.61 to better match the Chromium version in Vivaldi 3.1.

Last edited by mats_b_tegner; 06-19-2020 at 03:06 PM.
 
Old 06-16-2020, 03:38 AM   #410
ruario
Senior Member
 
Registered: Jan 2011
Location: Oslo, Norway
Distribution: Slackware
Posts: 2,517

Rep: Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652
Quote:
Originally Posted by mats_b_tegner View Post
Minor update for Vivaldi Desktop 3.1 (1929.34):
I would also suggest updating the chromium-codecs-ffmpeg-extra in the SlackBuild to version 83.0.4103.61 to better match the Chromium version in Vivaldi 3.1.
That is not going to work because Ubuntu have not published chromium-codecs-ffmpeg-extra 83.0.4103.61 for Xenial (16.04LTS), only Bionic (18.04LTS). This matters because the Bionic package requires Glibc 2.27 and Slackware 14.2 only has 2.23, so the contained lib is not usable for stable Slackware.
 
2 members found this post helpful.
Old 06-16-2020, 10:43 AM   #411
mats_b_tegner
Member
 
Registered: Nov 2009
Location: Gothenburg, Sweden
Distribution: Slackware
Posts: 751

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
Quote:
Originally Posted by ruario View Post
That is not going to work because Ubuntu has not published chromium-codecs-ffmpeg-extra 83.0.4103.61 for Xenial (16.04LTS), only Bionic (18.04LTS). This matters because the Bionic package requires Glibc 2.27 and Slackware 14.2 only has 2.23, so the contained lib is not usable for stable Slackware.
Ahh, sorry. I'm running -current so I didn't take Glibc into account.

Last edited by mats_b_tegner; 06-17-2020 at 04:05 AM.
 
Old 06-16-2020, 01:25 PM   #412
ruario
Senior Member
 
Registered: Jan 2011
Location: Oslo, Norway
Distribution: Slackware
Posts: 2,517

Rep: Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652
FWIW, Ubuntu provide an alternative source for suitable (chromium patched) libffmpeg binaries in the form of a .snap package. This is actually what the snap version of Ubuntu's own Chromium (and the Opera snap), uses to play proprietary media. I have been keeping an eye on this package because I could (and have done in local tests) fetch this and extract out a suitable lib. While the .snap container is actually an XZ compressed squashfs image, I have realised I can even get the file I want without having to go through a mount process via a bit of hackery. So far though, I have not needed to because they are still updating the chromium-codecs-ffmpeg-extra deb package for Xenial. In addition, it is worth noting that they have not felt the need to update this package since the 3rd of October 2019. Thus the most recent lib (it contains several) in that .snap is built from Chromium 77.0.3865.90 source and yet it is usable with their stable Chromium 83 snap (and their 84 test version). I have not checked but this is likely due to little (or perhaps no?) changes to that specific area of the Chromium code base. Anyway, if Ubuntu considers this good enough for their up to date Chromium, then I guess we should not worry too much that we are using a lib from 81 in 83.

Last edited by ruario; 06-16-2020 at 01:26 PM.
 
1 members found this post helpful.
Old 06-19-2020, 12:27 PM   #413
mats_b_tegner
Member
 
Registered: Nov 2009
Location: Gothenburg, Sweden
Distribution: Slackware
Posts: 751

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
Our friend Ruarí Ødegaard just announced the second minor update to Vivaldi Desktop 3.1 (1929.40):
https://vivaldi.com/sv/blog/news/min...i-desktop-3-1/
Quote:
The following improvements were made since the first 3.1 minor update:
[Chromium] Upgraded to 83.0.4103.109
[Fullscreen] Close Window hotkey from fullscreen video causes Window to be in ”Restored” state (VB-68087)
[Media][macOS Catalina] Instagram, IMDB, Twitch, … videos fail to play (VB-58686)
[Tabs] Page tiling breaks after closing any popout window (VB-68553)

Last edited by mats_b_tegner; 06-19-2020 at 03:06 PM.
 
1 members found this post helpful.
Old 06-24-2020, 03:48 PM   #414
mats_b_tegner
Member
 
Registered: Nov 2009
Location: Gothenburg, Sweden
Distribution: Slackware
Posts: 751

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
Third minor update for Vivaldi Desktop Browser 3.1 (1929.45):
https://vivaldi.com/sv/blog/news/min...p-browser-3-1/
Quote:
The following improvements were made since the second 3.1 minor update:
[Chromium] Upgraded to 83.0.4103.119
[Crash] beforeunload handler added after page load causes a crash when a page is closed (VB-68683)
[Crash] On startup for some users with slow or underpowered machines (VB-68842)
[Razer][Themes] Broken caching causes an excessive amount of Razer API calls (VB-68732)

Last edited by mats_b_tegner; 06-26-2020 at 03:43 AM.
 
2 members found this post helpful.
Old 06-25-2020, 03:11 AM   #415
ruario
Senior Member
 
Registered: Jan 2011
Location: Oslo, Norway
Distribution: Slackware
Posts: 2,517

Rep: Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652
Sadly I cannot put in on SBo, right now. Yesterday when I tried to upload it my previous submission for the last minor update had just moved to the ready queue. At that point you can neither upload a new one, nor remove the previous to replace it. I'll try not to forget to keep trying to update it. In the mean time, if you use SBo, just tweak the version number yourselves.
 
4 members found this post helpful.
Old 06-25-2020, 10:30 AM   #416
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 7,150

Rep: Reputation: 4818Reputation: 4818Reputation: 4818Reputation: 4818Reputation: 4818Reputation: 4818Reputation: 4818Reputation: 4818Reputation: 4818Reputation: 4818Reputation: 4818
Quote:
Originally Posted by ruario View Post
Sadly I cannot put in on SBo, right now. Yesterday when I tried to upload it my previous submission for the last minor update had just moved to the ready queue. At that point you can neither upload a new one, nor remove the previous to replace it. I'll try not to forget to keep trying to update it. In the mean time, if you use SBo, just tweak the version number yourselves.
You can ask the SBo admins to remove it from the ready queue or submit a PR through GitHub and have that overwrite the previous one.
 
1 members found this post helpful.
Old 06-28-2020, 02:46 PM   #417
Skaendo
Senior Member
 
Registered: Dec 2014
Location: West Texas, USA
Distribution: Slackware64-14.2
Posts: 1,319

Rep: Reputation: Disabled
I just noticed this today, but why is Vivaldi leaving all these hidden directories in my /tmp?
Attached Thumbnails
Click image for larger version

Name:	Screenshot from 2020-06-28 14-43-43.png
Views:	21
Size:	79.2 KB
ID:	33520  
 
Old 06-28-2020, 03:25 PM   #418
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 7,150

Rep: Reputation: 4818Reputation: 4818Reputation: 4818Reputation: 4818Reputation: 4818Reputation: 4818Reputation: 4818Reputation: 4818Reputation: 4818Reputation: 4818Reputation: 4818
This is likely related to the Chromium backend. Google Chrome leaves similar directories in my /tmp/ as well.

Code:
jbhansen@craven-moorhead:~/.config$ find /tmp/ -name .com* -maxdepth 1
/tmp/.com.google.Chrome.A35XzI
/tmp/.com.google.Chrome.U0hc9e
/tmp/.com.google.Chrome.Q7og5t
/tmp/.com.google.Chrome.iLUNp3
/tmp/.com.google.Chrome.9SsGfv
/tmp/.com.google.Chrome.vb1L87
/tmp/.com.google.Chrome.nM9KpR
/tmp/.com.google.Chrome.H9DY0r
/tmp/.com.google.Chrome.pKnZow
/tmp/.com.google.Chrome.NTw3mS
/tmp/.com.google.Chrome.wIVGm6
/tmp/.com.google.Chrome.MvqgOv
/tmp/.com.google.Chrome.eO1arl
/tmp/.com.google.Chrome.YWsvs3
/tmp/.com.google.Chrome.QczX9Z
/tmp/.com.google.Chrome.0ouj3J
/tmp/.com.google.Chrome.LnWKmS
/tmp/.com.google.Chrome.CieGPO
/tmp/.com.google.Chrome.Aug1qt
/tmp/.com.google.Chrome.viXRZj
/tmp/.com.google.Chrome.rrvUs0
/tmp/.com.google.Chrome.3lzF78
/tmp/.com.google.Chrome.cTftFR
/tmp/.com.google.Chrome.Prkiik
/tmp/.com.google.Chrome.3aXosi
/tmp/.com.google.Chrome.lzP77f
/tmp/.com.google.Chrome.Lib0ld
/tmp/.com.google.Chrome.f7y7gd
/tmp/.com.google.Chrome.rHG2bA
/tmp/.com.google.Chrome.CIyDRY
/tmp/.com.google.Chrome.KlSQyX
/tmp/.com.google.Chrome.ZFdWBi
/tmp/.com.google.Chrome.w90d0k
/tmp/.com.google.Chrome.Etsrwu
/tmp/.com.google.Chrome.1LdLFo
/tmp/.com.google.Chrome.pU6vVj
/tmp/.com.google.Chrome.MESkgj
/tmp/.com.google.Chrome.mGSn3T
/tmp/.com.google.Chrome.zGKQwR
/tmp/.com.google.Chrome.7BZR5M
/tmp/.com.google.Chrome.xL2D3i
/tmp/.com.google.Chrome.nrWYtl
/tmp/.com.google.Chrome.7W1GwT
/tmp/.com.google.Chrome.brg6OP
/tmp/.com.google.Chrome.5aWm27
/tmp/.com.google.Chrome.kPTKDD
/tmp/.com.google.Chrome.vfMKdv
/tmp/.com.google.Chrome.MxoVIl
/tmp/.com.google.Chrome.PgI6NJ
/tmp/.com.google.Chrome.ELKXJF
/tmp/.com.google.Chrome.UNH9Gf
/tmp/.com.google.Chrome.TwlFG5
/tmp/.com.google.Chrome.RDfGeU
/tmp/.com.google.Chrome.jg9qPj
/tmp/.com.google.Chrome.AZ4bzQ
/tmp/.com.google.Chrome.vFJrc5
/tmp/.com.google.Chrome.JgHxZ2
/tmp/.com.google.Chrome.1ekXxR
/tmp/.com.google.Chrome.N8dLK5
 
3 members found this post helpful.
Old Yesterday, 03:30 PM   #419
Skaendo
Senior Member
 
Registered: Dec 2014
Location: West Texas, USA
Distribution: Slackware64-14.2
Posts: 1,319

Rep: Reputation: Disabled
I keep losing the little controls next to 'forum tools' and 'Search this forum' here on LQ and keep getting directed to "https://www.linuxquestions.org/questions/slackware-14/?nojs=1#goto_forumtools".

This does not happen right away, but once it does not even a reinstall of Vivaldi can fix it. This time I have been running fine for ~6 months and all of a sudden out of the blue it happens. I am on 14.2 running the Cinnamon DE. I don't know if this happens with other DEs since I don't have them installed.

I have jdk-8u251 and mozjs-24 installed and wonder if Vivaldi is getting confused with one of them.

I cannot even use any of the formatting tools while creating/editing posts.
Attached Thumbnails
Click image for larger version

Name:	Screenshot from 2020-07-14 15-21-45.png
Views:	8
Size:	11.0 KB
ID:	33658  

Last edited by Skaendo; Yesterday at 03:31 PM.
 
Old Today, 03:21 AM   #420
YesItsMe
Member
 
Registered: Oct 2014
Posts: 651

Rep: Reputation: 247Reputation: 247Reputation: 247
Vivaldi has recently introduced a new user interface for saving passwords (wasting quite some space on my screen) and the latest "stable" version crashes reproducably when trying to install certain add-ons from the Chrome Web Store. Hmm. I shall report that.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Vivaldi Continues To Build Amazing Features With Vivaldi 1.11 LXer Syndicated Linux News 0 08-12-2017 06:09 PM
LXer: Vivaldi Technologies Vivaldi Web Browser LXer Syndicated Linux News 0 10-28-2016 07:26 PM
LXer: KDE Vivaldi Tablet Finally Shipping For QA Testing LXer Syndicated Linux News 0 07-23-2013 02:21 AM
LXer: Vivaldi Tablet Finally (Almost) Finalized LXer Syndicated Linux News 0 05-30-2013 07:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration