-   Slackware (
-   -   VirtualBox.SlackBuild problems (

joegumbo 09-01-2008 02:16 PM

VirtualBox.SlackBuild problems (SOLVED!)

I've searched to see if anyone else had this problem, and apparently I'm the only one.

I'm running Slackware 12.1 with 'slackpkg upgrades-all' applied. After installing Virtualbox along with virtualbox-kernel by using SlackBuilds, the GUI part seems to have installed just fine. I was able to use the wizard to create a fixed disk image to install an OS on. But, when I try to begin the installation of the guest OS, the following error message appears:


VirtualBox kernel driver not installed. The vboxdrv kernel module was either not loaded or /dev/vboxdrv was not created for some reason. Re-setup the kernel module by executing '/etc/init.d/vboxdrv setup' as root.
VBox status code: -1908 (VERR_VM_DRIVER_NOT_INSTALLED).

Result Code:
IConsole {d5a1cbda-f5d7-4824-9afe-d640c94c7dcf}

When I run '/etc/init.d/vboxdrv setup' as root, bash tells me that there is no such file or directory. Also, '/dev/vboxdrv' does not exist.

I followed the directions in the README:


You'll probably want to add the following lines to your rc.local:

# Start vboxdrv
if [ -x /etc/rc.d/rc.vboxdrv ]; then
. /etc/rc.d/rc.vboxdrv start

# Start vboxnet
if [ -x /etc/rc.d/rc.vboxnet ]; then
. /etc/rc.d/rc.vboxnet start

This will load the support kernel module and will setup the network
configuration for VirtualBox. You should add similar "stop" lines to
your rc.local_shutdown.
and I manually 'groupadd -g 215 vboxusers' as root as well as making my user a member of vboxusers.

I also rebooted just in case.

After this failed once, I uninstalled VirtualBox with pkgtool, cleaned out /tmp and did it all over again. I still cannot get VBox to work correctly.

The only thing that I can think of is that there may be a conflict with Win4Lin. But, I've successfully used both Win4Lin and VBox together on other distros in the past.

The reason I need VBox is because I need to use Fedora CORE 2. I'm taking my first actual real honest-to-goodness formal Linux class and this is the distro that the Prof decided we are to use. FC2 is too dated to use on my hw (that still works), so I need to virtualize it. However, if anyone here has a different idea as to a different (free) approach to virtualizing FC2 on Slackware, of course I'd welcome that too.

-Joe G.

Alien Bob 09-01-2008 02:29 PM

Did you check that the files


are actually executable? Because if they are not, your kernel driver and network support will not be initialized.


joegumbo 09-01-2008 02:44 PM

Hi Eric!

That did it!

You are a genius! :)

Thank you!

All times are GMT -5. The time now is 01:02 PM.