LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-09-2021, 08:16 AM   #1
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware14.2 64-Bit Desktop, Devuan 2.0 ASCII Toshiba Satellite Notebook
Posts: 3,191

Rep: Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938
Question VirtualBox does not see USB devices in MATE


I switched from LXDE to MATE - but it seems MATE handles USB devices differently. In short under MATE I can no longer get VirtualBox to detect my usb headset to pass through to a host OS (in this case Win10). Dmesg shows that Linux itself obviously detects it:

Code:
[32525.314051] usb 3-1.2: new full-speed USB device number 5 using ehci-pci
[32526.717647] usb 3-1.2: New USB device found, idVendor=046d, idProduct=0a8f
[32526.717651] usb 3-1.2: New USB device strings: Mfr=3, Product=1, SerialNumber=0
[32526.717652] usb 3-1.2: Product: Logitech USB Headset
[32526.717654] usb 3-1.2: Manufacturer: Logitech USB Headset
[32526.731850] input: Logitech USB Headset Logitech USB Headset as /devices/pci0000:00/0000:00:1a.0/usb3/3-1/3-1.2/3-1.2:1.3/0003:046D:0A8F.0004/input/input15
[32526.782146] hid-generic 0003:046D:0A8F.0004: input,hidraw3: USB HID v1.11 Device [Logitech USB Headset Logitech USB Headset] on usb-0000:00:1a.0-1.2/input3
[32527.366105] usbcore: registered new interface driver snd-usb-audio
root@slackmachine:/home/slackuser#
In the sound settings for MATE I have tried to toggle both the headset on and off , but virtualbox still no longer sees the headset:
Click image for larger version

Name:	Screenshot_2021-04-09_08-09-59.png
Views:	17
Size:	41.0 KB
ID:	36052

USB device list in VirtualBox:
Click image for larger version

Name:	Screenshot_2021-04-09_08-11-21.png
Views:	13
Size:	38.3 KB
ID:	36053

I use things like discord too, but I did make sure that discord did not use the headset, so I unplugged and plugged the USB headset back in, and when discord saw and asked, I opted discord to not grab the headset for itself, but seems nothing I do gets VirtualBox to see the headset. Nothing else really changed, and yes GuestAdditions for VirtualBox are installed. Yes I have checked the button in the USB list, and it still does not detect anything, and this is not under --Current but in 14.2.

Last edited by Jeebizz; 04-09-2021 at 09:41 AM.
 
Old 04-09-2021, 08:25 AM   #2
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware14.2 64-Bit Desktop, Devuan 2.0 ASCII Toshiba Satellite Notebook
Posts: 3,191

Original Poster
Rep: Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938
Also I noticed that even my keyboard and mouse aren't listed, unlike in LXDE - so again I suspect MATE handles USB differently. Not like I actually want to pass my keyboard and mouse, just my headset - but I can't.
 
Old 04-09-2021, 09:34 AM   #3
michaelk
Moderator
 
Registered: Aug 2002
Posts: 21,507

Rep: Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114
The way I understand VirtualBox USB filters it is a way to automatically connect a particular USB device to a guest. Otherwise you need to manually connect it via the Devices pull down menu. Is the headset listed in the guest's devices -> USB menu? Once it is connected to the Guest, the device is disconnected from the host.

Hmm, I expect/assume that USB devices are desktop independent regardless of OS.
 
Old 04-09-2021, 09:42 AM   #4
Emerson
LQ Sage
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 7,231

Rep: Reputation: Disabled
Probably has something to do with VBox settings for this particular VM and maybe missing VBox extras.
 
Old 04-09-2021, 09:44 AM   #5
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware14.2 64-Bit Desktop, Devuan 2.0 ASCII Toshiba Satellite Notebook
Posts: 3,191

Original Poster
Rep: Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938
Quote:
Originally Posted by michaelk View Post
The way I understand VirtualBox USB filters it is a way to automatically connect a particular USB device to a guest. Otherwise you need to manually connect it via the Devices pull down menu. Is the headset listed in the guest's devices -> USB menu? Once it is connected to the Guest, the device is disconnected from the host.

Hmm, I expect/assume that USB devices are desktop independent regardless of OS.
The device is not listed anywhere - (see my screenshot) , NOTHING is, not even my USB keyboard and mouse. In LXDE it would show it, if I went in the USB devices in VirtualBox and clicked on the + icon to show the devices to add to the list, but again under MATE , nothing not even my keyboard and mouse. All I know is it worked in LXDE, I mean yea if push comes to shove I'll just go back to LXDE - but I kinda want to know why MATE is not allowed VirtualBox to even detect any of the USB devices, and I am wondering if Plasma5 (when Slackware 15 is out), will exhibit similar behavior like MATE, who knows.
 
Old 04-09-2021, 09:46 AM   #6
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware14.2 64-Bit Desktop, Devuan 2.0 ASCII Toshiba Satellite Notebook
Posts: 3,191

Original Poster
Rep: Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938
Quote:
Originally Posted by Emerson View Post
Probably has something to do with VBox settings for this particular VM and maybe missing VBox extras.
No, the extras or in this case Guest additions are installed - otherwise I wouldn't actually be able to boot Windows - VirtualBox would throw errors - So I honestly have no idea, other than again to conclude that MATE is somehow preventing VirtualBox perhaps, I don't know. Again the only thing changed was me installing MATE.
 
Old 04-09-2021, 10:01 AM   #7
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.2 & current
Posts: 7,917
Blog Entries: 59

Rep: Reputation: Disabled
Have you got the Extension Pack installed?
https://www.virtualbox.org/wiki/Downloads
 
Old 04-09-2021, 10:06 AM   #8
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware14.2 64-Bit Desktop, Devuan 2.0 ASCII Toshiba Satellite Notebook
Posts: 3,191

Original Poster
Rep: Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938
Quote:
Originally Posted by brianL View Post
Have you got the Extension Pack installed?
https://www.virtualbox.org/wiki/Downloads
I have yes - which I would like to correct myself from my earlier post; because without the extension pack itself, I wouldn't be able to boot a guest OS - VirtualBox would throw errors - however it will boot the guest OS with or without GuestAdditions - which again I do have also installed on the guest OS too.

Click image for larger version

Name:	Screenshot_2021-04-09_10-04-24.png
Views:	7
Size:	30.3 KB
ID:	36054
 
Old 04-09-2021, 10:11 AM   #9
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.2 & current
Posts: 7,917
Blog Entries: 59

Rep: Reputation: Disabled
Must be a quirk of Mate.
 
Old 04-09-2021, 10:14 AM   #10
michaelk
Moderator
 
Registered: Aug 2002
Posts: 21,507

Rep: Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114
Ok, I get it now you clicked on the add button but it only shows an empty square.

Is your user a member of the vboxusers group?
 
2 members found this post helpful.
Old 04-09-2021, 10:25 AM   #11
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware14.2 64-Bit Desktop, Devuan 2.0 ASCII Toshiba Satellite Notebook
Posts: 3,191

Original Poster
Rep: Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938
Quote:
Originally Posted by michaelk View Post
Ok, I get it now you clicked on the add button but it only shows an empty square.

Is your user a member of the vboxusers group?
Thats it! I don't know how or why that got removed. *facepalm* Checked /etc/groups and added myself and now boom:
Click image for larger version

Name:	Screenshot_2021-04-09_10-22-28.png
Views:	13
Size:	133.4 KB
ID:	36055

Quote:
Originally Posted by brianL View Post
Must be a quirk of Mate.
Turns out the quirk was the user, experiencing the dreaded ID10T error
 
1 members found this post helpful.
Old 04-09-2021, 10:28 AM   #12
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.2 & current
Posts: 7,917
Blog Entries: 59

Rep: Reputation: Disabled
No vaccine for PEBCAK. Unfortunately.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] virtualbox is installed along with virtualbox-dkms and virtualbox-ext-pack and linux-headers-generic, but error for no /dev/vboxdrv Astral Axiom Linux - Software 2 03-04-2019 08:09 PM
Mate Dock Applet not working on Linux Mint 18.3 Sylvia / Mate Randymanme Linux Mint 3 02-07-2019 12:24 PM
LXer: Ubuntu MATE 15.04 Arrives With MATE Desktop 1.8.2 and MATE Tweak LXer Syndicated Linux News 0 05-15-2015 09:30 AM
Ubuntu Ultimate doesn't see DVD writer, but does see reader in VirtualBox joebpa Ubuntu 7 05-04-2012 01:56 PM
winecfg - Alsa does NOT see 'Mixer Devices' / Sound comes out of speakers (not headp) Virtuality Linux - Software 1 01-03-2008 08:13 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration