-   Slackware (
-   -   vim in Slack14_64 gets 'stuck' (

Habitual 10-17-2012 09:02 AM

vim in Slack14_64 gets 'stuck'
Funny thing happened on the way to my editor... I can't use "vim". It just hangs until I issue a "killall -9 vim".

I had an 'alias vi="vim"' but I remarked it out trying to track this down. I also REM'd out the EDITOR and export EDITOR statements in my .bashrc and .alias files. I mv'd the .vimrc to .vimrc.last and re-sourced everything.

/usr/bin/vim will not run. It just sits there.

Brand spanking new Slack14/64 with multilibs but I am not sure that has any bearing on this.

FWIW: "vim" also hangs for root.

Here's some stuff I hope will provide enough info for the community to help...

Packages installed:

-rw-r--r-- 1 root root  62K Oct 11 2012 10:20 PM vim-7.3.645-x86_64-1
-rw-r--r-- 1 root root 1.4K Oct 11 2012 10:26 PM vim-gvim-7.3.645-x86_64-1

vim --version

VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Aug 29 2012 11:33:02)
Included patches: 1-645
... (truncated lengthy output)...

Thank you for your time.

Sorry, I never know which sub-forum I should post to with these types of Questions.
I use Slackware but other than that it could also be in Linux - Software - Thanks or Sorry!

I tried
Editing ~/.bashrc and modified EDITOR statement:

export EDITOR="/usr/bin/vim"
and it worked for a minute.

I REM'arked all references to vim in my ~/.bashrc and ~/.aliases files.
vi works flawless and without issue,
vim is still hosed.
Thank you!

audriusk 10-17-2012 04:45 PM

Could you try running

$ strace -o strace-vim.log vim
and check the contents of strace-vim.log file? If you don't understand all the gibberish in that log file, post it here as attachment (it'll most likely be too big to post inline) so people can look at it.


Originally Posted by Habitual (Post 4808122)
vi works flawless and without issue,
vim is still hosed.

That's because /usr/bin/vi points to elvis in Slackware, which is different from vim.

markush 10-17-2012 07:05 PM


you should check, if vim works for another user.

What did you do before vim broke? did you edit your .vimrc file?


688a 10-18-2012 12:28 AM

My machine is having a problem with vi about the $LANG setup. It doesn't work properly. However, vim is working just fine for me. So I have a soft link of vi pointing to vim. You might want to try a soft link instead of all these setting. (I don't know it helps or not)

Habitual 10-18-2012 10:50 AM


Thanks! Strange...
I added a new user vim added and I sudo su - vim and 'vim' worked. I exited and tried my own and it worked...? Logged in to console as vim and 'vim' worked. Same for root and my account.
I did a 'reinstall' yesterday when previous measures failed.
I edited nothing in recent memory.


Thanks also, I will run a strace when it happens next.


I didn't think mine was $LANG-related.

echo "$LANG"
grep lang /etc/profile.d/
export LANG=en_US

for now, I guess I'll give it some time. Maybe it is fixed?.


Habitual 10-23-2012 12:40 PM

It happened again.
Tue Oct 23, 2012 - 12:33:49 PM EDT

This time I strace'd it.


I have logged out but I have not rebooted.

This cropped up again when I tried to "sudo /usr/sbin/sbopkg" I believe.

vim is broken for myself and root. the vim user it isn't.

sahko 10-25-2012 02:48 AM

gpm is probably your issue as well

Habitual 10-25-2012 11:11 AM


Originally Posted by sahko (Post 4814389)
gpm is probably your issue as well

That 'feature' that I enabled this go-round (but never did in the past)?

Next time it gets stuck, I'll bounce/kill gpm.

Thanks for your time,

I see this thread too...

Habitual 11-07-2012 09:25 AM

It got stuck again, this time I issued

sudo kill $(pidof gpm)
and vim 'magically' returned to 'normal'.

All times are GMT -5. The time now is 10:52 AM.