-   Slackware (
-   -   "Video tearing" with today's -current updates (

TSquaredF 02-11-2011 09:38 PM

"Video tearing" with today's -current updates
Found the new updates on my HD this morning (thanks to AlienBOB & Installed on my desktop (Intel graphics) with no issues, all worked well. Then moved to my laptop (Toshiba Satellite P205D-S7805).

#lspci | grep VGA
01:05.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series]

I use both KDE-4.6 & fluxbox on this laptop, depending on the situation. I use "wally-2.4" to set the wallpaper. On both desktops, the wallpaper displays properly & will switch fine. All of the KDE apps work OK, but LibreOffice, xfe, xscreensaver (among others) would cause the display to "tear" badly. I tried to get a screenshot, but all I could do was Ctrl-Alt-Bkspc to kill X. I did a lot of googling, but found nothing recent. I upgraded to the mesa that is in testing, but while it worked (& is still working), it didn't solve my problem. I figured the problem was the video driver, so downgraded to the xf86-video-ati-6.13.2-x86_64-1 package & that provided stable video.
So, I have "worked around" my problem. Just wanted to report it & hope that someone might have a solution instead of a work around.

Daedra 02-11-2011 09:59 PM

Have you tried enabling vsync? I know with the nvidia driver you can enable it globally, but I believe you can enable for certain individual things like GL screensavers, kwin effects, etc. I always get terrible tearing if I don't enable vsync.

However it is odd than downgrading fixed your problem, so vsync is probably not the culprit, but its worth a look.

TSquaredF 02-11-2011 10:10 PM

Hi,Daedra. Thanks for the response. I can't seem to find a method to "enable vsync". It's not a program, module or option in the kernel config. This is ati (radeon), not nvidia; would that be the difference?

Daedra 02-11-2011 10:39 PM

Are you using the proprietary ATI linux driver? Because I know it can be done with there driver. With opensource ATI drivers I found this page which may have some useful information. I can't really help much because I have never had to deal with ATI under linux.

NoStressHQ 02-11-2011 10:47 PM

I might be totally wrong, and it might be totally unrelated... But have you noticed this ?


"x/xf86-video-ati-6.14.0-i486-1.txz: Upgraded.
      This new driver requires KMS, which is set by default in the new kernel.
      Otherwise, create /etc/modprobe.d/radeon.conf with this content:
      options radeon modeset=1
      Also, the kernel should be booted with vga=normal.
      Problems have been observed when trying to use KMS after starting a VESA
      framebuffer console. Sorry about the penguins."

Edit: And this:


pasture/xf86-video-ati-6.13.2-i486-1.txz: Added.
      Provide an alternate ATI driver in case of problems with the latest one.

dugan 02-11-2011 10:49 PM

Are you running a compositing manager (like Compiz, xcompmgr. etc)? I've found that they cause tearing on my Intel integrated card.

TSquaredF 02-12-2011 11:20 AM

@ Daedra: I'm using the open source radeon driver. I think my graphics chip is no longer supported by the proprietary driver, but I will check that out.

@ NoStressHQ: I was using KMS with the earlier kernels. I did rename /etc/modprobe.d/radeon.conf so that the kernel could start kms prior to my trying the new kernel. I didn't think it would matter, since I had no "vga=XXX" statement in my grub2 stanza, but in desperation, I added "vga=normal". Made no difference. In my first post I stated that using xf86-video-ati-6.13.2-i486-1.txz was the work around I used. Thanks for the suggestions, though.

@ dugan: Nope, no compositing manager. I don't require much eye-candy, except for changing the wallpaper every few minutes, & wally takes care of that.

Anyone else have any ideas?

Chuck56 02-12-2011 12:05 PM


Originally Posted by TSquaredF (Post 4256210)
I did rename /etc/modprobe.d/radeon.conf so that the kernel could start kms prior to my trying the new kernel.

I don't think it matters what a file is named in modprobe.d so renaming radeon.conf to something else doesn't really do anything. Try removing the file from modprobe.d and see if that helps. I just upgraded a 64-current radeon box and had to remove the modprobe.d/radeon.conf file.

dugan 02-12-2011 02:27 PM

If you're using an xorg.conf, then check if it contains the following line. If it does, remove it:


Option "Composite" "Enable"

TSquaredF 02-12-2011 03:54 PM

@ Chuck56: I removed the radeon.conf file from /etc/modprobe.d, but no joy.

@ dugan: Thanks, but not using an xorg.conf.

All times are GMT -5. The time now is 06:55 AM.