LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 02-05-2006, 11:10 AM   #1
beets
LQ Newbie
 
Registered: Aug 2005
Distribution: Mandriva Spring
Posts: 4

Rep: Reputation: 0
Video Error - Undefined Mode on boot


First i'm not sure if this should be here or in newbie, I don't know if it's a slackware related problem or just a general issue.

But what's happening is when I boot get this message
Code:
You passed an undefined mode
Hit <ENTER> to see availible modes or <SPACE> to continue. Or wait 30 seconds.
I was just hitting space because I didn't want to break anything. I looked through rc.d to see if I could find what was causing the error but I couldn't figure it out.

I have tried some of the modes and found one that works for me but how to I make that selection permanent?

Edit: This is happening immedatly at boot.
Code:
Lading Linux.................................
BIOS check sucessful
You passed an undefinded mode
Hit <ENTER> to see availible modes or <SPACE> to continue. Or wait 30 seconds.

Last edited by beets; 02-05-2006 at 12:34 PM.
 
Old 02-05-2006, 12:49 PM   #2
lestoil
Member
 
Registered: Apr 2004
Location: new york
Distribution: win2k,ubuntu,sw13,arch,centos5.3
Posts: 815

Rep: Reputation: 31
When you hit enter what video mode did you pick that worked? It may be entered in /etc/lilo.conf if the vga mode is what you are talking about. When you make change to lilo remember to run /sbin/lilo. Review man lilo for more help.

Last edited by lestoil; 02-05-2006 at 12:50 PM.
 
Old 02-05-2006, 01:29 PM   #3
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
try setting vga=normal in lilo.conf. It always helps.
 
Old 02-06-2006, 08:10 AM   #4
beets
LQ Newbie
 
Registered: Aug 2005
Distribution: Mandriva Spring
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for the info. So I went into lilo.conf and found the mode set to vga=norma, so I changed it to VESA vga. I ran /sbin/lilo and rebooted. No change except where it used to say vga it now says VESA vga.

The options I get when I hit Enter.
Code:
Video Adapter: VESA VGA
Mode:      COLSxROWS
0  0F00     80x25
1  0F01     80x50
2  0F02     80x43
3  0F03     80x28
4  0F04     80x30
5  0F05     80x34
6  0F06     80x60
I've been using option 4. Should I add this to Lilo somewhere? I didn't have much time yesterday to look at the .conf to see if there was a place for it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
UNDEFINED MODE NUMBER error coolblue Linux - Newbie 7 06-10-2006 08:05 AM
No Video in X, Unless ..... Sax2 is ran in failsafe mode on each boot pfx Linux - Newbie 2 06-26-2005 08:09 PM
Video Card boot up error: undefined mode number tt08 Linux - Newbie 1 10-24-2004 09:26 AM
How do I boot into text mode to fix video problem? bass0ssab Linux - Hardware 2 08-29-2003 02:20 PM
I want to boot my redhat8.0 in video mode,how to do it? prad Linux - General 11 12-12-2002 02:38 PM


All times are GMT -5. The time now is 10:29 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration